Solved:Lightspark

If you are looking for a specific 64-bit package and you can't find it in any of the 64-bit repos, please post a request for it here
Post Reply
User avatar
blue4meridian
Shogun
Shogun
Posts: 279
Joined: 29 Sep 2014, 05:58
Distribution: 64bit LxQt (Plastique/Mikachu)
Location: Jersey City N.J. USA

Solved:Lightspark

Post#1 by blue4meridian » 24 Feb 2015, 02:48

Salutations... :good:

This powerful player is not in the USM or pkgs.com repos... :wall:
https://launchpad.net/lightspark/+download

I don't know how to compile... :oops: (yet?)
If anyone has the skill set (and interest) to compile "Lightspark"... please post a download link.

Best Regards... :beer:
Last edited by blue4meridian on 25 Mar 2015, 13:46, edited 4 times in total.

User avatar
phhpro
Full of knowledge
Full of knowledge
Posts: 545
Joined: 10 Nov 2013, 20:35
Distribution: .

Re: Lightspark

Post#2 by phhpro » 24 Feb 2015, 04:58

...
Last edited by phhpro on 04 Feb 2016, 03:01, edited 1 time in total.

User avatar
blue4meridian
Shogun
Shogun
Posts: 279
Joined: 29 Sep 2014, 05:58
Distribution: 64bit LxQt (Plastique/Mikachu)
Location: Jersey City N.J. USA

Re: Lightspark

Post#3 by blue4meridian » 24 Feb 2015, 07:42

Salutations... :good:

I'm interested in Lightspark because I want an FLV player that can be spawned that "fully" supports OpenGl and Llvm.
I prefer to not use a plugin... I prefer to spawn (external play). I'm interested in using Lightspark with QtWeb browser.

Best Regards... :beer:

cttan
Shogun
Shogun
Posts: 332
Joined: 26 Jan 2011, 16:15
Distribution: Porteus 3.2 64bit KDE
Location: Malaysia

Re: Lightspark

Post#4 by cttan » 26 Feb 2015, 04:40

Hi blue4meridian,

You can download gnash and lightspark from usm, slackyonly and pkgs.org.
Convert gnash-0.8.10-x86_64-7_slack.txz to xzm
https://slackonly.com/pub/packages/14.1 ... dia/gnash/

libllvm3.5_3.5-9_amd64.xzm
libstdc++6-4.9.2-4.mga5.x86_64.xzm
glibc-2.20-16.mga5.x86_64.xzm
lightspark-0.7.2-19.mga5.x86_64.xzm
lightspark-mozilla-plugin-0.7.2-19.mga5.x86_64.xzm
lib64lightspark0-0.7.2-19.mga5.x86_64.xzm
http://pkgs.org/

All the rest of the modules from usm.
Pls note that I'm using Porteus 3.1 64bit KDE

Replace /mnt/sdb1/useful_mods_xzm/ with your module folder.
Sample lightspark.sh script:-

Code: Select all

#!/bin/bash
#
activate /mnt/sdb1/useful_mods_xzm/gstreamer-0.10.36-x86_64-2.xzm
activate /mnt/sdb1/useful_mods_xzm/gst-plugins-base-0.10.36-x86_64-2.xzm
activate /mnt/sdb1/useful_mods_xzm/agg-2.5-x86_64-3ponce.xzm
activate /mnt/sdb1/useful_mods_xzm/gnash-0.8.10-x86_64-7_slack.xzm
#
activate /mnt/sdb1/useful_mods_xzm/glibmm-2.36.2-x86_64-1ponce.xzm
activate /mnt/sdb1/useful_mods_xzm/libsigc++-2.3.1-x86_64-1sl.xzm
activate /mnt/sdb1/useful_mods_xzm/libxml++-2.36.0-x86_64-1sl.xzm
activate /mnt/sdb1/useful_mods_xzm/libllvm3.5_3.5-9_amd64.xzm
activate /mnt/sdb1/useful_mods_xzm/ffmpeg-2.4.3-x86_64-1alien.xzm
activate /mnt/sdb1/useful_mods_xzm/libstdc++6-4.9.2-4.mga5.x86_64.xzm
activate /mnt/sdb1/useful_mods_xzm/glibc-2.20-16.mga5.x86_64.xzm
activate /mnt/sdb1/useful_mods_xzm/lightspark-0.7.2-19.mga5.x86_64.xzm
activate /mnt/sdb1/useful_mods_xzm/lightspark-mozilla-plugin-0.7.2-19.mga5.x86_64.xzm
activate /mnt/sdb1/useful_mods_xzm/lib64lightspark0-0.7.2-19.mga5.x86_64.xzm
ln -s /usr/lib64/libboost_filesystem.so.1.54.0 /usr/lib64/libboost_filesystem.so.1.55.0
ln -s /usr/lib64/libboost_system.so.1.54.0 /usr/lib64/libboost_system.so.1.55.0
ln -s /usr/lib64/libGLEW.so.1.9 /usr/lib64/libGLEW.so.1.11
ln -s /usr/lib64/libpng14.so.14 /usr/lib64/libpng16.so.16
ln -s /usr/lib64/libLLVM-3.5.so.1 /usr/lib64/libLLVM-3.5.so
ln -s /usr/lib64/libedit.so.0 /usr/lib64/libedit.so.2
ln -s /usr/lib64/librtmp.so.0 /usr/lib64/librtmp.so.1
mkdir /usr/lib64/lightspark/plugins/
mkdir ~/.cache/lightspark
exit
Test using:-
lightspark /usr/share/gnash/gnash-splash.swf

User avatar
blue4meridian
Shogun
Shogun
Posts: 279
Joined: 29 Sep 2014, 05:58
Distribution: 64bit LxQt (Plastique/Mikachu)
Location: Jersey City N.J. USA

Re: Lightspark

Post#5 by blue4meridian » 27 Feb 2015, 03:09

Salutations... :good:

I could not locate Lightspark for Slackware or Arch @ pkgs.com. The Arch version is preferable.
I try to build most of my bundles with Arch frontends and Slackware dependencies.

Best Regards... :beer:

Posted by 98.109.143.210 via http://webwarper.net
This is added while posting a message to avoid misusing the service

cttan
Shogun
Shogun
Posts: 332
Joined: 26 Jan 2011, 16:15
Distribution: Porteus 3.2 64bit KDE
Location: Malaysia

Re: Lightspark

Post#6 by cttan » 27 Feb 2015, 09:21

Hi blue4meridian,

Just follow my guide and download the packages. Your lightspark would be working.
The lightspark package in pkgs is from Mageia distro.

Post Reply