Navigation arrows missing (solved)

Post bug reports related to either the kiosk ISO or the kiosk wizard here.
Post Reply
mark04
White ninja
White ninja
Posts: 5
Joined: 12 Feb 2015, 16:23
Distribution: 3.2.0
Location: UK

Navigation arrows missing (solved)

Post#1 by mark04 » 12 Feb 2015, 16:34

Hi,

I have just installed the latest version 3.2.0 of Porteus Kiosk, and I'm a little stumped as to how I can show the navigation bar correctly.

In an earlier version that I used (3.1.1) when I selected to show the Navigation Bar (but then disabled the address bar), I could see the forward and back arrows, a refresh icon and the home icon.

In this latest version, with the same settings (nav bar enabled, address bar disabled) all I now see is a home button... I can't seem to get the other navigation to appear.

Am I missing something? Or is this a bug?

Thanks
Mark
Last edited by mark04 on 13 Feb 2015, 14:34, edited 1 time in total.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4565
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Navigation arrows missing

Post#2 by fanthom » 12 Feb 2015, 18:45

firefox 31.x ESR uses new Australis interface which integrated back/forward/refresh buttons directly with URL bar.
unfortunately when you remove URL bar then those buttons are missing ...

'classic theme restorer' addon could be probably used to get them back:
https://addons.mozilla.org/en-US/firefo ... merestorer
http://www.dedoimedo.com/computers/fire ... ralis.html
Please add [Solved] to your thread title if the solution was found.

mark04
White ninja
White ninja
Posts: 5
Joined: 12 Feb 2015, 16:23
Distribution: 3.2.0
Location: UK

Re: Navigation arrows missing

Post#3 by mark04 » 12 Feb 2015, 21:44

Thanks Fanthom.

It's a bit odd having a kiosk where you need to disable the address bar, but then lose the main navigation buttons...

Being a relative newbie to linux and Porteus Kiosk, can you (or anyone else reading this) advise on how I can go ahead and install that 'classic theme restorer'? Would I need to download the iso to a linux PC and 'unISO' it somehow?

Is there any way I can use ssh to connect to a 3.2.0 kiosk and install it that way? Or is there anywhere I can find version 3.1.3 of the porteus kiosk ISO, so I can try that? (I can't seem to find it anywhere)...

Thanks

User avatar
fanthom
Site Admin
Site Admin
Posts: 4565
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Navigation arrows missing

Post#4 by fanthom » 12 Feb 2015, 22:26

maybe you could use 'whitelist' function in the wizard? it's purpose is nearly the same as 'disable address bar' option.

older kiosk versions have known bugs and vulnerabilities so are deleted from the server.
Please add [Solved] to your thread title if the solution was found.

mark04
White ninja
White ninja
Posts: 5
Joined: 12 Feb 2015, 16:23
Distribution: 3.2.0
Location: UK

Re: Navigation arrows missing

Post#5 by mark04 » 12 Feb 2015, 22:58

Thanks Fanthom,

At he moment I have the kiosks pointed at an intranet portal page, which lists the websites I want to give access to. Then I hide the address bar, so they can only get to those sites I list. This means I just have one 'portal' page to maintain. If I expose the address bar, and use a whitelist, then surely I'd have to reinstall each kiosk and update each individual kiosk whitelist every time I wanted to add a website to the kiosk... It'd be a nightmare...

If only I could get firefox back to show the nav buttons, but no address bar, the kiosk would be ideal... :-(

Can anyone suggest a way I can get the nav buttons to show in 3.2.0 (seeing as I cant find the previous version anywhere)? Or how I go about installing the 'classic theme restorer'?

Thanks

User avatar
fanthom
Site Admin
Site Admin
Posts: 4565
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Navigation arrows missing

Post#6 by fanthom » 13 Feb 2015, 08:16

"surely I'd have to reinstall each kiosk and update each individual kiosk whitelist every time I wanted to add a website to the kiosk... It'd be a nightmare..."
should not be the case since next release:
http://porteus-kiosk.org/remote-management.html
(please dont ask me when it will be out)

"how I go about installing the 'classic theme restorer'?"
there is a couple of threads on the forum showing how to integrate addons in kiosk. i have never done Classic Theme Restorer myself so cant give definite answer.
maybe others could share their knowledge in this matter?
Please add [Solved] to your thread title if the solution was found.

tome
Contributor
Contributor
Posts: 562
Joined: 26 Jun 2013, 14:03
Distribution: x64 Openbox
Location: Poland
Contact:

Re: Navigation arrows missing

Post#7 by tome » 13 Feb 2015, 10:38

"how I go about installing the 'classic theme restorer'?"
Go to https://addons.mozilla.org/firefox/addo ... erestorer/ and click "+Add to Firefox" button.

mark04
White ninja
White ninja
Posts: 5
Joined: 12 Feb 2015, 16:23
Distribution: 3.2.0
Location: UK

Re: Navigation arrows missing

Post#8 by mark04 » 13 Feb 2015, 11:19

Thanks tome,

I get that... But how do I get a 'tweaked' version of firefox with the old nav buttons INTO the Porteus Kiosk 3.2.0 ISO?

I have found out how to mount the ISO, and how to unsquash the zxm files, but then I'm not sure how I would go about getting a modified version of firefox across into the ISO.

I'm a linux newbie, and any (simple) help/advice would be gratefully received... Or if someone has a copy of the 3.1.3 kiosk ISO they could give me access to, I would be VERY grateful.

Thanks.
Mark

User avatar
fanthom
Site Admin
Site Admin
Posts: 4565
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Navigation arrows missing

Post#9 by fanthom » 13 Feb 2015, 11:20

i may have solution to this. 'classic theme restorer' may be no needed although stop/refresh buttons wont be visible (only back/forward).
will push an update on the server after some testing.

please watch kiosk Twitter channel for news:
https://twitter.com/porteuskiosk

thanks for reporting.
Please add [Solved] to your thread title if the solution was found.

mark04
White ninja
White ninja
Posts: 5
Joined: 12 Feb 2015, 16:23
Distribution: 3.2.0
Location: UK

Re: Navigation arrows missing

Post#10 by mark04 » 13 Feb 2015, 14:34

Thanks Fanthom,

I have just tried this latest revision and it works beautifully. Thank you for sorting the problem so quickly...much appreciated.

Thanks again.
Mark
:good:

Post Reply