USM error: Brokenman needs to update database.

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
squarefractal
White ninja
White ninja
Posts: 5
Joined: 02 Feb 2015, 13:08
Distribution: -----
Location: -----

USM error: Brokenman needs to update database.

Post#1 by squarefractal » 03 Feb 2015, 17:25

I'm trying to install the ttf-indic-fonts package from USM, but when I select the package from USM and click download, I get the following error:

Code: Select all

Fatal error
LIBS.TXT

Code: Select all

Brokenman needs to update database. Could not find LIBS.TXT
Is this an error on my end, or is this something that the aforementioned community member must resolve?
Thanks in advance.

Bogomips
Full of knowledge
Full of knowledge
Posts: 2536
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: USM error: Brokenman needs to update database.

Post#2 by Bogomips » 03 Feb 2015, 18:38

Hi

It's for him to resolve. Might be worth mentioning once again under USM Bug reports, to bring to his attention.
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

beny
Full of knowledge
Full of knowledge
Posts: 723
Joined: 02 Jan 2011, 11:33
Location: italy

Re: USM error: Brokenman needs to update database.

Post#3 by beny » 03 Feb 2015, 18:55

http://slackbuilds.org/mirror/slackware ... arch-1.txz, hi, you can't use the usm software for downloads the core of slackware,this software is part of x,so if you want other kind of packages you can use usm,maybe you can downloads a whole slackware 32 or 64 and put into one dvd,so you have only check if what you want is inside the disc

User avatar
Ed_P
Contributor
Contributor
Posts: 3152
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

Re: USM error: Brokenman needs to update database.

Post#4 by Ed_P » 03 Feb 2015, 19:08

Bogomips wrote:It's for him to resolve. Might be worth mentioning once again under USM Bug reports, to bring to his attention.
Actually it has been, by a couple of members including me. viewtopic.php?f=117&t=3205&start=255#p31208 Also noted here: viewtopic.php?f=117&t=4313#p31155

Need for a mod to flag the problem as FAA so a dev can see it.
brokenman wrote:Moderators will be expected to answer questions on the forum, remove spam, mark threads as FAA, move topics to relevant categories when posted incorrectly and finally to enter bug reports into our system when they are confirmed as bugs.
Ed

Bogomips
Full of knowledge
Full of knowledge
Posts: 2536
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: USM error: Brokenman needs to update database.

Post#5 by Bogomips » 04 Feb 2015, 12:47

Just done usm -u all. No crash this time. Looks like database has been updated. So, try again. :)
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

User avatar
Ed_P
Contributor
Contributor
Posts: 3152
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

Re: USM error: Brokenman needs to update database.

Post#6 by Ed_P » 04 Feb 2015, 15:25

Code: Select all

usm -u all
sh-4.2# usm -u all
 Starting alien database update 
Downloading: vercheck.txt  DONE
Downloading: CHECKSUMS.md5.gz  DONE
Downloading: MANIFEST.bz2  DONE
Downloading: PACKAGES.TXT.gz  DONE
Downloading: LIBS.TXT.gz  DONE
File verification was good.
Optimizing manifest
 alien  database updated. 

Updating config file

 Starting salix database update 
Downloading: CHECKSUMS.md5  DONE
Downloading: PACKAGES.TXT  DONE
Downloading: LIBS.TXT.gz  DONE
Downloading: OPTIFEST.gz  DONE
 salix  database updated. 

Updating config file

 Starting slacky database update 
Downloading: CHECKSUMS.md5.gz  DONE
Downloading: MANIFEST.bz2  DONE
Downloading: PACKAGES.TXT.gz  DONE
Downloading: LIBS.TXT.gz  DONE
File verification was good.
Optimizing manifest
 slacky  database updated. 

Updating config file

 Starting ponce database update 
Downloading: CHECKSUMS.md5.gz  DONE
Downloading: MANIFEST.bz2  DONE
Downloading: PACKAGES.TXT.gz  DONE
Downloading: LIBS.TXT.gz  DONE
Optimizing manifest
 ponce  database updated. 

Updating config file

 Starting slackware database update 
Downloading: CHECKSUMS.md5  DONE
Downloading: MANIFEST.bz2  DONE
Downloading: PACKAGES.TXT  DONE
Downloading: LIBS.TXT.gz  DONE
File verification was good.
Optimizing manifest
 slackware  database updated. 

Updating config file

 Starting slackwarepatches database update 
Downloading: CHECKSUMS.md5  DONE
Downloading: MANIFEST.bz2  DONE
Downloading: PACKAGES.TXT  DONE
Downloading: LIBS.TXT.gz  DONE
File verification was good.
Optimizing manifest
 slackwarepatches  database updated. 

Updating config file

 Starting sbo database update 
SLACKBUILDS.TXT.gz
Downloading: SLACKBUILDS.TXT.gz  DONE
 sbo  database updated. 

Updating config file


Downloading: extra-deps.txt  DONE
Downloading: ignore-deps.txt  DONE

 You can now close this window 


sh-4.2# 
And when trying to download the alien flash package:

Code: Select all

root@porteus:/home/guest# usm -i flash

 The following items were found.
 Choose an number to confirm. 
 ctrl+c to quit

1) flash-player-plugin-11.2.202.429-x86_64-1sl.txz
2) flash-plugin-11.2.202.440-x86_64-1gv.txz
3) chromium-pepperflash-plugin-16.0.0.296-x86_64-1alien.txz
4) flashplayer-plugin-11.2.202.440-x86_64-1alien.txz
#? 4

Package:  flashplayer-plugin-11.2.202.440-x86_64-1alien.txz  (5212 K) [installed]
flashplayer-plugin: flashplayer-plugin (flash plugin for web browsers)
flashplayer-plugin:
flashplayer-plugin: Provides Adobe Flash plugin for browsers that recognize
flashplayer-plugin: /usr/lib/mozilla/plugins as a valid plugin directory
flashplayer-plugin:
flashplayer-plugin: Plugin is subject to Adobe terms of use: 
flashplayer-plugin:  http://www.adobe.com/go/labs_term_of_use
flashplayer-plugin:
flashplayer-plugin: Plugin is subject to Adobe Flash EULA:
flashplayer-plugin:  http://labs.adobe.com/technologies/eula/flashplayer.html
flashplayer-plugin:

root@porteus:/home/guest# usm -g flashplayer-plugin-11.2.202.440-x86_64-1alien.txz

 Nothing found for:  flashplayer-plugin-11.2.202.440-x86_64-1alien.txz 

root@porteus:/home/guest# usm -g flash

 The following items were found.
 Choose an number to confirm. 
 ctrl+c to quit

1) flash-player-plugin-11.2.202.429-x86_64-1sl.txz
2) flash-plugin-11.2.202.440-x86_64-1gv.txz
3) flashplayer-plugin-11.2.202.438-x86_64-1alien.txz
#? 3

Processing:   flashplayer-plugin-11.2.202.438-x86_64-1alien.txz 
Ignored libraries: libkdeui.so,libkutils.so,libkdecore.so,libQt,

Libraries required:  37
Libraries found in system: 37
Libraries to resolve: 0


awk: cmd. line:1: (FILENAME=- FNR=1) fatal: attempt to access field -1
grep: /etc/usm/mirrors-.txt: No such file or directory
grep: /var/usm//PACKAGES.TXT: No such file or directory
grep: /var/usm//PACKAGES.TXT: No such file or directory

 The following packages are required. 
flashplayer-plugin-11.2.202.438-x86_64-1alien.txz [] [downgrade]

Total size: 0 KB
 Would you like to install the package/s? (custom paths are supported) [y/n] 
Trying to download the alien flash module with the USM GUI gives the LIB.TXT error still.

This needs to be FAA'd.
Ed

Bogomips
Full of knowledge
Full of knowledge
Posts: 2536
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: USM error: Brokenman needs to update database.

Post#7 by Bogomips » 04 Feb 2015, 17:18

@Ed

Unlike your output, usm -g runs error free

Code: Select all

root@porteus:/home/guest# usm -g flash

 The following items were found.
 Choose an number to confirm. 
 ctrl+c to quit

1) flash-player-plugin-11.2.202.359-i386-1sl.txz
2) flash-player-plugin-11.2.202.429-i386-1sl.txz
3) flash-plugin-11.2.202.440-i686-1gv.txz
4) flashplayer-plugin-11.2.202.438-i386-1alien.txz
#? 3

Processing:   flash-plugin-11.2.202.440-i686-1gv.txz 
Ignored libraries: 

Libraries required:  57
Libraries found in system: 57
Libraries to resolve: 0



 The following packages are required. 
flash-plugin-11.2.202.440-i686-1gv.txz [4973K] [not installed]

Total size: 4 MB
 Would you like to install the package/s? (custom paths are supported) [y/n]

 Press [r] to remove packages, [q] to quit, or enter to start downloading.
CLI seems to be working OK. Maybe GUI will have come good, if not USM Bug Reports is still flagged FAA.
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

User avatar
Ed_P
Contributor
Contributor
Posts: 3152
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

Re: USM error: Brokenman needs to update database.

Post#8 by Ed_P » 04 Feb 2015, 17:29

Bogomips wrote: Maybe GUI will have come good, if not USM Bug Reports is still flagged FAA.
The additional info posted in this thread may help in resolving the problem. Is there a limit on how many FAAs a mod can flag about a problem??
Ed

Bogomips
Full of knowledge
Full of knowledge
Posts: 2536
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: USM error: Brokenman needs to update database.

Post#9 by Bogomips » 04 Feb 2015, 17:47

@Ed

It's early days yet, IMHO it's all suck it and see :Search:
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

User avatar
Ed_P
Contributor
Contributor
Posts: 3152
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

Re: USM error: Brokenman needs to update database.

Post#10 by Ed_P » 04 Feb 2015, 22:57

Actually I've already found a solution to my problem, thanks to ElectricQt, I'm just trying to help other users from experiencing the same situation. If that's not important, oh well then. See ya.
Ed

Bogomips
Full of knowledge
Full of knowledge
Posts: 2536
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: USM error: Brokenman needs to update database.

Post#11 by Bogomips » 05 Feb 2015, 12:54

@squarefractal

If you can do CLI, here is the explanation and the workaround.

Code: Select all

root@porteus:/home/guest# usm -s ttf-indic-fonts

ttf-indic-fonts-0.5.14-noarch-1.txz was found in slackware [not installed]
Packages found:   1 

Use:   usm -i <package>  for more info
Use:   usm -g <package>  to download

root@porteus:/home/guest# usm -i ttf-indic

Package:  ttf-indic-fonts-0.5.14-noarch-1.txz  (2908 K) [not installed]
ttf-indic-fonts: ttf-indic-fonts (Fonts for Indic scripts)
ttf-indic-fonts:
ttf-indic-fonts: This is a collection of free fonts that support some of the more
ttf-indic-fonts: widely used Indic scripts.  Included are TTF fonts for Bengali,
ttf-indic-fonts: Devanagari, Gujarati, Kannada, Malayalam, Oriya, Punjabi, Tamil,
ttf-indic-fonts: and Telugu.
ttf-indic-fonts:
ttf-indic-fonts: For more information about enabling full Indic support (this package
ttf-indic-fonts: will enable display, but probably not input), see the
ttf-indic-fonts: Indic-Fonts-HOWTO which can be found in /usr/doc/Linux-HOWTOs.
ttf-indic-fonts:

root@porteus:/home/guest# usm -g ttf-indic-fonts

 Nothing found for:  ttf-indic-fonts 

root@porteus:/home/guest# usm -g ttf-indic-fonts-0.5.14-noarch-1.txz

 Nothing found for:  ttf-indic-fonts-0.5.14-noarch-1.txz 
Now, usm -g <package>, would be expected to work, but I believe it uses a different set of routines, (Already come across a somewhat similar deficiency, and reported it.)

Workaround
  1. Go to http://packages.slackware.com/
  2. Search ttf-indic-fonts
  3. Download package
  4. txz2xzm /<Path to Download>/ttf-indic-fonts-0.5.14-noarch-1.txz
  5. activate /<Path to Download>/ttf-indic-fonts-0.5.14-noarch-1.xzm
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

squarefractal
White ninja
White ninja
Posts: 5
Joined: 02 Feb 2015, 13:08
Distribution: -----
Location: -----

Re: USM error: Brokenman needs to update database.

Post#12 by squarefractal » 05 Feb 2015, 13:54

Okay, got the package installed manually. Many thanks to all those who tried to help me out.

User avatar
Ed_P
Contributor
Contributor
Posts: 3152
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

Re: USM error: Brokenman needs to update database.

Post#13 by Ed_P » 05 Feb 2015, 23:54

@squarefractal

It looks like the USM databases got updated today. The LIBS.TXT error for the alien Flash 440 module didn't occur today in either 3.1 LXQt or 3.01 RazorQt after updating them. :good:
Ed

User avatar
brokenman
Site Admin
Site Admin
Posts: 5456
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: USM error: Brokenman needs to update database.

Post#14 by brokenman » 06 Feb 2015, 02:06

Thanks Bogomips. I can confirm a bug in the way the new automated system generates the OPTIFEST file which leads to this 'not found' error. I will manually generate an update this weekend and see where the problem lies.
How do i become super user?
Wear your underpants on the outside and put on a cape.

Post Reply