Problem with x11vnc

Share your opinion about Porteus Kiosk Edition.
Post Reply
User avatar
Archybaldos
White ninja
White ninja
Posts: 13
Joined: 02 Dec 2014, 17:14
Distribution: FreeBSD, Ubuntu
Location: Europe

Problem with x11vnc

Post#1 by Archybaldos » 29 Jan 2015, 07:59

Hi!
Why not stably x11vnс?
Often after loading the Kiosk vnc says:
Server closed connection
-The server running as application

But half the time it takes password and gives access to the desktop. But after a short time the session is closed and no longer admits to reboot (says: Failed to connect to server, x11vnc crash?).
What could it be?

Porteus-Kiosk-3.2.0-i486
UltraVNC Viewer 1.2.0.3 (Win32)
Local network connect

Thank you for any help!

User avatar
fanthom
Site Admin
Site Admin
Posts: 4546
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Problem with x11vnc

Post#2 by fanthom » 29 Jan 2015, 11:07

never experienced this myself and this is first bug report about x11vnc ...
can anybody confirm this?

when VNC rejects connection - do you have to reboot kiosk or just try connecting again?
Please add [Solved] to your thread title if the solution was found.

User avatar
Archybaldos
White ninja
White ninja
Posts: 13
Joined: 02 Dec 2014, 17:14
Distribution: FreeBSD, Ubuntu
Location: Europe

Re: Problem with x11vnc

Post#3 by Archybaldos » 29 Jan 2015, 11:17

Only after reboot connect established, but for litlle time :(
iptables disabled, windows firewall disabled.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4546
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Problem with x11vnc

Post#4 by fanthom » 29 Jan 2015, 11:22

"Only after reboot connect established, but for litlle time :( "
do i understand correctly that VNC works for some time then vnc server crashes and you have to reboot kiosk to get it working again?
Please add [Solved] to your thread title if the solution was found.

User avatar
Archybaldos
White ninja
White ninja
Posts: 13
Joined: 02 Dec 2014, 17:14
Distribution: FreeBSD, Ubuntu
Location: Europe

Re: Problem with x11vnc

Post#5 by Archybaldos » 29 Jan 2015, 12:00

Yes, exactly.
And after manual closing session also can't connect. After reboot works 6-8 min and crash.
Http request for 192.168.1.2:5900 (kiosk IP) also nothing returns.

Opss. Now I'm have stable disconnect, but http request return "RFB 003.008" :%)
Last edited by Archybaldos on 29 Jan 2015, 12:08, edited 1 time in total.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4546
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Problem with x11vnc

Post#6 by fanthom » 29 Jan 2015, 12:06

ok - will try to reproduce this bug on my side.

thanks a lot for reporting.
Please add [Solved] to your thread title if the solution was found.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4546
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Problem with x11vnc

Post#7 by fanthom » 30 Jan 2015, 21:15

cant reproduce here however i did not test the kiosk for a long time (about 20 mins only).

please enable ssh then login to kiosk and run 'ps' to check if 'x11vnc' process is running. you may also run 'netstat -nl' to check if port 5900 is opened.

please let me know what you have found.
Please add [Solved] to your thread title if the solution was found.

Post Reply