Version 3.1 won't boot on HP Mini 1000

Here you can post about your various experiences with PC hardware. You can also post about hardware that is not compatible with the linux kernel or not recommended for use with Porteus.
Post Reply
advb69
White ninja
White ninja
Posts: 12
Joined: 28 Apr 2014, 12:40
Distribution: Porteus Mate V3
Location: London

Version 3.1 won't boot on HP Mini 1000

Post#1 by advb69 » 03 Jan 2015, 22:12

Hi,

I have used the Mate version of Porteus 3.0 on my HP Mini 1000 netbook and it works fine. I decided to give version 3.1 a go but none of the versions I tried (Mate, XFCE and LXQt) will work.

It gets past Phase I of the boot process but then the screen goes blank. (Its at the point in the process when the text of the bootup process normally changes to the native LCD resolution.) There is a bit more disk activity but the screen remains blank. I can then only power it off. I've tried the text only option but the same thing happens.

I boot from a USB key and tried it on my main PC and my wife's Acer netbook. Version 3.1 boots normally on them.

Any suggestions why 3.0 works but 3.1 wont? The netbook screen has a slightly odd resolution (1024x576).

Thanks!

advb69
White ninja
White ninja
Posts: 12
Joined: 28 Apr 2014, 12:40
Distribution: Porteus Mate V3
Location: London

Re: Version 3.1 won't boot on HP Mini 1000

Post#2 by advb69 » 03 Jan 2015, 22:32

Just a quick update. I downloaded Porteus Kiosk version 3.2 and it booted into the GUI normally. (It didn't recognise the netbook WiFi card but that's a common problem as it is a Broadcom card.)

So the boot problem is only with version 3.1 of standard Porteus but not with 3.0 or the Kiosk version.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4546
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Version 3.1 won't boot on HP Mini 1000

Post#3 by fanthom » 05 Jan 2015, 13:21

this is bit unusual to use kiosk to resolve hardware issues in desktop edition but i'm happy that kiosk can be useful :)

please enable 'debug mode' in kiosk and send me generated report on fanthom@porteus.org as per:
http://porteus-kiosk.org/news.html#150104

thanks
Please add [Solved] to your thread title if the solution was found.

advb69
White ninja
White ninja
Posts: 12
Joined: 28 Apr 2014, 12:40
Distribution: Porteus Mate V3
Location: London

Re: Version 3.1 won't boot on HP Mini 1000

Post#4 by advb69 » 10 Jan 2015, 16:46

Unfortunately, the Kiosk Wizard starts to run but cannot connect to the network. I've tried on my PC and 2 netbooks, both using the wired and WiFi connection options, but it fails. (I've downloaded the Kiosk ISO image twice and tried both from USB and CD with the same result.) So I can't try the debug option on the HP Mini.

But thanks for trying to help.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4546
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Version 3.1 won't boot on HP Mini 1000

Post#5 by fanthom » 11 Jan 2015, 16:30

that's very strange. porteus-kiosk.org must be blocked somehow as i'm newarly sure that all wired drivers are compiled into kernel.

anyway - lets go back to Desktop edition. please boot with 'nomodeset' cheatcode which give you GUI (using VESA driver) or let you booting to the text mode. once you are there please run 'psinfo' command -> upload generated report to pastebin.com -> link here.

thank you
Please add [Solved] to your thread title if the solution was found.

advb69
White ninja
White ninja
Posts: 12
Joined: 28 Apr 2014, 12:40
Distribution: Porteus Mate V3
Location: London

Re: Version 3.1 won't boot on HP Mini 1000

Post#6 by advb69 » 13 Jan 2015, 23:31

Hi,

The "nomodeset" cheatcode gets all versions booting into the GUI so I have run psinfo as requested. I have pasted the output to pastebin with a title "Porteus version 3.1 won't boot on HP Mini 1000 - PSInfo data".

Thanks for all the help so far.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4546
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Version 3.1 won't boot on HP Mini 1000

Post#7 by fanthom » 14 Jan 2015, 09:49

please try this solution:
viewtopic.php?f=81&t=735&p=5619#p5619

you may play with 'acpi_osi=' and 'acpi_backlight=' parameters as well:
https://www.kernel.org/doc/Documentatio ... meters.txt
Please add [Solved] to your thread title if the solution was found.

Post Reply