[SOLVED]How to disable autologin and guest account?

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
arcull
White ninja
White ninja
Posts: 16
Joined: 30 Dec 2014, 16:24
Distribution: Porteus,Ubuntu
Location: Slovenia

[SOLVED]How to disable autologin and guest account?

Post#1 by arcull » 30 Dec 2014, 18:36

Hi everyone there.

I'm a new on here and I've just tried to install porteus on usb key. Everything went smooth and I'm very satisfied with this distro, it boots up very fast, it has the basic apps you need, you can update the packages to stay up to date,etc.... very good job indeed.

However I would like to do a few changes. First of all, the distro on my usb key will be for me only, so this guest account which everyone can potentialy use if he/she gest my key is not a good option in my case. So if anyone knows how to do that it would be grate. I remember in Ubuntu, you had to edit the window manager settings file to do that...I'm not sure how to do it here. Besides it would be nice to have the ability to disable guest account at all levels, I mean not just in X but also in tty, if possible.

Another thing, connected to the first one however, is the autologin, I know there is a kernel startup switch AKA cheatcode, to select the desired user to auto login, but I would prefer none. I would like to create a new user account and login with it manually everytime it OS starts up.

Thanks in advance for your help guys, and a happy new year :beer:
Last edited by arcull on 03 Jan 2015, 20:14, edited 2 times in total.

User avatar
francois
Contributor
Contributor
Posts: 4901
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: How to disable autologin and guest account?

Post#2 by francois » 31 Dec 2014, 04:20

The cheatcode for autologin of guest account is login=guest. So just keep it empty login= and there will be no autologin.

You can change the password of the guest or root account with passwd command. However, you need the changes= cheatcode to keep the changes. See cheatcodes on the first page of this forum.
Voltaire: Le mieux est l'ennemi du bien.

arcull
White ninja
White ninja
Posts: 16
Joined: 30 Dec 2014, 16:24
Distribution: Porteus,Ubuntu
Location: Slovenia

Re: How to disable autologin and guest account?

Post#3 by arcull » 31 Dec 2014, 06:41

Thanks francois, I haven't thought of that option. But I'm not sure what do you mean by
However, you need the changes= cheatcode to keep the changes
If I remember well, I tried for instance add new user with "adduser" command, and even after reboot my user was there and I didn't mess with the cheatcodes at all.

And one more simpel question,I think I don't need to open a new thread for this: what type of encryption (AES,Blowfish...) does the option to encrypt content in porteus in control center offer? I mean, if it is "up to date" and not an old one?

arcull
White ninja
White ninja
Posts: 16
Joined: 30 Dec 2014, 16:24
Distribution: Porteus,Ubuntu
Location: Slovenia

Re: How to disable autologin and guest account?

Post#4 by arcull » 03 Jan 2015, 10:22

So just keep it empty login= and there will be no autologin.
I still can't make this work, I tried all these options:

Code: Select all

login=
login= 
login=""
login=''
The only option seems to enter just any character like this

Code: Select all

login=x
Then it doesn't login cause the user doesn't exist. Has anyone solved this?

beny
Full of knowledge
Full of knowledge
Posts: 720
Joined: 02 Jan 2011, 11:33
Location: italy

Re: How to disable autologin and guest account?

Post#5 by beny » 03 Jan 2015, 10:41

hi, if you can start in init3 the auto login do not run .you have to login manually with root and password and btw you can change password if needed

arcull
White ninja
White ninja
Posts: 16
Joined: 30 Dec 2014, 16:24
Distribution: Porteus,Ubuntu
Location: Slovenia

Re: How to disable autologin and guest account?

Post#6 by arcull » 03 Jan 2015, 10:58

hi, if you can start in init3 the auto login do not run .you have to login manually with root and password and btw you can change password if needed
Ok, that's an option, but would rather boot directly to gui (level 5 if I remember corectly). Ok if I can't make it work, I can live with the

Code: Select all

login=x
solution.

beny
Full of knowledge
Full of knowledge
Posts: 720
Joined: 02 Jan 2011, 11:33
Location: italy

Re: How to disable autologin and guest account?

Post#7 by beny » 03 Jan 2015, 12:02

in porteus cfg located in boot directory i think you can see the option and if you want change it the init 4 is the level for graphic login , init 3 is used by user manual login and if you want you can change desktop environment directly at this level.

arcull
White ninja
White ninja
Posts: 16
Joined: 30 Dec 2014, 16:24
Distribution: Porteus,Ubuntu
Location: Slovenia

Re: How to disable autologin and guest account?

Post#8 by arcull » 03 Jan 2015, 20:11

in porteus cfg located in boot directory i think you can see the option and if you want change it the init 4 is the level for graphic login , init 3 is used by user manual login and if you want you can change desktop environment directly at this level.
Thanks, running to level 3 is without autologin, which is ok, however after login I have to "startx" to get the lxqt, so it is not very convenient way of doing it in my case.

I don't think it is worth complicating with this, I'll stick with my "x user solution", it is good enough :pardon:

User avatar
francois
Contributor
Contributor
Posts: 4901
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: [SOLVED]How to disable autologin and guest account?

Post#9 by francois » 03 Jan 2015, 23:48

@Arcull:

From porteus faq:
http://www.porteus.org/tutorials/26-gen ... -them.html
login=user_name

... Lets you specify the name of the user (could be also 'root')
which will be autologged into GUI session.
If username is not provided then booting stops on the lxdm/kdm
login screen.


It works perfectly for me, leaving the login= (empty). I get the login prompt in graphic mode.

You should have this in the /boot/syslinux/porteus.cfg:

LABEL gui
MENU LABEL Graphics mode (XFCE)
KERNEL vmlinuz
APPEND initrd=initrd.xz changes=/porteus login=
TEXT HELP
...
ENDTEXT

What is your grubloader syntax?
Voltaire: Le mieux est l'ennemi du bien.

arcull
White ninja
White ninja
Posts: 16
Joined: 30 Dec 2014, 16:24
Distribution: Porteus,Ubuntu
Location: Slovenia

Re: [SOLVED]How to disable autologin and guest account?

Post#10 by arcull » 04 Jan 2015, 07:49

thanks francois, this should be the relevant part of my porteus.cfg. As already mentioned, I tried with blank value,and also with one white space...but it just doesn't work.

Code: Select all

LABEL LXQt
MENU LABEL Graphics mode (LXQt)
KERNEL vmlinuz
#APPEND initrd=initrd.xz changes=/porteus timezone=Europe/Ljubljana kmap=si,us
#APPEND initrd=initrd.xz 3 changes=/porteus timezone=Europe/Ljubljana kmap=si,us
APPEND initrd=initrd.xz changes=/porteus timezone=Europe/Ljubljana kmap=si,us login=x
TEXT HELP
    Run Porteus the best way we can.
    Try to autoconfigure graphics
    card and use the maximum
    allowed resolution
ENDTEXT

User avatar
fanthom
Site Admin
Site Admin
Posts: 4546
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: [SOLVED]How to disable autologin and guest account?

Post#11 by fanthom » 05 Jan 2015, 13:25

will check this one. i assume that only LXQt is affected?
Please add [Solved] to your thread title if the solution was found.

arcull
White ninja
White ninja
Posts: 16
Joined: 30 Dec 2014, 16:24
Distribution: Porteus,Ubuntu
Location: Slovenia

Re: [SOLVED]How to disable autologin and guest account?

Post#12 by arcull » 05 Jan 2015, 19:24

thanks fanthom, but worry to much about it, I can live with my simple solution :) I don't know about other desktops, since I tried only lxqt.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4546
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: [SOLVED]How to disable autologin and guest account?

Post#13 by fanthom » 09 Jan 2015, 08:24

'login=' is fixed now for LXQt.
will push to updates next week once i patch other bugs.
Please add [Solved] to your thread title if the solution was found.

Post Reply