KDE games not working[solved]

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
User avatar
Titide21
White ninja
White ninja
Posts: 15
Joined: 29 Dec 2014, 11:54
Distribution: Porteus-v3.1
Location: Mauritius

KDE games not working[solved]

Post#1 by Titide21 » 30 Dec 2014, 13:47

I've installed the module:- 026-KDE_games-4.10.5-i486-1sw.xzm
The games appear on the menu, but whenever try to open one of them, nothing happens.
I've activated:- libkdegames-4.10.5-x86_64-1.xzm as well as kde-baseapps-4.10.5-x86_64-1.txz and all its dependencies.
What more must I do for the games to work? :(
Last edited by Titide21 on 31 Dec 2014, 12:17, edited 1 time in total.

User avatar
francois
Contributor
Contributor
Posts: 5081
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: KDE games not working

Post#2 by francois » 31 Dec 2014, 03:45

What architecture is your porteus installation? You have selected some packages from i486 and others from x86_64. To my knowledge kde games used to function under 64 bit only (x86_64).
Voltaire: Le mieux est l'ennemi du bien.

User avatar
Titide21
White ninja
White ninja
Posts: 15
Joined: 29 Dec 2014, 11:54
Distribution: Porteus-v3.1
Location: Mauritius

Re: KDE games not working

Post#3 by Titide21 » 31 Dec 2014, 09:00

64bit. I'll download the x64 then and try it out.

User avatar
Titide21
White ninja
White ninja
Posts: 15
Joined: 29 Dec 2014, 11:54
Distribution: Porteus-v3.1
Location: Mauritius

Re: KDE games not working

Post#4 by Titide21 » 31 Dec 2014, 12:16

kdegames and kdeedu is now working fine, apart from the KDE help center not being able to launch.
I've activated compatKDE4-libraries-14.1-x86_64-1ftm.xzm
libkdegames-4.10.5-x86_64-1.xzm
kdepimlibs-4.10.5-x86_64-1.xzm
:)

User avatar
francois
Contributor
Contributor
Posts: 5081
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: KDE games not working[solved]

Post#5 by francois » 02 Jan 2015, 07:03

khelpcenter in command line yields no message, this means that your porteus version does not have have this program installed.

To be lean porteus packages are stripped from unnecessary files accoding to this old tchecoslovac strategy (I imagine that a developper will correct this if I am wrong):
http://old.slax.org/documentation_creat ... _rules.php

This means that you will have to intall khelpcenter yourself. One way to do it is to get the khelpcenter rpm package from pkgs.org convert it to xzm and make sure that you have all the needed libraries. I have had a look at it. It does not seem that complicated. Many of the libraries are there already.
Voltaire: Le mieux est l'ennemi du bien.

User avatar
Titide21
White ninja
White ninja
Posts: 15
Joined: 29 Dec 2014, 11:54
Distribution: Porteus-v3.1
Location: Mauritius

Re: KDE games not working[solved]

Post#6 by Titide21 » 03 Jan 2015, 08:45

francois wrote:khelpcenter in command line yields no message, this means that your porteus version does not have have this program installed.

To be lean porteus packages are stripped from unnecessary files accoding to this old tchecoslovac strategy (I imagine that a developper will correct this if I am wrong):
http://old.slax.org/documentation_creat ... _rules.php

This means that you will have to intall khelpcenter yourself. One way to do it is to get the khelpcenter rpm package from pkgs.org convert it to xzm and make sure that you have all the needed libraries. I have had a look at it. It does not seem that complicated. Many of the libraries are there already.
:(
well, i decided not to play games on porteus. I activated the kdeedu modules, and everything launches fine
Then to make the documentation work, i activated khelpcenter-5.0.2-x86_64-1alien.xzm.

Now, here are the modules previously activated on booting:-
guest@porteus:/mnt/sda5/porteus/modules$ ls -a
./ gcc-java-4.8.2-x86_64-1.xzm* lesstif-0.95.2-x86_64-1.xzm* python-2.7.5-x86_64-1.xzm*
../ ghostscript-9.07-x86_64-2.xzm* libaio-0.3.109-x86_64-1.xzm* t1lib-5.1.2-x86_64-3.xzm*
at-spi2-atk-2.8.1-x86_64-1.xzm* gnutls-3.1.16-x86_64-1.xzm* libkdegames-4.10.5-x86_64-1.xzm* tcl-8.6.1-x86_64-1.xzm*
at-spi2-core-2.8.0-x86_64-1.xzm* gst-plugins-base-0.10.36-x86_64-2.xzm* liblinebreak-2.1-x86_64-1dj.xzm* tetex-3.0-x86_64-8.xzm*
djview4-4.9-x86_64-1_slack.xzm* gstreamer-0.10.36-x86_64-2.xzm* libspectre-0.2.7-x86_64-1.xzm* tetex-doc-3.0-x86_64-8.xzm*
emacs-24.3-x86_64-3.xzm* gtk+3-3.8.2-x86_64-2.xzm* libunistring-0.9.3-x86_64-1.xzm* tk-8.6.1-x86_64-1.xzm*
fbreader-0.12.10-x86_64-2ponce.xzm* guile-2.0.9-x86_64-1.xzm* libvisual-0.4.0-x86_64-3.xzm* xpdf-3.03-x86_64-3.xzm*
fftw-3.3.3-x86_64-1.xzm* ilmbase-1.0.3-x86_64-1.xzm* mariadb-5.5.32-x86_64-1.xzm*
gc-7.2d-x86_64-1.xzm* jasper-1.900.1-x86_64-3.xzm* openexr-1.7.1-x86_64-1.xzm*
gcc-gfortran-4.8.2-x86_64-1.xzm* krb5-1.12-x86_64-1sl.xzm* p11-kit-0.16.4-x86_64-1.xzm*


note: i know that for khelpcenter to work, it needs (1) kdelibs-4.10.5-x86_64-2.xzm and (2) kde-runtime-4.14.3-x86_64-1alien.xzm and (3)soprano-2.9.0-x86_64-1.xzm
i activate soprano-2.9.0-x86_64-1.xzm

however, putting (1) and (2) in the directory /mnt/sda5/porteus/modules/ to get activated on startup, completely locks me out of porteus. so i decided to put them in /tmp/usm/ so as to activate them when i need them.

I am well aware of a compatKDE4-libraries-14.1-x86_64-1ftm.xzm for the replacement of kdelibs-4.10.5-x86_64-2.xzm.


now, i activate kde-runtime-4.14.3-x86_64-1alien.xzm, i launch kstars, from kstars, i launch its handbook, it doesn't work because it needs the kdelibs or compatekde4libs to run.

from there, when i activate kdelibs, my start menu doesn't show any icons in the applications tab, but on launching the documentation, it works.

alternatively, when i activate compatkde4libs, no disruption of my start menu, but this appears in the documentation:-The requested help file could not be parsed:<br/>/usr/share/doc/HTML/en//kstars/index.docbook

i just confirmed where the bug arises by putting kde-runtime-4.14.3-x86_64-1alien.xzm,
kdeedu-4.4.3-x86_64-1.xzm,
khelpcenter-5.0.2-x86_64-1alien.xzm and compatKDE4-libraries-14.1-x86_64-1ftm.xzm
in the modules directory to get activated on startup. the login works fine, but the documentation stills shows:- The requested help file could not be parsed:<br/>/usr/share/doc/HTML/en//kbruch/index.docbook (another program's documentation to confirm it bugs)

but if i activate kdelibs in /tmp/usm/ and (remove compatkde4 from the modules directory in another reboot) then the documentation will work, but the icons in the start menu will dissappear.

:Search: it seems one can't solve the problem, it creates another. the best option for me now, is to put kdelibs in /tmp/usm/ and activate it when i need the documentation, so that it doesn't affect my logging in on porteus, even if i don't see the icons in applications tab on the start menu.

Post Reply