Warnings in Firefox - Flash vulnerable. Adobe FLASH blocked

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
ElectriQT
Samurai
Samurai
Posts: 116
Joined: 10 Nov 2013, 12:02
Distribution: LXDE3.5Manjaro, LXDE3.01-32bit
Location: Sweden

Warnings in Firefox - Flash vulnerable. Adobe FLASH blocked

Post#1 by ElectriQT » 12 Dec 2014, 20:48

Besides the massive DDOS on Sweden's infrastructure and IP-television.. Now we cant even see TV on "Web-PLAY"

During the almost nationwide attacks this week Many have changed DNS to "googletracker" at 8.8.8.8 , or the preferred open DNS 208.67.222.222 etc. Yes that did help a bit, as this week from time to time it has been impossible to reach sites at all,

You must go trough a direct IP-number..
or change the DNS to someone that is not under attack at the moment, :x
Most people dont have so many clean IP:s to their sites in the bookmarks, So they could not even search for help, maybe not even call.. or watch the news.. Even security-alarms for disabled or old people went dead. And probably our maps for the fire-department mobile units, and so on..
Not so good. But can be a Good lesson to learn for this country, ..maybe.

I have this new situation, in 2 different computers here now. Some hours ago it was no problem:
https://forums.opensuse.org/showthread. ... vulnerable
[ running LXDE 301, ]

No updates available in PorteusSettingsCenter.

I have Never seen a block like this before on youtube

Mozilla says it IS up to date.. :wall:
http://paste.opensuse.org/view/raw/9563817

dont you all have this problem now in 3.01?

User avatar
fanthom
Site Admin
Site Admin
Posts: 4623
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Warnings in Firefox - Flash vulnerable. Adobe FLASH bloc

Post#2 by fanthom » 12 Dec 2014, 21:48

please update flash through USM and warning should be gone.
Please add [Solved] to your thread title if the solution was found.

ElectriQT
Samurai
Samurai
Posts: 116
Joined: 10 Nov 2013, 12:02
Distribution: LXDE3.5Manjaro, LXDE3.01-32bit
Location: Sweden

Re: Warnings in Firefox - Flash vulnerable. Adobe FLASH bloc

Post#3 by ElectriQT » 12 Dec 2014, 21:54

We have the Same problem in the new XFCE 3.1 !

It DID work, Played one video 1 time at YouTube. Then ALL flash was blocked everywhere on all sites in my next tests.

( I added the latest of the plugins Noscript, and updated ghostery to be sure it was not some webjunk causing this problem. Even with-out Noscript plugin we have the same problem)

User avatar
brokenman
Site Admin
Site Admin
Posts: 5652
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Warnings in Firefox - Flash vulnerable. Adobe FLASH bloc

Post#4 by brokenman » 12 Dec 2014, 22:59

We have the Same problem in the new XFCE 3.1 !
The problem will be the same in ALL desktops because the flash plugin is in the browser modules. Did the update through USM work? It seems an update was released days after Porteus was released.
How do i become super user?
Wear your underpants on the outside and put on a cape.

ElectriQT
Samurai
Samurai
Posts: 116
Joined: 10 Nov 2013, 12:02
Distribution: LXDE3.5Manjaro, LXDE3.01-32bit
Location: Sweden

Re: Warnings in Firefox - Flash vulnerable. Adobe FLASH bloc

Post#5 by ElectriQT » 13 Dec 2014, 00:19

Thanks for reply,

Nope, I always used "update" in the PorteusSettingsCenter, but there is no updates,
so I assumed there was no updates :-) to our modules/system, ..yet

and as Mozilla says flashplayer indeed *is* up to date,. I then got even more confused.. :unknown:

+ Mozilla on the plugincheck-page says that my New Firefox ESR 31.3 in fresh Porteus 3.1 is *outdated* already after a fev days, and needs to be upgraded... then I gave up any hope to try to understand this mess, ...and changed over to html5 video-player instead..

:-)

ElectriQT
Samurai
Samurai
Posts: 116
Joined: 10 Nov 2013, 12:02
Distribution: LXDE3.5Manjaro, LXDE3.01-32bit
Location: Sweden

Re: Warnings in Firefox - Flash vulnerable. Adobe FLASH bloc

Post#6 by ElectriQT » 13 Dec 2014, 00:47

@Fantom / Brokenman
No, It was the new firefox-module, using 3.1 XFCE now.

And Probably Im to stupid to understand how to use USM for security push-stuff.

- how would it indicate all updates, there in USM?

Should it show me in some way what installed things that needs to be fixed today?
I Cant find that.

And I thought that all core stuff, things that live in our original modules would be updated trough the "update" button in the normal PorteusSettingsCenter-program, if not, when will *that* be used?

Also, Im now sure that I do not understand why(if?) it is old stuff in the new release, I understand if we/you miss it, no problem, but now that we do know, why continue to send out a broken ffox package to all that want to upgrade/replace the module with a working and safe one?

(I mean if it is a totally blocked flash. and may be also Mozilla, as they tells us that the browser needs update, "this ESR is old" or someting like that, -but hmm, is it really ? I thought I checked this 3 days ago and it was back then a lower number in LXDE 301, and at that time there was no updates in PSC. And also I did check in Firefox, "about","check for updates", it was also the latest, not to many days ago, is it not working OK any more?.

And I also cant find the newer ones now, if there are any.. :-)
Who knows. Its just a mess by Mozilla now? As they say the blocked flash is ok also, but FFox is not.



So, is that update and info-stuff also an error? ...Or just another "new to linux"-user-error again By me? Hehe, living bug-magnet.

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 1019
Joined: 20 Mar 2012, 03:42
Distribution: 3.2.2-64bit xfce/openbox
Location: australia
Contact:

Re: Warnings in Firefox - Flash vulnerable. Adobe FLASH bloc

Post#7 by ncmprhnsbl » 13 Dec 2014, 03:50

just did an update of flash through usm (using alien-11.2.202.425)
problem is firefox is looking for its plugins in /usr/lib not
/usr/lib64 (which is where flash puts em).
i just put a symlink in <mkdir> /usr/lib/mozilla/plugins
and this works.

maybe this is an esr thing,
either lagging behind firefox main or as a security measure

not sure if this will help with any web attacks.
Forum Rules : http://forum.porteus.org/viewtopic.php?f=35&t=44

ElectriQT
Samurai
Samurai
Posts: 116
Joined: 10 Nov 2013, 12:02
Distribution: LXDE3.5Manjaro, LXDE3.01-32bit
Location: Sweden

Re: Warnings in Firefox - Flash vulnerable. Adobe FLASH bloc

Post#8 by ElectriQT » 13 Dec 2014, 12:45

ncmprhnsbl wrote:just did an update of flash through usm (using alien-11.2.202.425)
problem is firefox is looking for its plugins in /usr/lib not
/usr/lib64 (which is where flash puts em).
i just put a symlink in <mkdir> /usr/lib/mozilla/plugins
and this works.

maybe this is an esr thing,
either lagging behind firefox main or as a security measure

not sure if this will help with any web attacks.
Hi ,
-Hmm, No I dont understand how it was meant to be,
but it seems to me, ..to be a total mess and needs heavy cleaning to follow some "standard", I assume.. :-)
But maybe the "total mess" are the general Linuxes-standards to follow? ;-)

( I use 32bit Porteus only, as BankID ... this stupid but ultrasupermegaimportant program for all Sweeds to have an idenity and be able to work/be sick/insuranse/TaxReporting/start a company and so on and on.., that "security" program cant work on 64bit they say. It also requires firefox 2 or 3.x to install. Will try harder to understand that install script later, will be a different thread.. )



Today I Finaly got some search answer in the GUI-USM :Yahoo!:
(chose "packages", as the other one say: "to many results to display").
I did a search for packages and "flash" -wooha..!
So This is probably the first time ever for me to find anything at all in USM. (..but there is no updates, the installed one seems to be the latest.. And The installed one is Blocked at all sites now. )

So What did I do wrong with USM?
Not only can you close the update-window after updating all, it seems that you NEED to close the USM program and re-open it again!
(probably that is 101% normal? Well..normal when you KNOW that :-)

(Brokenman is this correct? This was the only thing I can imagine I did now that I *might* not have done before in all the times i have tried USM, it seems like the program can not load or reload the downloaded databases, needs a restart to read files?)


But the one you installed, that is the current one(and the blocked one) , it was installed in 3.1 by default( it seems. Now Im running XFCE 3.1 32bit) (Hard to know if this ".425"-number is "new" ..or very old?, as they did forgot to put the releasedates in the filename, or in description. it seems.. but anyway, it is the already installed one, it says. So no new updates exists there. )

-or.. am I "doing it wrong" again?
:sorry:

tome
Contributor
Contributor
Posts: 574
Joined: 26 Jun 2013, 14:03
Distribution: x64 Openbox
Location: Poland
Contact:

Re: Warnings in Firefox - Flash vulnerable. Adobe FLASH bloc

Post#9 by tome » 13 Dec 2014, 16:27

Probably because current flash player for Linux is "older" than current for Windows. Did you change Firefox user agent?

User avatar
fanthom
Site Admin
Site Admin
Posts: 4623
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Warnings in Firefox - Flash vulnerable. Adobe FLASH bloc

Post#10 by fanthom » 13 Dec 2014, 19:32

just checked and USM has only version 424 so brokenman must update USM database.
please do as follows:

a) download manually from here:
http://www.slackware.com/~alien/slackbu ... er-plugin/
b) convert to xzm
c) put in /porteus/modules and activate or do a reboot

thanks
Please add [Solved] to your thread title if the solution was found.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5652
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Warnings in Firefox - Flash vulnerable. Adobe FLASH bloc

Post#11 by brokenman » 13 Dec 2014, 22:34

Fanthom, I am pretty sure the USM database is up to date. ncmprhnsbl above used it to download the file and yesterday I did too.

ElectriQT I will check the thing about closing the app in order to read the new database. It's odd since the database files are separate from the program. The program just reads them.
How do i become super user?
Wear your underpants on the outside and put on a cape.

ElectriQT
Samurai
Samurai
Posts: 116
Joined: 10 Nov 2013, 12:02
Distribution: LXDE3.5Manjaro, LXDE3.01-32bit
Location: Sweden

Re: Warnings in Firefox - Flash vulnerable. Adobe FLASH bloc

Post#12 by ElectriQT » 13 Dec 2014, 23:18

brokenman wrote:Fanthom, I am pretty sure the USM database is up to date. ncmprhnsbl above used it to download the file and yesterday I did too.

ElectriQT I will check the thing about closing the app in order to read the new database. It's odd since the database files are separate from the program. The program just reads them.

Ok, so probaby it IS me .
"doing it wrong", :-) Im good at that..

http://www.adobe.com/software/flash/about/ Says:
"You have version 11,2,202,424 installed" = NOT up to date.

But USM says:
.425-i386-1alien , installed" = Up to date

So .425 alien = the same as the ".424 normal" = so all ".425 aliens" are therefore not up to date?? Hehehe, well,
-No, I dont think so

But Firefox says it is the new one we have in Poerteus 3.1 , the real .424 that we all have(?), and that it is the latest and there are no updates...,
https://www.mozilla.org/en-US/plugincheck/
So they say it is up to date.. So Therefore they block it..! :%)

And.. they also say:
"Looks like you’re using an older version of Firefox. [Update to stay fast and safe].

:beer:

It is multiple errors, in many dimensions and levels.., it is mainly a Firefox-crewscrew-up , I guess,
The main reason to this fail is not Porteus. It just looks that way now....

My personal thoughts on this:
- I think the best thing to do now is to re-release the 3.1 and the firefox-module with the "real" new flash inside, as this will be a nightmare to explain to all new users how to fix, not good PR or experience as their first contact with Linux.., what do you guys think?

ElectriQT
Samurai
Samurai
Posts: 116
Joined: 10 Nov 2013, 12:02
Distribution: LXDE3.5Manjaro, LXDE3.01-32bit
Location: Sweden

Re: Warnings in Firefox - Flash vulnerable. Adobe FLASH bloc

Post#13 by ElectriQT » 13 Dec 2014, 23:36

brokenman wrote:Fanthom, I am pretty sure the USM database is up to date. ncmprhnsbl above used it to download the file and yesterday I did too.

ElectriQT I will check the thing about closing the app in order to read the new database. It's odd since the database files are separate from the program. The program just reads them.
Are USM lagging one update behind then?

As I got no results(in a clean start, new iso, still missing the stuff in "the" db after update. (reading from the old empty one?) )
and Fanthom gets latest updates, ... -1
:-)

I know nothing about Linux and programming, but If I could do something I would try to close/flush all the current db-files after the successful "update all"-procedure in the GUI-USM, Let the program then reopen them all, and re-read the files, so no restart will be needed ?

User avatar
brokenman
Site Admin
Site Admin
Posts: 5652
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Warnings in Firefox - Flash vulnerable. Adobe FLASH bloc

Post#14 by brokenman » 14 Dec 2014, 01:33

Using firefox as guest reports incorrect versions. Running it as root (which I don't recommend) is showing correct versions for. Need to dig further.
How do i become super user?
Wear your underpants on the outside and put on a cape.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5652
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Warnings in Firefox - Flash vulnerable. Adobe FLASH bloc

Post#15 by brokenman » 14 Dec 2014, 01:43

As a test could someone please update flash plugin to .425.

Close firefox
Open it again and check your version here:
https://www.adobe.com/software/flash/about/

Now start firefox from a root terminal and visit the same page above.

Disregard the above. During copying I had copied a testing flashplayer library and screwed up something.
I just downloaded the latest firefox module from the porteus server. Booted into fresh mode.
https://www.adobe.com/software/flash/about showed me .424

Updated to .425 with USM and the same website now shows the correct version.
How do i become super user?
Wear your underpants on the outside and put on a cape.

Post Reply