LXQT forum???

Get help with LXQt specific problems
User avatar
fanthom
Site Admin
Site Admin
Posts: 4618
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: LXQT forum???

Post#16 by fanthom » 05 Jan 2015, 13:24

i'm sorry - i have tested it under guest only. will check root's account this evening.

thanks for reporting.
Please add [Solved] to your thread title if the solution was found.

User avatar
francois
Contributor
Contributor
Posts: 5081
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: LXQT forum???

Post#17 by francois » 06 Jan 2015, 01:01

Thanks for looking at it. :)

On a precedent issue, where we tried to save the desktop, I got some partial solution. I can get some personnally tailored desktop setting for lxqt with the use of the guiexec cheatcode. The use of scripts is also handy.
Voltaire: Le mieux est l'ennemi du bien.

User avatar
francois
Contributor
Contributor
Posts: 5081
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: LXQT forum???

Post#18 by francois » 06 Jan 2015, 18:01

src2pkg in root mode there is an error message:

Code: Select all

/usr/bin/xterm: Can't execvp 'echo: Bo such file or directory
root@porteus:~#
Thanks.
Voltaire: Le mieux est l'ennemi du bien.

ElectriQT
Samurai
Samurai
Posts: 116
Joined: 10 Nov 2013, 12:02
Distribution: LXDE3.5Manjaro, LXDE3.01-32bit
Location: Sweden

Re: LXQT forum???

Post#19 by ElectriQT » 07 Jan 2015, 10:29

Hmm, ?
Here the panel icon DO start usm,
(running 32 bit, in "always fresh"-mode)

But I cant take screenshots by the button, only by the menu-way
(the prt sc-button dont work in LXQT, but I think it does ion LXDE)

And when I try to save a shot to the usbstick system say
"cant mount, only system administrators can do that" or a similar text,
(sda1 = the usb stick here. have no hdd)

So a leftclick OR rightclick "mount" here on the usb boot -stick (sda1) give me: "Only system admins have the permission to do this"
(But No box to fill in the passwd..)


and when i try to "open as root" from
"tool, "open as root" from the FM-menu,"
then here I finally did get a passwd popup!,
And I here provide the passwd, and .... then nothing changes, im still guest in PcmanFM, :wall:

So always-fresh-mode is pretty useless if we cant access the usb-stick/disks.. ?

User avatar
francois
Contributor
Contributor
Posts: 5081
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: LXQT forum???

Post#20 by francois » 09 Jan 2015, 22:06

The icon in the lxqt panel will not start the usm gui. It has to be started thru command line, which will start the usmgui frontend.Only in root mode (tested in always fresh mode).
Is it normal to have in root mode /usr/share/applications/usm.desktop file:

Code: Select all

Exec=/opt/porteus-scripts/xorg/psu /usr/bin/usmgui
instead of only

Code: Select all

/usr/bin/usmgui
With /usr/bin/usmgui only usmgui will start from the icon on the panel root mode.
Voltaire: Le mieux est l'ennemi du bien.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4618
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: LXQT forum???

Post#21 by fanthom » 11 Jan 2015, 19:11

that works - thanks a lot francois :)
Please add [Solved] to your thread title if the solution was found.

User avatar
francois
Contributor
Contributor
Posts: 5081
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: LXQT forum

Post#22 by francois » 15 Jan 2015, 20:14

Same problem with porteus-setting-center. Please replace in /usr/share/applications/porteus-setting-center:

Code: Select all

Exec=/opt/porteus-scripts/xorg/psu /opt/porteus-scripts/porteus-settings-centre
by

Code: Select all

Exec=/opt/porteus-scripts/porteus-settings-centre
Same problem for :
porteus-installer
porteus-save-file-manager
porteus-system-info
mount-manager

pcmanfm-super-user-mode
-lxterminal -e "pcmanfm-qt" works
mount manager
-mount manager works
Last edited by francois on 15 Jan 2015, 20:35, edited 1 time in total.
Voltaire: Le mieux est l'ennemi du bien.

User avatar
francois
Contributor
Contributor
Posts: 5081
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: LXQT forum???

Post#23 by francois » 15 Jan 2015, 20:34

This script does not work under lxqt:

Code: Select all

root@porteus:~# /opt/porteus-scripts/xorg/browser
root@porteus:~#


I like this script. It should be very useful, once functional under lxqt.

This is why to get porteus-FAQ:

Code: Select all

/opt/google/chrome/google-chrome /usr/doc/Porteus-FAQ/index.html
will work better than

Code: Select all

/opt/porteus-scripts/xorg/browser /usr/doc/Porteus-FAQ/index.html (From the panel menu)
which does not work at all.
Voltaire: Le mieux est l'ennemi du bien.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4618
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: LXQT forum???

Post#24 by fanthom » 16 Jan 2015, 20:45

browser script calls 'chrome' while this application is called now 'google-chrome' or 'google-chrome-stable'.
will push an update with a fix next week.
Please add [Solved] to your thread title if the solution was found.

User avatar
francois
Contributor
Contributor
Posts: 5081
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: LXQT forum???

Post#25 by francois » 17 Jan 2015, 16:02

Another problem: /root/.config/lxqt/autostart.conf does not work. Tested with instructions to start leafpad:

Code: Select all

@leafpad
This lxqt/autostart problem was reported the 9th of may 2014 on archlinux:
https://aur.archlinux.org/packages/lxqt ... mments=all

There is no way to come back from the extended view once it has been applied other than using xrandr commands:
lxqt panel menu > preferences > lxqt system settings > monitor settings > quick options > extended view

What about all the lxqt menu items that are not functional? This seems to make porteus lxqt a very imperfect desktop. Isn't it?
Thanks.

I could report directly to the lxqt forum if this could help. :)
https://github.com/lxde/lxqt/issues
Voltaire: Le mieux est l'ennemi du bien.

User avatar
francois
Contributor
Contributor
Posts: 5081
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: LXQT forum???

Post#26 by francois » 18 Jan 2015, 13:08

Impossible to delete files with pcmanfm-qt. =@
I have to resort to mc command line.

What the trick???
Thanks. :)
Voltaire: Le mieux est l'ennemi du bien.

User avatar
Ed_P
Contributor
Contributor
Posts: 3325
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

Re: LXQT forum???

Post#27 by Ed_P » 18 Jan 2015, 13:53

francois wrote:Impossible to delete files with pcmanfm-qt. =@
I have to resort to mc command line.

What the trick???
viewtopic.php?f=132&t=4212#p30361
Ed

User avatar
francois
Contributor
Contributor
Posts: 5081
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: LXQT forum???

Post#28 by francois » 27 Jan 2015, 22:54

@fanthom:
lxqt-runner (the run in the menu of slackermagic):
viewtopic.php?f=132&t=4243&p=31056#p31056
will yield the following error message:

Code: Select all

root@porteus:~# lxqt-runner
dbusCall: QDBusInterface is invalid "org.freedesktop.login1" "/org/freedesktop/login1" "org.freedesktop.login1.Manager" "CanHibernate" 
dbusCall: QDBusInterface is invalid "org.lxqt.session" "/LxQtSession" "org.lxqt.session" "canLogout" 
Ind i setFilter... 
dbusCall: QDBusInterface is invalid "org.freedesktop.login1" "/org/freedesktop/login1" "org.freedesktop.login1.Manager" "CanHibernate" 
dbusCall: QDBusInterface is invalid "org.lxqt.session" "/LxQtSession" "org.lxqt.session" "canLogout"
Voltaire: Le mieux est l'ennemi du bien.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4618
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: LXQT forum???

Post#29 by fanthom » 28 Jan 2015, 12:41

its rather harmless, press Alt+F2 to start the runner.
i'll create desktop launcher for it in next update push.

thanks
Please add [Solved] to your thread title if the solution was found.

User avatar
francois
Contributor
Contributor
Posts: 5081
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: LXQT forum???

Post#30 by francois » 29 Jan 2015, 01:15

Thanks. This is appreciated.
Voltaire: Le mieux est l'ennemi du bien.

Post Reply