A stupid little "df -h" puzzle I cannot explain

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
Post Reply
att
Contributor
Contributor
Posts: 131
Joined: 28 Dec 2010, 17:09

A stupid little "df -h" puzzle I cannot explain

Post#1 by att » 26 Nov 2014, 15:05

Hello everyone!

I am using "porteus 3.13.6-porteus #1 SMP PREEMPT..." (Porteus 3.0, 64bit).

df -h says:

bash-4.2# df -h
Filesystem Size Used Avail Use% Mounted on
aufs 2.4G 296M 2.1G 13% /
devtmpfs 2.0G 0 2.0G 0% /dev
/mnt/live/run 2.0G 859M 1.1G 44% /run ; -> so I thought "hmmmm. 859 MB RAM wasted on "/run" ? Just after booting? "

Lets examine this:

cd /run
du -h .

(..........)

0 ./udev/links/disk\x2fby-id\x2fata-Hitachi_HD(.............something)
0 ./udev/links/input\x2fby-path\x2fplatform-i8042-serio-1-event-mouse
0 ./udev/links/mouse
0 ./udev/links/input\x2fby-path\x2fplatform-i8042-serio-1-mouse
0 ./udev/links/rtc
0 ./udev/links/input\x2fby-path\x2fplatform-i8042-serio-0-event-kbd
0 ./udev/links
896K ./udev/data
904K ./udev
12K ./blkid
916K .

I am puzzled. 916 KB. Not 859 MB used. (???)
What is going on?
Any explanation?

Is this a bug, or a feature? :)

Anyway, 859 MB might be all my 72 or so modules. Is this related in any way?
Please help me to clear up my misunderstanding. Thanks!

Post Reply