3.0.1 x86-64 - mount: unknown filesystem type 'exfat'

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
Post Reply
User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

3.0.1 x86-64 - mount: unknown filesystem type 'exfat'

Post#1 by Rava » 26 Oct 2014, 11:28

3.0.1, XFCe edition, x86-64

I have a new SDXC 64 GB card (my first XC card even!). The card reader seems to work fine.
This is what I get in /var/log/messages:

Code: Select all

porteus kernel: [113417.392059] usb 2-2.1: new full-speed USB device number 22 using uhci_hcd
porteus kernel: [113417.510141] usb-storage 2-2.1:1.0: USB Mass Storage device detected
porteus kernel: [113417.526243] scsi19 : usb-storage 2-2.1:1.0
porteus kernel: [113418.533084] scsi 19:0:0:0: Direct-Access     Generic  STORAGE DEVICE   0207 PQ: 0 ANSI: 0
porteus kernel: [113418.824066] sd 19:0:0:0: [sdb] 3862528 512-byte logical blocks: (1.97 GB/1.84 GiB)
porteus kernel: [113418.829058] sd 19:0:0:0: [sdb] Write Protect is off
porteus kernel: [113418.863078]  sdb: sdb1
porteus kernel: [113418.896080] sd 19:0:0:0: [sdb] Attached SCSI removable disk
porteus kernel: [113608.198639] sdb: detected capacity change from 1977614336 to 0
porteus kernel: [113613.827091] sd 19:0:0:0: [sdb] 124735488 512-byte logical blocks: (63.8 GB/59.4 GiB)
porteus kernel: [113613.877122]  sdb: sdb1
And I get an error message telling me exfat is unknown to mount when trying to mount it via XFCe/Thunar.

Trying to mount as root in console/terminal I get this info:

Code: Select all

mount: unknown filesystem type 'exfat'
What is needed to get mount to support exfat?
Cheers!
Yours Rava

User avatar
fanthom
Site Admin
Site Admin
Posts: 4586
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: 3.0.1 x86-64 - mount: unknown filesystem type 'exfat'

Post#2 by fanthom » 26 Oct 2014, 21:03

compile these two (quite old so maybe get latest version from google code page):
http://slackbuilds.org/result/?search=exfat&sv=14.1

and mind:

Code: Select all

Keep in mind, that it might be illegal to use this software in
countries respecting US-Patents.
Please add [Solved] to your thread title if the solution was found.

User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Re: 3.0.1 x86-64 - mount: unknown filesystem type 'exfat'

Post#3 by Rava » 03 Jan 2015, 04:49

I was able to get it working, but since the move to 3.1, including the rc's I have to search on which boot media I saved the exfat module.

When I find it I check if it is also working with 3.1, post the results and change the thread title to [solved]
Cheers!
Yours Rava

Post Reply