X86_64 unable to use JRE with openoffice

Non release banter
Post Reply
blablotin
Black ninja
Black ninja
Posts: 67
Joined: 04 Jan 2011, 22:59
Location: Euro

X86_64 unable to use JRE with openoffice

Post#1 by blablotin » 01 Apr 2011, 21:27

Hello,
While I am on Porteus x86_64
I would like to use a favorite add-on for open office called LanguageTool-1.3.1.
but this add-on need a JRE environment to be installed, so I downloaded the module jre-6u24-x86_64-1 from a slacky repo, and then run open office to add this extension, but I get this error message even after the ldconfig, and the reboot. even when I am logued as "ROOT"

Image

So I try to go to tool -> option -> java.
The case use java environement is enabble but the list of installed java environment is empty. and when I choose add, it is impossible to find a path to The right file/folder, it always stay empty. (I have tried reccursively lib64, /usr/lib64, usr/lib64/)

Moreover, in porteus 32 bit I just had to install jre-6u20-i586-1 and open office could install LanguageTool. So I don't understand.

What do I have to do to make openoffice be abble to see jre in 64 bits OS?
why is it different from the 32 bits OS althought I only have 64 bits modules?

User avatar
fanthom
Site Admin
Site Admin
Posts: 4590
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: X86_64 unable to use JRE with openoffice

Post#2 by fanthom » 02 Apr 2011, 07:16

i would like to try it on my PC. where can i get the packages?
please provide download links.
Please add [Solved] to your thread title if the solution was found.

blablotin
Black ninja
Black ninja
Posts: 67
Joined: 04 Jan 2011, 22:59
Location: Euro

Re: X86_64 unable to use JRE with openoffice

Post#3 by blablotin » 02 Apr 2011, 08:48

Hi fanthom, I have use slackyd to get jre. The package is available here:
ftp://ftp.osuosl.org/pub/slackware/slac ... 6_64-1.txz

beny
Full of knowledge
Full of knowledge
Posts: 729
Joined: 02 Jan 2011, 11:33
Location: italy

Re: X86_64 unable to use JRE with openoffice

Post#4 by beny » 02 Apr 2011, 09:43

blablotin no trouble to install your extension but i have the last openoffice 3.3. version,i have downloads java from current,if you want there is a script that made a package of the last openoffice in the language that you wish.

hypomania
Samurai
Samurai
Posts: 117
Joined: 10 Mar 2011, 10:50
Distribution: Windows phone
Location: Saudi Arabia

Re: X86_64 unable to use JRE with openoffice

Post#5 by hypomania » 04 Apr 2011, 03:44

after installing "jre-6u24-x86_64-1.txz"
ftp://ftp.osuosl.org/pub/slackware/slac ... 6_64-1.txz

open terminal and type this

Code: Select all

ln -s /usr/lib/java/bin/* /usr/bin/
then open OpenOffice.org , and tell us the result.

Best Regards.

blablotin
Black ninja
Black ninja
Posts: 67
Joined: 04 Jan 2011, 22:59
Location: Euro

Re: X86_64 unable to use JRE with openoffice

Post#6 by blablotin » 05 Apr 2011, 10:03

@Arabic_World, doing symbolic link didn't change anything for openoffice.

@beny: is it better to create package from the .debs openoffice from the official website?

beny
Full of knowledge
Full of knowledge
Posts: 729
Joined: 02 Jan 2011, 11:33
Location: italy

Re: X86_64 unable to use JRE with openoffice

Post#7 by beny » 05 Apr 2011, 10:09

hi blablotin the original openoffice package format is rpm.the package that i have told you made a package tgz and is for slackware environment.

blablotin
Black ninja
Black ninja
Posts: 67
Joined: 04 Jan 2011, 22:59
Location: Euro

Re: X86_64 unable to use JRE with openoffice

Post#8 by blablotin » 05 Apr 2011, 12:45

Hello Beny, when I try to install OOo rpm with the installation wizard, there are errors that end this, and it requiere 300 Mo more than an OOo package for porteus.

Where is the script you told me?

beny
Full of knowledge
Full of knowledge
Posts: 729
Joined: 02 Jan 2011, 11:33
Location: italy

Re: X86_64 unable to use JRE with openoffice

Post#9 by beny » 05 Apr 2011, 16:11

hi blablotin
http://www.mediafire.com/?dalk27qfr1fr6
install it as a module and choose when ask it the repository and language enjoy
many thanks to submax82 for the builder.

blablotin
Black ninja
Black ninja
Posts: 67
Joined: 04 Jan 2011, 22:59
Location: Euro

Re: X86_64 unable to use JRE with openoffice

Post#10 by blablotin » 08 Apr 2011, 10:32

Hi beny, thank you for the script.
Openoffice.org 3.3 have found java.

Post Reply