Sound Level

New features which should be implemented in Porteus Kiosk Edition and the kiosk wizard.
Post Reply
MHOS
Ronin
Ronin
Posts: 2
Joined: 03 Oct 2014, 20:19
Distribution: Porteus Kiosk 3.1.1
Location: VA

Sound Level

Post#1 by MHOS » 03 Oct 2014, 20:33

All I must first start by saying this is one of the best Kiosk softwares I have tested to date.
I am using this software for a simple jukebox to run pandora, subsonic, etc... for the Virginia Beach Elks Lodge.

My issue is I need to turn the volume up. Its set way to low by default and need to turn it up to 100% globally.

I have looked online and the forums but have not been able to get the volume set to 100%.

Things I have tried:

Set the following in rc.local
amixer set Master 100
Rebuilt iSO no joy

autoexec=amixer~set~Master~100
Rebuilt iSO no joy


Is there somewhere else I should be setting this at startup?
For some reason I'm not able to SSH into the box to try running these commands locally because even after setting up through the wizard I get:
ssh: connect to host 192.168.1.68 port 22: Connection refused
Which is odd to me as im able to VNC connect no problem which was also setup using the wizard. I know thats the correct ip and port but service is not starting.

Anyways, if anyone can guide me as to where I need to set the volume level to 100% that would be great. I can build the iSO and have made other changes this one is just stumping me.
Also sound does work just low.

Thanks,
Casey

User avatar
fanthom
Site Admin
Site Admin
Posts: 4623
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Sound Level

Post#2 by fanthom » 04 Oct 2014, 08:34

hi Casey,
My issue is I need to turn the volume up. Its set way to low by default and need to turn it up to 100% globally.
please try:

Code: Select all

amixer set Master 100%
'%' at the end is crucial.
For some reason I'm not able to SSH into the box to try running these commands locally because even after setting up through the wizard
are you sure your firewall is not blocking ssh protocol? i'm connecting with kiosk everyday through ssh and it never failed to me.
once you get ssh to work then please login to kiosk -> run 'amixer' command and check if there are other channels (like PCM) which needs to be set to 100%.

btw: in kiosk 3.2 (planned for December) you'll be able to set sound level through the wizard.
Please add [Solved] to your thread title if the solution was found.

MHOS
Ronin
Ronin
Posts: 2
Joined: 03 Oct 2014, 20:19
Distribution: Porteus Kiosk 3.1.1
Location: VA

Re: Sound Level

Post#3 by MHOS » 07 Oct 2014, 21:09

Updated the /etc/rc.d/rc.local with the line you provied and rebuilt the iso.
No luck.

Going to try starting from scratch as SSH still not working. Port scanned the kiosk ip and only open port was 5900.
Thinking something may have become corrupt during extraction/compression.

Suxs though I had FxKeyboard and AdBlockPlus working just the way I needed it.

I'll report my findings when I get time to rework it.

Also was thinking it would be cool to see a section in the wizard to add xpi urls for addons.
Just a thought.

Keep up the good work guys.

Thanks,
Casey

User avatar
fanthom
Site Admin
Site Admin
Posts: 4623
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Sound Level

Post#4 by fanthom » 08 Oct 2014, 07:30

Thinking something may have become corrupt during extraction/compression.
rather not as module wont load when is corrupted.

"Also was thinking it would be cool to see a section in the wizard to add xpi urls for addons."
addons will never be accepted in the wizard for one reason: automatic updates which targets 'setup and forget' approach.
after 3 years an addon may be not developed anymore and another firefox update may simply break it.
for this reason i need to be very careful when adding new features to the wizard. i must make sure they will be still supported by the next 10 years or so :)
Please add [Solved] to your thread title if the solution was found.

Post Reply