Root Permission denied

Post here if you are a new Porteus member and you're looking for some help.
THX2006
White ninja
White ninja
Posts: 15
Joined: 26 Sep 2014, 00:16
Distribution: Porteus LXDE
Location: U.S.

Root Permission denied

Post#1 by THX2006 » 27 Sep 2014, 18:05

Hello to all
I'm running 3.01 with LXDE on a USB drive.
I have the same problem as szaboa does Here
Can access usm, gufw, p-s-c, or any other that needs to be run as root as long as I su to root in lxterminal.
Didn't notice any real solution in the "szaboa" post. Can keep doing it this way if the other involves sudo, I will not use it for anything.


on a side note:
Had to change the "properties" line on the bleachbit start menu entry to

Code: Select all

/usr/bin/bleachbit
to get it to work, now it launches fine.

I'm really kind of liking this Porteus so far. :good:

User avatar
brokenman
Site Admin
Site Admin
Posts: 5657
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Root Permission denied

Post#2 by brokenman » 27 Sep 2014, 20:57

From a terminal as root try: ln -s /usr/bin/gnsu /usr/bin/gnsudo
How do i become super user?
Wear your underpants on the outside and put on a cape.

THX2006
White ninja
White ninja
Posts: 15
Joined: 26 Sep 2014, 00:16
Distribution: Porteus LXDE
Location: U.S.

Re: Root Permission denied

Post#3 by THX2006 » 28 Sep 2014, 03:16

brokenman wrote:From a terminal as root try: ln -s /usr/bin/gnsu /usr/bin/gnsudo
Just did it, nothing changed.
Thanks though.

User avatar
phhpro
Full of knowledge
Full of knowledge
Posts: 545
Joined: 10 Nov 2013, 20:35
Distribution: .

Re: Root Permission denied

Post#4 by phhpro » 28 Sep 2014, 04:02

...
Last edited by phhpro on 04 Feb 2016, 02:00, edited 1 time in total.

THX2006
White ninja
White ninja
Posts: 15
Joined: 26 Sep 2014, 00:16
Distribution: Porteus LXDE
Location: U.S.

Re: Root Permission denied

Post#5 by THX2006 » 28 Sep 2014, 17:58

Thanks phhpro, didn't work either.
I'll probably just keep doing it from root lxterminal. I really want nothing to do with sudo, whether they "fixed it" or not. Never needed it before, see no need for it now. If I was going to use Porteus all the time instead of casually like I do right now then I'd try to figure it out, as it stands it's just not that big a deal.

User avatar
phhpro
Full of knowledge
Full of knowledge
Posts: 545
Joined: 10 Nov 2013, 20:35
Distribution: .

Re: Root Permission denied

Post#6 by phhpro » 29 Sep 2014, 02:28

...
Last edited by phhpro on 04 Feb 2016, 01:58, edited 1 time in total.

THX2006
White ninja
White ninja
Posts: 15
Joined: 26 Sep 2014, 00:16
Distribution: Porteus LXDE
Location: U.S.

Re: Root Permission denied

Post#7 by THX2006 » 29 Sep 2014, 23:55

Thanks for the offer phhpro.
That would be anything from the start menu > System tools, that needs root password.
As it stands it's nothing that will keep me from using Porteus.

User avatar
phhpro
Full of knowledge
Full of knowledge
Posts: 545
Joined: 10 Nov 2013, 20:35
Distribution: .

Re: Root Permission denied

Post#8 by phhpro » 30 Sep 2014, 20:54

...
Last edited by phhpro on 04 Feb 2016, 01:57, edited 1 time in total.

THX2006
White ninja
White ninja
Posts: 15
Joined: 26 Sep 2014, 00:16
Distribution: Porteus LXDE
Location: U.S.

Re: Root Permission denied

Post#9 by THX2006 » 30 Sep 2014, 22:58

phhpro wrote:Just took a moment to try. No problems here. Whatever wants root passwd works just fine.
Somehow I knew you was going to say that.
phhpro wrote: You haven't changed the default, have you?
Well Yeah.... I don't leave any password as default when it's listed next to the login in. (my minimum password is 14 characters long)

Doing it like I am is not a big deal, Thanks for trying phhpro.

memomelaque
Ronin
Ronin
Posts: 2
Joined: 13 Oct 2014, 12:01
Distribution: lxd
Location: Melaque, Mexico

Re: Root Permission denied

Post#10 by memomelaque » 13 Oct 2014, 12:12

I am using LXDE from a thumb drive and when asked for root password "toor" does not work. No, I have not changed the root password.

What is going on?

User avatar
francois
Contributor
Contributor
Posts: 5134
Joined: 28 Dec 2010, 14:25
Distribution: xfce plank porteus artix
Location: C'est l'hiver: la neige soudainement est là à Montréal.

Re: Root Permission denied

Post#11 by francois » 13 Oct 2014, 12:29

In terminal:
su
toor

Maybe you were asked the guest password. :)
Carpe diem.

memomelaque
Ronin
Ronin
Posts: 2
Joined: 13 Oct 2014, 12:01
Distribution: lxd
Location: Melaque, Mexico

Re: Root Permission denied

Post#12 by memomelaque » 13 Oct 2014, 13:56

No, it does not mention Guest, only root and toor is rejected every time.

Even su, toor does not work in terminal

User avatar
francois
Contributor
Contributor
Posts: 5134
Joined: 28 Dec 2010, 14:25
Distribution: xfce plank porteus artix
Location: C'est l'hiver: la neige soudainement est là à Montréal.

Re: Root Permission denied

Post#13 by francois » 13 Oct 2014, 14:22

1.0 Did you used capital characters instead of small characters? Did you check the md5sum? Did you used persistence with the save= cheatcode in the syslinux menu entry? Try the always fresh option which should provide a virgin setup. And tell us if the root password works.

2.0 Go into the /boot/syslinux/porteus.cfg and add the login=root (cheatcode for login the root user) and reboot choosing graphic mode:

Code: Select all

LABEL kde
MENU LABEL Graphics mode (KDE4)
KERNEL vmlinuz
APPEND initrd=initrd.xz changes=/porteus login=root
If you are able to do so then use the passwd in terminal to change the root password:

Code: Select all

root@porteus:/# passwd
3.0 If this does not work, or you are doing something that I unable to figure out, or the download was corrupted. In which case, download anew and just reinstall the boot and porteus folders on the usb with the porteus.iso using the mloop «the name of the iso» (the folders will be in /mnt/loop):

Code: Select all

root@porteus:/mnt/sda5/64bit_v30/kde/changes/root/Downloads# mloop Porteus-KDE4-v3.0-i486.iso
using /dev/loop33
...
4.0 Just tell us by which method you did install porteus.
Carpe diem.

THX2006
White ninja
White ninja
Posts: 15
Joined: 26 Sep 2014, 00:16
Distribution: Porteus LXDE
Location: U.S.

Re: Root Permission denied

Post#14 by THX2006 » 01 Nov 2014, 20:25

francois wrote:1.0 Did you used capital characters instead of small characters? Did you check the md5sum? Did you used persistence with the save= cheatcode in the syslinux menu entry? Try the always fresh option which should provide a virgin setup. And tell us if the root password works.

2.0 Go into the /boot/syslinux/porteus.cfg and add the login=root (cheatcode for login the root user) and reboot choosing graphic mode:

Code: Select all

LABEL kde
MENU LABEL Graphics mode (KDE4)
KERNEL vmlinuz
APPEND initrd=initrd.xz changes=/porteus login=root
If you are able to do so then use the passwd in terminal to change the root password:

Code: Select all

root@porteus:/# passwd
3.0 If this does not work, or you are doing something that I unable to figure out, or the download was corrupted. In which case, download anew and just reinstall the boot and porteus folders on the usb with the porteus.iso using the mloop «the name of the iso» (the folders will be in /mnt/loop):

Code: Select all

root@porteus:/mnt/sda5/64bit_v30/kde/changes/root/Downloads# mloop Porteus-KDE4-v3.0-i486.iso
using /dev/loop33
...
4.0 Just tell us by which method you did install porteus.
Hello francois
Sorry it took this long to ask, but, every time you use KDE in your directions, can it be changed to LXDE (with no other changes) as memomelaque and I are using ?

User avatar
brokenman
Site Admin
Site Admin
Posts: 5657
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Root Permission denied

Post#15 by brokenman » 01 Nov 2014, 21:55

Thanks to Tome I confirmed a bug in the modified gnsu which means that passwords with some special characters (like spaces) are not passed successfully. This will be address in next release v3.1rc2. Thanks.
How do i become super user?
Wear your underpants on the outside and put on a cape.

Post Reply