Blender ALT conflict [Solved]

Non release banter
Post Reply
sparticle
White ninja
White ninja
Posts: 8
Joined: 23 Aug 2013, 15:46
Distribution: Knoppix, Slitaz, Porteus
Location: Kosova/Gjakova

Blender ALT conflict [Solved]

Post#1 by sparticle » 13 Sep 2014, 11:06

Hi, guys. Porteus is awesome, however Blender doesn't fit well with the global shortcuts. It could be a nice feature to have the global ALT combinations disabled when pressing it together with SUPER on LXDE, so I could use ALT for Blender. I'll try to fix it by myself, but if you already have a solution for that, feel free to post it here!
Last edited by sparticle on 13 Sep 2014, 20:23, edited 1 time in total.

sparticle
White ninja
White ninja
Posts: 8
Joined: 23 Aug 2013, 15:46
Distribution: Knoppix, Slitaz, Porteus
Location: Kosova/Gjakova

Re: Disable global ALT while holding SUPER

Post#2 by sparticle » 13 Sep 2014, 11:28

Okay, this is my temporary solution. I replaced ALT with SUPER:
1. Open the file "/home/guest/.config/openbox/lxde-rc.xml" using Leafpad.
2. Use replace to replace "A-" with "W-" and check "Match case" and "Replace all at once"
3. Save and ALT + CTRL + Backspace to restart LXDE.
Last edited by sparticle on 13 Sep 2014, 20:00, edited 1 time in total.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4625
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Disable global ALT while holding SUPER

Post#3 by fanthom » 13 Sep 2014, 19:30

thanks for sharing
Please add [Solved] to your thread title if the solution was found.

sparticle
White ninja
White ninja
Posts: 8
Joined: 23 Aug 2013, 15:46
Distribution: Knoppix, Slitaz, Porteus
Location: Kosova/Gjakova

Re: Disable global ALT while holding SUPER

Post#4 by sparticle » 13 Sep 2014, 20:22

Nothing special :) . However I'm having no problem with the new key-configuration, so I might add [Solved] and change the topic name to "Blender ALT conflict", since this could only be for Blender users from interest. Thank you for making such a powerful OS! The modules are so incredible, how is it even possible that they're so compressed and yet so fast. I've got so many powerful software installed (Blender, Gimp, VLC, nVidia, etc.) and yet only 204.2 MB in my modules folder. I mean, if I had to extract blender it would just take that size and yet it has only 65.9 MB as a module. Porteus just won my heart for ever.

sparticle
White ninja
White ninja
Posts: 8
Joined: 23 Aug 2013, 15:46
Distribution: Knoppix, Slitaz, Porteus
Location: Kosova/Gjakova

Re: Blender ALT conflict [Solved]

Post#5 by sparticle » 14 Sep 2014, 12:56

Also, if you can't copy content inside the Blender interface, clearing the clipboard history fixes this. You'll find the "Clipboard Manager" in system tray.

Post Reply