Verizon wireless modem not working in Porteus Version 3

Here you can post about your various experiences with PC hardware. You can also post about hardware that is not compatible with the linux kernel or not recommended for use with Porteus.
jmhoward56
Black ninja
Black ninja
Posts: 37
Joined: 08 Dec 2011, 19:28
Location: USA

Re: Verizon wireless modem not working in Porteus Version 3

Post#16 by jmhoward56 » 07 Sep 2014, 15:08

Here is psinfo for current system state.
http://pastebin.com/KpCv0WDY

jmhoward56
Black ninja
Black ninja
Posts: 37
Joined: 08 Dec 2011, 19:28
Location: USA

Re: Verizon wireless modem not working in Porteus Version 3

Post#17 by jmhoward56 » 07 Sep 2014, 15:40

So if I unplug modem and then try to plug back in it appears to go back to doing same thing as before, connects momentarily then drops. So I tried the reboot procedure and it was still doing same thing, connected for a second or two then dropped. Then I noticed I was plugged in to a usb2 port, plugged in to a usb3 port and rebooted and it connected this time. Issue seems to be related to usb3 maybe.

jmhoward56
Black ninja
Black ninja
Posts: 37
Joined: 08 Dec 2011, 19:28
Location: USA

Re: Verizon wireless modem not working in Porteus Version 3

Post#18 by jmhoward56 » 07 Sep 2014, 15:47

As long as I boot with the device in the usb3 port it will work, anything else fails even unplugging and plugging back in the usb3 port it was plugged in before.

jmhoward56
Black ninja
Black ninja
Posts: 37
Joined: 08 Dec 2011, 19:28
Location: USA

Re: Verizon wireless modem not working in Porteus Version 3

Post#19 by jmhoward56 » 09 Sep 2014, 16:38

After several searches on Google I saw a few posts that mentioned there might be some issues with certain computers usb3 ports and the newer ModemManager and NetworkManager. I am thinking about trying to compile and downgrade to the ones from Slackware 14.0. I was wanting to know if there are any dependencies that I might break doing this or that might prevent the older ones from compiling. I noticed that you added iproute2 to the Porteus 3 versions and wondered about any issues with it I might encounter.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5503
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Verizon wireless modem not working in Porteus Version 3

Post#20 by brokenman » 09 Sep 2014, 23:30

I don't think you will have any trouble downgrading as long as you downgrade both ModemManager and NetworkManager together. There was a jump to ModemManager-1.0 in 14.1
Also you probably won't need the libsecret dependency for the slackware 14.0 version of NetworkManager to compile.
How do i become super user?
Wear your underpants on the outside and put on a cape.

jmhoward56
Black ninja
Black ninja
Posts: 37
Joined: 08 Dec 2011, 19:28
Location: USA

Re: Verizon wireless modem not working in Porteus Version 3

Post#21 by jmhoward56 » 18 Apr 2015, 16:57

Problem solved some what. Last night when trying to connect to internet the modem said there was a firmware update available so I downloaded and installed it. I immediately thought of my connection problems in Slackware 14.1 so I found a usb with Porteus 3.01 on it and booted it up. I then inserted the newly updated Pantech usb modem and tried to connect and was met with the same problems as before. This morning I was going back over notes from before and decided to try downgrading ModemManager and NetworkManager. I downloaded these txz packages from a Slackware 14.0 repository, created xzm modules from them and copied them to modules folder. Next I booted up Porteus, fired up a terminal and went into /etc/rc.d. There I changed permissions on rc.networkmanager to 755 and started the network manager daemon. I then inserted the usb modem waited for it to initialize and presto, here I am on the internet and posting this on the forum. I am going to test it for a few days and if it continues working I will finally update my laptop to Slackware 14.1.
PS How do I marked as solved?

User avatar
wread
Module Guard
Module Guard
Posts: 1080
Joined: 09 Jan 2011, 18:48
Distribution: Porteus v3.2.5-kde5-64 bits
Location: Santo Domingo
Contact:

Re: Verizon wireless modem not working in Porteus Version 3

Post#22 by wread » 18 Apr 2015, 18:40

The laptop is bad or the Porteus download is corrupted. Please check the md5sums!
Porteus is proud of the FASTEST KDE ever made.....(take akonadi, nepomuk and soprano out and you will have a decent OS).
The Porteus Community never sleeps!

jmhoward56
Black ninja
Black ninja
Posts: 37
Joined: 08 Dec 2011, 19:28
Location: USA

Re: Verizon wireless modem not working in Porteus Version 3

Post#23 by jmhoward56 » 18 Apr 2015, 23:25

The laptop is not bad, the modem works just fine if I boot to Windows and connect it. It also works just fine on my Slackware 14.0 install on the laptop. It did not work if I try to run it on Slackware 14.1 with the newer ModemManager and NetworkManager. Since I have downgraded to to Slackware 14.0 ModemManager and NetworkManager I have it working so far.

jmhoward56
Black ninja
Black ninja
Posts: 37
Joined: 08 Dec 2011, 19:28
Location: USA

Re: Verizon wireless modem not working in Porteus Version 3

Post#24 by jmhoward56 » 18 Apr 2015, 23:35

I also downloaded all versions of Porteus, KDE. Mate, LXQT, and Xfce and installed on different usb thumb drives. There is something with ModemManager, NetworkManager and the cdc_ether kernel module from what I can determine.

Post Reply