[SOLVED] How do I remove this annoying weather report?

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
Post Reply
att
Contributor
Contributor
Posts: 131
Joined: 28 Dec 2010, 17:09

[SOLVED] How do I remove this annoying weather report?

Post#1 by att » 23 Mar 2011, 19:39

Hello,

I have some issues with this annoying widgets in KDE4. "Weather report" and "Mail Notify" is turned on by default in Porteus, and I find both of them annoying as hell.
I very often boot into Porteus using the "fresh" aka copy2ram option and do not use slaxsave.dat files or changes-directories whatsoever; I prefer to copy my config files by "rootcopy" method.

"Weather report" is especially annoying. When I forget to unlock widgets and close it in the beginning, it comes along with an error saying that it cannot fetch weather info from the net.
And then, I cannot close the window anymore. See screenshot:

http://666kb.com/i/bs0tfzfeto9glvyqp.jpg

So, how to turn this off, preferably by rootcopying any config file from rootcopy-dir ?

Second: I also rootcopy some kde4 config files and dirs so as to prevent other languages for my keyboard except german, but that doesn't work either.
KDE boots, displays my german flag for 1 second (hooray!) but then decides to switch to English flag and keyboard layout every time, no matter what my rootcopy dir says.

Any advice how to save my keyboard layout config more permanently ?
Last edited by att on 24 Mar 2011, 12:35, edited 1 time in total.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4566
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: How do I remove this annoying weather report?

Post#2 by fanthom » 23 Mar 2011, 23:36

1) remove all widgets which you want to get rid off, then store:
/root/.kde4/share/config/plasma-desktop-appletsrc
in /porteus/rootcopy

2) dont know why but KDE-4 also reads keyboard settings included in
/root/.config/autostart/xkb.desktop
(this file is LXDE specific)
so when you change default kbd setting to german, please also do it in this file. store both: kde/lxde config files in /porteus/rootcopy and you are set.
Please add [Solved] to your thread title if the solution was found.

att
Contributor
Contributor
Posts: 131
Joined: 28 Dec 2010, 17:09

Re: How do I remove this annoying weather report?

Post#3 by att » 24 Mar 2011, 12:34

Thank you, that solved my problem! I also now save the /root/.kde4/share/config/kwinrc file, to remember the number of virtual desktops.
Nice clue, thanx!

Post Reply