[SOLVED] KDE ignoring/overriding my xorg.conf

Get help with KDE4 specific problems
Post Reply
router
White ninja
White ninja
Posts: 18
Joined: 02 Aug 2014, 02:22
Distribution: Porteus 3 and pclinuxOS
Location: usa

[SOLVED] KDE ignoring/overriding my xorg.conf

Post#1 by router » 14 Aug 2014, 05:43

hi everyone

i have xorg.conf placed in both of /etc/X11 and /usr/share/X11 in an attempt to make a default display resolution that applies to all users, but KDE is somewhere overriding that and setting what it thinks i would like to have

i have as yet NOT used any desktop utilities to set any resolutions, and i don't want to do it that way, i know how but the point is, if i say do something in xorg.conf i want KDE to honor it, and if it is not, i would like to know where at in its setup it is disobeying , so i can make it stop

any help? btw i'm on a completely virgin install of porteus 3.01 kde other than that xorg.conf i mentioned
Last edited by router on 15 Aug 2014, 18:10, edited 1 time in total.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4565
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: KDE ignoring/overriding my xorg.conf

Post#2 by fanthom » 14 Aug 2014, 07:14

hi router,

if you use proprietary AMD/nVidia driver then please have a look on /etc/rc.d/rcS.d/S99-(amd/nVidia) file. you may override it by placing an empty file in your /rootcopy or custom module.
Please add [Solved] to your thread title if the solution was found.

router
White ninja
White ninja
Posts: 18
Joined: 02 Aug 2014, 02:22
Distribution: Porteus 3 and pclinuxOS
Location: usa

Re: KDE ignoring/overriding my xorg.conf

Post#3 by router » 14 Aug 2014, 18:15

i'm not using proprietary. i know what's happening, i just don't know where it is happening. either xrandr or krandrtray is getting called after the greeter accepts my user login (or after autologin) , and because i don't have a saved setting it is using the best/highest resolution it can use, instead of the one given in my xorg.conf.

or, it's restarting the X server in some way that makes X not look at xorg.conf, but the Xorg log doesn't support that theory, unless it's also getting started in a way that makes it not write to the normal log.

i tried to defeat it by making a krandrrc and putting it in /usr/share/config but that didn't work either. but really what i would like to do is just make it not call xrandr again anyway, i'd like the greeter or autologin to skip that call and just go ahead with the resolution X is already running at, from my xorg.conf. the greeter screen uses the resolution i specified there if i don't let autologin, and it again uses my resolution if i log out from a kde session even if i let autologin. so it's something between the greeter and the starting of the sessions, or something in the session start scripts, i'm just not that smart to find it.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4565
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: KDE ignoring/overriding my xorg.conf

Post#4 by fanthom » 15 Aug 2014, 08:26

i tried to defeat it by making a krandrrc and putting it in /usr/share/config but that didn't work either.
launch 'krandrtray' in terminal -> set your resolution -> make $HOME/.kde4/usr/share/config/krandrrc persistent
but really what i would like to do is just make it not call xrandr again anyway, i'd like the greeter or autologin to skip that call and just go ahead with the resolution X is already running at, from my xorg.conf.
try this:
kde system settings -> startup and shutdown -> service manager -> disable KScreen2
not sure if it work though
Please add [Solved] to your thread title if the solution was found.

User avatar
francois
Contributor
Contributor
Posts: 4937
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: KDE ignoring/overriding my xorg.conf

Post#5 by francois » 15 Aug 2014, 10:24

What is the resolution that you want to set standard? What is the output of xrandr command?

You can use a xrandr script to set the resolution and by dropping it in the /root/.kde4/Autostart/ folder , see:
viewtopic.php?f=81&t=3045&hilit=+xrandr
viewtopic.php?f=61&t=3203

I have a dual display setting but for my standalone monitor the following script does the job:

Code: Select all

root@porteus:~# xrandr --output LVDS1 --mode 1440x900
Voltaire: Le mieux est l'ennemi du bien.

router
White ninja
White ninja
Posts: 18
Joined: 02 Aug 2014, 02:22
Distribution: Porteus 3 and pclinuxOS
Location: usa

Re: KDE ignoring/overriding my xorg.conf

Post#6 by router » 15 Aug 2014, 11:36

don't misunderstand, i already know how to set the resolutions on a per user basis, either through the kde GUI way or by an xrandr script.

and i know that with a little trial and error i could find some place in the startup scripts that get kde up and running, i could put an xrandr command so any user logging in would start at what i tell xrandr there.

but i am curious and stubborn, i want to know exactly where in the existing startup is my xorg.conf getting ignored. where ever that is, i want to bend it to my own will and make it respect my xorg.conf, instead of me calling xrandr again and overriding the override.

if anyone knows exactly what happens, between the greeter accepting a password, and the kde desktop coming up, or if anyone knows how i can find out for myself, that is the info i want to learn. the greeter screen already obeys my xorg.conf, so it's after that is something bypassing it.

i'll see what's up with kscreen2 service, i know it's related in a way but i think it only watches and stores the state of the displays then return them to a stored state after having saved the state once, but i think it should not be involved in the initial setting of the resolution.

in other words to more clearly say what i want to be able to do, partly for just the sake of having more knowledge of how things work, i would like to know, if i clean install porteus-kde, and don't let any autologin happen, make it stop and stand on the greeter screen, i want to know, if i switch at that point to the console, and start up midnight commander, what file i would edit, so that no matter whether it is guest or root that then logs in, their desktop will already come up at the resolution that is specified in my xorg.conf. and i want to use whatever method the existing startup scripts are already using, i want them to do what they do, i just want them to do it my way. :)

User avatar
francois
Contributor
Contributor
Posts: 4937
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: KDE ignoring/overriding my xorg.conf

Post#7 by francois » 15 Aug 2014, 14:37

@fanthom:
Maybe there could be something possible within the menu entry. There used to be the autoexec cheatcode in slaxremix:
http://old.slax.org/slax/forum.php?acti ... ntID=76244

Code: Select all

kernel (hd0,1)/boot/vmlinuz ramdisk_size=6666 root=/dev/ram0 rw autoexec=xconf;telinit~4 from=/other_linux max_loop=256


In the above removing xconf for:

Code: Select all

autoexec=telinit~4
Would keep the previous xorg.conf.

You are the one who knows what the actual porteus could do.
Last edited by francois on 15 Aug 2014, 19:05, edited 1 time in total.
Voltaire: Le mieux est l'ennemi du bien.

router
White ninja
White ninja
Posts: 18
Joined: 02 Aug 2014, 02:22
Distribution: Porteus 3 and pclinuxOS
Location: usa

Re: KDE ignoring/overriding my xorg.conf

Post#8 by router » 15 Aug 2014, 18:06

i fell asleep before i could explore it much but i think he may have put his finger on it with the kscreen service. i went to a console and disabled it by editing its desktop file in /usr/share/kde stuff and my logins kept the sizes i wanted. now if i can dig a little and find out more about kscreen, where it gets (or doesn't get) its info, but if not, yea just not letting it run might be an answer.

i know it was kscreen tho because not only did i shut it off, but i replaced xrandr with a script that does nothing, and when i re enable kscreen it still ignores my xorg.conf even with xrandr non-functional lol


i think its close enough to call it solved but i'm still open to knowing more about the kde startup process.

Post Reply