[solved] Porteus LXDE 32bit 3.0.1 firefox-31.0

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
Post Reply
User avatar
amplatfus
Samurai
Samurai
Posts: 117
Joined: 30 Oct 2012, 14:55
Distribution: MATE Porteus-v3.2.2
Location: Romania

[solved] Porteus LXDE 32bit 3.0.1 firefox-31.0

Post#1 by amplatfus » 09 Aug 2014, 00:39

Hi,

I have tried to use firefox-31.0 in actual LXDE 3.0 by replace the xzm in base folder.
After boot, Firefox wasn't started.
From terminal I got:

Code: Select all

root@portes:~# firefox
XPCOMGlueLoad error for file /usr/lib/firefox-31.0/libxul.so:
/usr/lib/firefox-31.0/libsmime3.so: version `NSS_3.16' not found (required by /usr/lib/firefox-31.0/libxul.so)
Couldn't load XPCOM.
The same situation was on Always Fresh option from Porteus boot menu.
Could you please help?

BR,
amplatfus
Last edited by amplatfus on 09 Aug 2014, 06:33, edited 1 time in total.
Porteus-v3.2.2 MATE
Kernel: 4.9.12-porteus

User avatar
brokenman
Site Admin
Site Admin
Posts: 5574
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Porteus LXDE 32bit 3.0.1 firefox-31.0

Post#2 by brokenman » 09 Aug 2014, 02:00

Are you using Porteus v3.0.1?

You can see by the output of: cat /etc/porteus-version
How do i become super user?
Wear your underpants on the outside and put on a cape.

User avatar
amplatfus
Samurai
Samurai
Posts: 117
Joined: 30 Oct 2012, 14:55
Distribution: MATE Porteus-v3.2.2
Location: Romania

Re: Porteus LXDE 32bit 3.0.1 firefox-31.0

Post#3 by amplatfus » 09 Aug 2014, 05:33

No. But I'm still on 3.0 LXDE 32 bit.
Could be a reason?

Thanks.
amplatfus
Porteus-v3.2.2 MATE
Kernel: 4.9.12-porteus

User avatar
amplatfus
Samurai
Samurai
Posts: 117
Joined: 30 Oct 2012, 14:55
Distribution: MATE Porteus-v3.2.2
Location: Romania

Re: [solved] Porteus LXDE 32bit 3.0.1 firefox-31.0

Post#4 by amplatfus » 09 Aug 2014, 06:35

Hi,

That was the reason. With LXDE 3.01 32 bit, firefox-31.0 is working, of course :)

BR,
amplatfus
Porteus-v3.2.2 MATE
Kernel: 4.9.12-porteus

Post Reply