Skype 4.3

If you are looking for a specific 64-bit package and you can't find it in any of the 64-bit repos, please post a request for it here
User avatar
fanthom
Site Admin
Site Admin
Posts: 4617
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Skype 4.3

Post#16 by fanthom » 24 Sep 2014, 09:08

does it happen in 'Always Fresh' mode as well? i have tried skype module in 64bit LXDE and it worked without compat32libs.
Please add [Solved] to your thread title if the solution was found.

cttan
Shogun
Shogun
Posts: 332
Joined: 26 Jan 2011, 16:15
Distribution: Porteus 3.2 64bit KDE
Location: Malaysia

Re: Skype 4.3

Post#17 by cttan » 26 Sep 2014, 08:37

@fanthom
I am able to login using Always Fresh mode. But when I use my boot line with toroot then it is not working.
I see that the .asoundrc file is not copied to the /home/guest folder.
Last edited by cttan on 26 Sep 2014, 09:39, edited 1 time in total.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4617
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Skype 4.3

Post#18 by fanthom » 26 Sep 2014, 08:55

so maybe it's a matter of replacing /home/guest with /root?
will update the skype module this evening and make it work for root also.

could you point me to where should i look for the lines to change?
Please add [Solved] to your thread title if the solution was found.

cttan
Shogun
Shogun
Posts: 332
Joined: 26 Jan 2011, 16:15
Distribution: Porteus 3.2 64bit KDE
Location: Malaysia

Re: Skype 4.3

Post#19 by cttan » 26 Sep 2014, 09:40

@fanthom

I am still trying to make it work when booting using toroot.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4617
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Skype 4.3

Post#20 by fanthom » 01 Oct 2014, 16:50

skype works here from root account (calls, sound and video). this is what i'm getting in terminal:

Code: Select all

root@porteus:~# skype 
Configuring audio...
W: [pulseaudio] main.c: This program is not intended to be run as root (unless --system is specified).
W: [pulseaudio] authkey.c: Failed to open cookie file '/root/.config/pulse/cookie': No such file or directory
W: [pulseaudio] authkey.c: Failed to load authorization key '/root/.config/pulse/cookie': No such file or directory
W: [pulseaudio] authkey.c: Failed to open cookie file '/root/.pulse-cookie': No such file or directory
W: [pulseaudio] authkey.c: Failed to load authorization key '/root/.pulse-cookie': No such file or directory
libv4l2: error turning on stream: File too large
libv4l2: error dequeuing buf: Invalid argument
can anybody confirm that skype module do not work from the root account?

thanks
Please add [Solved] to your thread title if the solution was found.

cttan
Shogun
Shogun
Posts: 332
Joined: 26 Jan 2011, 16:15
Distribution: Porteus 3.2 64bit KDE
Location: Malaysia

Re: Skype 4.3

Post#21 by cttan » 05 Oct 2014, 15:53

@fanthom

When login in using Always Fresh + login=root, I'm getting this:-
Image

User avatar
fanthom
Site Admin
Site Admin
Posts: 4617
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Skype 4.3

Post#22 by fanthom » 05 Oct 2014, 18:37

@cttan
this bug is fixed now - only KDE4 and Razor were affected, weird that you were the only one who reported it.

please download updated module from here:
http://dl.porteus.org/x86_64/current/mo ... -skype.xzm

btw: compat32lib module is not needed to run this version of skype

thanks
Please add [Solved] to your thread title if the solution was found.

cttan
Shogun
Shogun
Posts: 332
Joined: 26 Jan 2011, 16:15
Distribution: Porteus 3.2 64bit KDE
Location: Malaysia

Re: Skype 4.3

Post#23 by cttan » 06 Oct 2014, 16:34

Hi fanthom,

I'm from the slax background so I like toroot very much. I guess I'm the only one around and use KDE. Most would have chosen other DE. Most of the people would be on guest account.

Bad news is the updated module still having error:-

Code: Select all

oot@porteus:~# skype
Configuring audio...
W: [pulseaudio] main.c: This program is not intended to be run as root (unless --system is specified).
W: [pulseaudio] authkey.c: Failed to open cookie file '/root/.config/pulse/cookie': No such file or directory
W: [pulseaudio] authkey.c: Failed to load authorization key '/root/.config/pulse/cookie': No such file or directory
W: [pulseaudio] authkey.c: Failed to open cookie file '/root/.pulse-cookie': No such file or directory
W: [pulseaudio] authkey.c: Failed to load authorization key '/root/.pulse-cookie': No such file or directory
E: [pulseaudio] main.c: Daemon startup failed.
WARNING!! You audio is not properly configured!! Edit ~/.asoundrc and fix it

###

root@porteus:~# ps aux | grep pulseaudio
root      3288  0.0  0.0   5084  1048 pts/0    S+   00:23   0:00 grep pulseaudio
root@porteus:~# 
Pulseaudio not started while Skype is running so unable to select in Skype sound menu.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4617
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Skype 4.3

Post#24 by fanthom » 06 Oct 2014, 17:26

checked once again on KDE4 with being logged in as root: everything works.

do you have a sound in your KDE4? can you watch YT videos with sound?
please run in 'Always Fresh' mode -> download and activate 08-skype.xzm then check again.

thanks
Please add [Solved] to your thread title if the solution was found.

cttan
Shogun
Shogun
Posts: 332
Joined: 26 Jan 2011, 16:15
Distribution: Porteus 3.2 64bit KDE
Location: Malaysia

Re: Skype 4.3

Post#25 by cttan » 09 Oct 2014, 01:04

Hi fanthom,
FInally I got the Skype 4.3 successfully started when using login=root once. :Yahoo!:
But most of the time when I boot up I'm getting /usr/bin/skype: line 26: 15316 Segmentation fault

At least we can confirm the module is working.

Thank you for your time.
Last edited by cttan on 10 Oct 2014, 06:52, edited 1 time in total.

cttan
Shogun
Shogun
Posts: 332
Joined: 26 Jan 2011, 16:15
Distribution: Porteus 3.2 64bit KDE
Location: Malaysia

Re: Skype 4.3

Post#26 by cttan » 10 Oct 2014, 06:51

Hi fanthom,

FYI I found out that when I enable compat32, the Skype able to start up and I'm able to see the PulseAudio Server in the Sound Menu.

I'm using copy2ram login=root and no changes.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4617
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Skype 4.3

Post#27 by fanthom » 10 Oct 2014, 19:52

it runs without compat32 here.
can anybody confirm that latest skype wont work reliable without compat32libe package?
Please add [Solved] to your thread title if the solution was found.

User avatar
francois
Contributor
Contributor
Posts: 5078
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: Skype 4.3

Post#28 by francois » 11 Oct 2014, 15:33

I might be late for the testing but skype 4.3 downloaded with usm porteus 3.0.1 kde environment works fine for me. :)

Oh, I just realize that I am on the 32 bit edition. :(
Voltaire: Le mieux est l'ennemi du bien.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5571
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Skype 4.3

Post#29 by brokenman » 12 Oct 2014, 15:33

Works fine here without compat32
How do i become super user?
Wear your underpants on the outside and put on a cape.

cttan
Shogun
Shogun
Posts: 332
Joined: 26 Jan 2011, 16:15
Distribution: Porteus 3.2 64bit KDE
Location: Malaysia

Re: Skype 4.3

Post#30 by cttan » 12 Oct 2014, 17:19

Hi fanthom

It is working fine now.
Thank you all.

Post Reply