Possible bug with 'Porteus Settings Centre' or 'changes-ro'

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
Post Reply
WavyLinesAreNotReal
White ninja
White ninja
Posts: 21
Joined: 08 Jan 2013, 05:07
Distribution: Porteus v3.1 KDE 64-bit
Location: USA

Possible bug with 'Porteus Settings Centre' or 'changes-ro'

Post#1 by WavyLinesAreNotReal » 26 Jun 2014, 01:25

Summary: Using the cheat code 'changes-ro' for the 1st time causes problems with '.dat' save files. In order for a '.dat' save file to be accepted and used by Porteus, Porteus 1st has to be shutdown with 'changes-ro' not included in the 'porteus.cfg' file. This allows Porteus to save the session the way it wants to be saved. At that point, the '.dat' file can be used with 'changes-ro', and future sessions can be saved manually through 'Porteus Settings Centre'.

Operating System: 64-bit KDE porteus

How To Create:
1. Start a Porteus session.
2. Create a new cheatcode setting.
* Edit 'porteus.cfg' with the following
- 'changes-ro' as part of the cheatcode.
- without a '.dat' save file
3. Restart Porteus and select the new cheatcode setting on the startup menu.
4. Make some highly noticeable adjustments to your current session.
* e.g. Create a new icon, mute the volume, change the keyboard
5. Create a new '.dat' save file
6. Manually save the current session to the '.dat' file
7. Edit 'porteus.cfg' with the following
* the new '.dat' save file as part of the cheatcode.
8. Restart Porteus
9. Observe that the current session was not saved.
10. Observe also that manually saving the session to the new '.dat' file will never work.

Work Around:
1. Start the Porteus session.
2. Edit 'porteus.cfg' with the following
* 'changes-ro' removed
3. Restart the Porteus session.
4. Make some highly noticeable adjustments to your current session.
* e.g. Create a new icon, mute the volume, change the keyboard
5. Manually save the current session.
6. Edit 'porteus.cfg' with the following
* 'changes-ro' as part of the cheatcode
7. Restart Porteus
8. Observe that the current session was actually saved.
* Observe also that manually saving the current session will work from now on.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4547
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Possible bug with 'Porteus Settings Centre' or 'changes-

Post#2 by fanthom » 26 Jun 2014, 06:29

this is actually expected behavior. 'changes-ro' tells the system: 'do not save changes' so would be not clever to add this cheat, reboot and still expect that next session get saved into save.dat.

here is correct procedure for using save.dat + 'changes-ro'
a) when you boot porteus for the first time you should create save.dat (if you need it) then reboot so it gets used
b) now you should set everything as you like and add 'changes-ro' to porteus.cfg
c) session still gets saved till you shutdown/reboot, every new session is not saved until you remove 'changes-ro' cheat
Please add [Solved] to your thread title if the solution was found.

WavyLinesAreNotReal
White ninja
White ninja
Posts: 21
Joined: 08 Jan 2013, 05:07
Distribution: Porteus v3.1 KDE 64-bit
Location: USA

Re: Possible bug with 'Porteus Settings Centre' or 'changes-

Post#3 by WavyLinesAreNotReal » 26 Jun 2014, 18:35

Is it possible to simply turn off automatic saving on shutdown? That way if I see changes I like, I still have the option to do a manual save.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4547
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Possible bug with 'Porteus Settings Centre' or 'changes-

Post#4 by fanthom » 26 Jun 2014, 20:35

Is it possible to simply turn off automatic saving on shutdown?
changes are saved in real time unless you use 'changes=EXIT:' cheatcode. with 'changes=EXIT:' they are buffered in RAM and during shutdown you have an option to not save them (press any key other than space/enter if i remember correctly).
Please add [Solved] to your thread title if the solution was found.

Post Reply