[Solved] accentsfail in lxterminal on x64 alone

Non release banter
Post Reply
biotec
White ninja
White ninja
Posts: 23
Joined: 23 Jan 2014, 23:50
Distribution: slackware
Location: Oviedo

[Solved] accentsfail in lxterminal on x64 alone

Post#1 by biotec » 18 Jun 2014, 22:05

Hi, Im very happy with porteus, but I found what seems to be a strange bug:

special characters are not shown in the porteus-x64 version of lxterminal (??? shown instead), but only there.
It doesn't seem to be a configuration problem, because I'm using exactly the same for configuration on porteus-x32 and on a pure slackware-64 14.1 with success.
Xterm and UXterm is able to show those chars too. Only lxterminal in porteus-x64 is failing.

Any help would be appreciate, because I wanted to use the same setup in several computers, some running porteus and others slackware, some x32, others x64.

Regards
Last edited by biotec on 20 Jun 2014, 21:30, edited 1 time in total.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4566
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: accentsfail in lxterminal on x64 alone

Post#2 by fanthom » 19 Jun 2014, 07:19

hi biotec,

please install this package and check if that helps:
http://mirrors.slackware.com/slackware/ ... arch-1.txz

if not then please provide following details:
- what's you locale settings? we need the output of:

Code: Select all

grep "export LANG=" /etc/profile.d/lang.sh
- what's your keyboard mapping seting? please provide the output of:

Code: Select all

setxkbmap -query
thanks
Please add [Solved] to your thread title if the solution was found.

biotec
White ninja
White ninja
Posts: 23
Joined: 23 Jan 2014, 23:50
Distribution: slackware
Location: Oviedo

Re: accentsfail in lxterminal on x64 alone

Post#3 by biotec » 20 Jun 2014, 11:00

Hello fanthom,

Thanks for helping.

Unfortunately adding new fonts doesn't solve the problem.

With respect to your questions:

# grep "export LANG=" /etc/profile.d/lang.sh
export LANG=es_ES@euro

# setxkbmap -query
rules: evdev
model: pc104
layout: es
options: grp:alt_shift_toggle,terminate:ctrl_alt_bksp

However, for LANG I had also tried with es_ES and fr_FR with no effect :no:

Regarding the keyboard, it cannot be the culprit because the trouble is not just for typing, it is while dumping on the screen with cat, less, vi and so on any file with latin1 chars. However, this failure to show those chars only happen with lxterminal on porteus-x64, whereas using lxterminal under porteus-x32 works well. Even stranger for me, if I call xterm or uxterm from the non-working lxterminal, special chars are shown !!! :shock:

Regards.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4566
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: accentsfail in lxterminal on x64 alone

Post#4 by fanthom » 20 Jun 2014, 20:39

maybe some other modules or changes (lxterminal settings?) causes this issue?

could you boot to always fresh mode -> activate your localization module (i assume you created it through PSC?) -> logout/login back and check if that helps.
Please add [Solved] to your thread title if the solution was found.

biotec
White ninja
White ninja
Posts: 23
Joined: 23 Jan 2014, 23:50
Distribution: slackware
Location: Oviedo

Re: accentsfail in lxterminal on x64 alone

Post#5 by biotec » 20 Jun 2014, 21:29

Hi again, fanthom, :good:

I found the cause: I was using the same minimalistic locale module that I prepared to use with porteus-x32 but is not correct in porteus-x64 (x32 requires /usr/lib/locale, whereas x64 requires /usr/lib64/locale). The actual locale files are the same in both versions, but not the location, :shock: so a few softlinks make this setup correct for both versions.

Thank you very much for your help, and sorry for annoying you with such a stupid mistake of mine. :sorry:

Regards (and keep on with Porteus, its great for teaching, among other uses!). :beer:

Post Reply