Black screen with cursor toshiba tecra

Post bug reports related to either the kiosk ISO or the kiosk wizard here.
Post Reply
kwelch
White ninja
White ninja
Posts: 9
Joined: 29 May 2014, 16:33
Distribution: porteus kiosk 3.1
Location: US

Black screen with cursor toshiba tecra

Post#1 by kwelch » 30 May 2014, 15:44

When booting to porteus kiosk edition v3.1 my PC hangs at a black screen with just the cursor after loading all modules. after running the lspci-knn command i got this output:

root@porteus:/home/guest# lspci -knn
00:00.0 Host bridge [0600]: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub [8086:27a0] (rev 03)
Subsystem: Toshiba America Info Systems Device [1179:0001]
Kernel driver in use: agpgart-intel
Kernel modules: intel_agp
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)
Subsystem: Toshiba America Info Systems Device [1179:0006]
Kernel driver in use: i915
Kernel modules: i915
00:02.1 Display controller [0380]: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller [8086:27a6] (rev 03)
Subsystem: Toshiba America Info Systems Device [1179:0006]
00:1b.0 Audio device [0403]: Intel Corporation NM10/ICH7 Family High Definition Audio Controller [8086:27d8] (rev 02)
Subsystem: Toshiba America Info Systems Device [1179:0001]
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel
00:1c.0 PCI bridge [0604]: Intel Corporation NM10/ICH7 Family PCI Express Port 1 [8086:27d0] (rev 02)
Kernel driver in use: pcieport
Kernel modules: shpchp
00:1c.2 PCI bridge [0604]: Intel Corporation NM10/ICH7 Family PCI Express Port 3 [8086:27d4] (rev 02)
Kernel driver in use: pcieport
Kernel modules: shpchp
00:1d.0 USB controller [0c03]: Intel Corporation NM10/ICH7 Family USB UHCI Controller #1 [8086:27c8] (rev 02)
Subsystem: Toshiba America Info Systems Device [1179:0001]
Kernel driver in use: uhci_hcd
00:1d.1 USB controller [0c03]: Intel Corporation NM10/ICH7 Family USB UHCI Controller #2 [8086:27c9] (rev 02)
Subsystem: Toshiba America Info Systems Device [1179:0001]
Kernel driver in use: uhci_hcd
00:1d.2 USB controller [0c03]: Intel Corporation NM10/ICH7 Family USB UHCI Controller #3 [8086:27ca] (rev 02)
Subsystem: Toshiba America Info Systems Device [1179:0001]
Kernel driver in use: uhci_hcd
00:1d.3 USB controller [0c03]: Intel Corporation NM10/ICH7 Family USB UHCI Controller #4 [8086:27cb] (rev 02)
Subsystem: Toshiba America Info Systems Device [1179:0001]
Kernel driver in use: uhci_hcd
00:1d.7 USB controller [0c03]: Intel Corporation NM10/ICH7 Family USB2 EHCI Controller [8086:27cc] (rev 02)
Subsystem: Toshiba America Info Systems Device [1179:0001]
Kernel driver in use: ehci-pci
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev e2)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge [8086:27b9] (rev 02)
Subsystem: Toshiba America Info Systems Device [1179:0001]
Kernel modules: intel_rng
00:1f.2 IDE interface [0101]: Intel Corporation 82801GBM/GHM (ICH7-M Family) SATA Controller [IDE mode] [8086:27c4] (rev 02)
Subsystem: Toshiba America Info Systems Device [1179:0001]
Kernel driver in use: ata_piix
01:00.0 Ethernet controller [0200]: Intel Corporation 82573L Gigabit Ethernet Controller [8086:109a]
Subsystem: Toshiba America Info Systems Device [1179:0001]
Kernel driver in use: e1000e
Kernel modules: e1000e
02:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection [8086:4222] (rev 02)
Subsystem: Intel Corporation Device [8086:1040]
Kernel driver in use: iwl3945
Kernel modules: iwl3945, wl
03:0b.0 CardBus bridge [0607]: Texas Instruments PCIxx12 Cardbus Controller [104c:8039]
Subsystem: Toshiba America Info Systems Device [1179:0001]
Kernel driver in use: yenta_cardbus
Kernel modules: yenta_socket
03:0b.1 FireWire (IEEE 1394) [0c00]: Texas Instruments PCIxx12 OHCI Compliant IEEE 1394 Host Controller [104c:803a]
Subsystem: Toshiba America Info Systems Device [1179:0001]
Kernel driver in use: firewire_ohci
Kernel modules: firewire_ohci
03:0b.3 SD Host controller [0805]: Texas Instruments PCIxx12 SDA Standard Compliant SD Host Controller [104c:803c]
Subsystem: Toshiba America Info Systems Device [1179:0001]
Kernel driver in use: sdhci-pci

User avatar
fanthom
Site Admin
Site Admin
Posts: 4618
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Black screen with cursor toshiba tecra

Post#2 by fanthom » 30 May 2014, 16:05

i see that you have used our desktop edition to run 'lspci -knn' which makes things easier to me.
i assume that our desktop edition works well on this hardware?

while on desktop edition - could you upload /var/log/Xorg.0.log to pastebin.com and link here?
could you enable ssh access in kiosk and do the same? i hope that ssh will be available as it starts just before firefox...
if you manage to login then please run 'cat /var/log/Xorg.0.log' and copy the output to pastebin.com

thanks.
Please add [Solved] to your thread title if the solution was found.

kwelch
White ninja
White ninja
Posts: 9
Joined: 29 May 2014, 16:33
Distribution: porteus kiosk 3.1
Location: US

Re: Black screen with cursor toshiba tecra

Post#3 by kwelch » 30 May 2014, 19:44

here is the log you requested: http://pastebin.com/qwf65tP4.

now as for your second request, im not exactly sure how to enable ssh in the kiosk version.

EDIT: Also if i boot to the ISO multiple times i eventually get the GUI to come up, but then if i burn the OS to the HDD i once again lose the GUI when i restart.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4618
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Black screen with cursor toshiba tecra

Post#4 by fanthom » 31 May 2014, 09:00

im not exactly sure how to enable ssh in the kiosk version.
you can do it in the wizard :)

Also if i boot to the ISO multiple times i eventually get the GUI to come up, but then if i burn the OS to the HDD i once again lose the GUI when i restart.
this is weird. first think kiosk does after getting into GUI is to set the wallpaper - maybe it's hanging at this stage?
could you upload your ISO for me? if cant go public then please send me download URL on admin@porteus-kiosk.org.

thanks
Please add [Solved] to your thread title if the solution was found.

kwelch
White ninja
White ninja
Posts: 9
Joined: 29 May 2014, 16:33
Distribution: porteus kiosk 3.1
Location: US

Re: Black screen with cursor toshiba tecra

Post#5 by kwelch » 02 Jun 2014, 21:45

unfortunately i cannot enable ssh when the problem occurs because the OS hangs before i ever get to the wizard. i will gladly upload my ISO for evaluation tomorrow. and also something to note: when the OS hangs at the black screen, sometimes the resolution changes and sometimes it doesn't. Also when the resolution does change the OS still hangs from time to time. not sure if that's any help at all but its something I've noticed.

kwelch
White ninja
White ninja
Posts: 9
Joined: 29 May 2014, 16:33
Distribution: porteus kiosk 3.1
Location: US

Re: Black screen with cursor toshiba tecra

Post#6 by kwelch » 05 Jun 2014, 15:12

Here is the link to the ISO, i also sent you an email containing the same link. and another thing that i noticed about the issue is that although the screen in black, i know that firefox is loading because the cursor turns to the text select icon when i hover over where the search bar should be. so it seems like everything is loading correctly other than the video driver.


https://www.dropbox.com/s/pwu082n9p5mu6 ... 1-i486.iso

Post Reply