Constant receiving on LAN?

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
Dave99
Black ninja
Black ninja
Posts: 54
Joined: 19 Apr 2014, 20:15
Distribution: Porteus
Location: R.S.A.

Constant receiving on LAN?

Post#1 by Dave99 » 16 May 2014, 18:42

Hi all

Can any one explain why my Porteus Desktop edition (3) is constantly receiving data over the Ethernet.
To confirm I typed the following in a terminal and ran every now and again and sure enough the received bytes kept on incrementing
along with the activity LED flashing.

Code: Select all

ifconfig eth1 | grep RX
Note that eth1 in the Ethernet and eth0 the wifi.

Thanks in advance.
Dave

User avatar
Ed_P
Contributor
Contributor
Posts: 3419
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

Re: Constant receiving on LAN?

Post#2 by Ed_P » 16 May 2014, 21:07

Dave99 wrote: why my Porteus Desktop edition (3) is constantly receiving data over the Ethernet.
Are you sure it isn't receiving checks from the router that you're still connected?
Ed

donald
Full of knowledge
Full of knowledge
Posts: 1244
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Re: Constant receiving on LAN?

Post#3 by donald » 16 May 2014, 21:16

That would interest me too.
I also noticed this.
Look here:
viewtopic.php?f=113&t=2358#p16589

User avatar
brokenman
Site Admin
Site Admin
Posts: 5656
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Constant receiving on LAN?

Post#4 by brokenman » 17 May 2014, 01:20

Boot standard vanilla porteus
Connect to the internet
Wait 1 minute
issue: netstat -t -u

What is the output?
How do i become super user?
Wear your underpants on the outside and put on a cape.

Dave99
Black ninja
Black ninja
Posts: 54
Joined: 19 Apr 2014, 20:15
Distribution: Porteus
Location: R.S.A.

Re: Constant receiving on LAN?

Post#5 by Dave99 » 17 May 2014, 11:23

Hi all

Ed_P wrote:
Are you sure it isn't receiving checks from the router that you're still connected?
All the time? surely not.

donald wrote:
That would interest me too.
I too am very interested in what is causing this, will keep you posted.

brokenman wrote:
Boot standard vanilla porteus
Connect to the internet
Wait 1 minute
issue: netstat -t -u

What is the output?
Will do so on Monday when back at the office.
Thanks.

donald
Full of knowledge
Full of knowledge
Posts: 1244
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Re: Constant receiving on LAN?

Post#6 by donald » 17 May 2014, 19:52

@brokenman
yup, netstat, I know...
But because I do not see this behavior with my 2nd OS (Slitaz) I'm assuming
this is not necessary to hold the Line.(Router, Probe / response)
therefore the Question is still remaining,what causes the flashing WiFi-LED
indicating Network Traffic.

Dave99
Black ninja
Black ninja
Posts: 54
Joined: 19 Apr 2014, 20:15
Distribution: Porteus
Location: R.S.A.

Re: Constant receiving on LAN?

Post#7 by Dave99 » 17 May 2014, 20:35

@donald

I don't use Slitaz but I do use Puppy, Tiny Core, XP and 7 and have never seen this behaviour before.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5656
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Constant receiving on LAN?

Post#8 by brokenman » 17 May 2014, 22:29

If you are talking about traffic between your computer (running vanilla Porteus) and the wireless then I do not see this but I guess it will depend heavily on your modem brand/model and wireless drivers.

For the link between your modem and ISP, there will always be traffic backwards and forwards as they send ARP requests and check that you ip is in use etc. It could even be the driver code in the kernel as in this link:

http://askubuntu.com/questions/12069/ho ... g-wifi-led
How do i become super user?
Wear your underpants on the outside and put on a cape.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4625
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Constant receiving on LAN?

Post#9 by fanthom » 18 May 2014, 08:42

@donald/Dave

maybe you could install wireshark and track what type of traffic it is?
Please add [Solved] to your thread title if the solution was found.

Dave99
Black ninja
Black ninja
Posts: 54
Joined: 19 Apr 2014, 20:15
Distribution: Porteus
Location: R.S.A.

Re: Constant receiving on LAN?

Post#10 by Dave99 » 18 May 2014, 09:21

@fanthom

Good idea.
I assume the SlackBuild at the url below will be OK?

http://slackbuilds.org/repository/12.1/ ... wireshark/


Dave.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4625
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Constant receiving on LAN?

Post#11 by fanthom » 19 May 2014, 19:36

no as it's 6 years old. please use precompiled package - download it through USM.
Please add [Solved] to your thread title if the solution was found.

Dave99
Black ninja
Black ninja
Posts: 54
Joined: 19 Apr 2014, 20:15
Distribution: Porteus
Location: R.S.A.

Re: Constant receiving on LAN?

Post#12 by Dave99 » 20 May 2014, 17:52

Hi fanthom

I don't like using USM as it has never worked properly for me in so far as it does not always collect/report on the required dependencies.

EXAMPLE 1:

Tried VLC, after downloading everything required and converting to XZM, and activating the new module in /temp/usm, I launched vlc and it complains that I need qt4 plug-in compiled, it could have checked it first.

EXAMPLE 2:

Tried wireshark and after everything complained about not finding liblua.so
I did a 'whereis' and sure enough only thing is liblua.a

User avatar
fanthom
Site Admin
Site Admin
Posts: 4625
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Constant receiving on LAN?

Post#13 by fanthom » 20 May 2014, 17:57

USM tracks only shared libs and everything ".a" is static.
please download 'lua' package through USM and check if that helps.
Please add [Solved] to your thread title if the solution was found.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5656
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Constant receiving on LAN?

Post#14 by brokenman » 21 May 2014, 16:07

USM is adaptable, meaning that if people post these 'missing libraries' I can add them to the database so USM picks them up.
How do i become super user?
Wear your underpants on the outside and put on a cape.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4625
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Constant receiving on LAN?

Post#15 by fanthom » 21 May 2014, 16:20

very good.
i still have an old PPM database of functional deps somewhere so will send it to you.
Please add [Solved] to your thread title if the solution was found.

Post Reply