[SOLVED] nvidia speed

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
Post Reply
Burninbush
Power user
Power user
Posts: 49
Joined: 29 Dec 2010, 01:46
Location: Near SF, CA

[SOLVED] nvidia speed

Post#1 by Burninbush » 23 Feb 2011, 22:18

Again, I dunno if this is a bug or not -- just a request for info maybe.

I have various 32bit and 64bit distros installed here on two machines, both have nvidia video hardware.

My issue is this: glxgears and other vid benches run ~2x as fast on 32bit linux/kde3 vs 64bit linux/kde4.

I have tried both the supplied nvidia module and compiled them from the nvxx.run files -- makes no difference.

What am I missing? One thing about the 64bitters, all are running kde4, if that makes the difference. Though I dunno why it should --

User avatar
brokenman
Site Admin
Site Admin
Posts: 5439
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: nvidia speed

Post#2 by brokenman » 24 Feb 2011, 04:05

Can you please try something for me?

Open a console annd type: ps a and look for the process ID for /usr/bin/X
then issue: renice -4 -p <pid>

Run your glxgears test again and is there an improvement?
How do i become super user?
Wear your underpants on the outside and put on a cape.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4547
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: nvidia speed

Post#3 by fanthom » 24 Feb 2011, 08:31

@bb
does it make any difference if you run LXDE instead of KDE?
Please add [Solved] to your thread title if the solution was found.

User avatar
Hamza
Warlord
Warlord
Posts: 1846
Joined: 28 Dec 2010, 07:41
Distribution: Porteus
Location: France

Re: nvidia speed

Post#4 by Hamza » 02 Mar 2011, 14:26

@fanthom

I think , because , the manager of the graphics card is different in LXDE or in KDE .

An example for the sound card:

In KDE3 , we have ALSA or OSS for the sound manager

but , in KDE4 , we have Phonon

For LXDE , I do not know , because , i do not use LXDE Desktop. :sorry: , but it is perfect for laptop !

and , if you want a better speed on your graphic card or CPU or maybe Ethernet Card , you can use the "Overlocking" , but it is very dangerous =@
NjVFQzY2Rg==

Burninbush
Power user
Power user
Posts: 49
Joined: 29 Dec 2010, 01:46
Location: Near SF, CA

Re: nvidia speed

Post#5 by Burninbush » 10 Mar 2011, 20:11

FWIW, I'm beginning to think that my glxgears issue might be a motherboard failure of some esoteric sort -- latest issue is a bizarre error message when I try to locally compile an nvidia-xx.run file. I get an error "extraction failed", sometimes includes text "caught signal" -- download latest version, same failure; move entire distro and .run file to the other desktop and it extracts fine. The error occurs before nvidia has an opportunity to create a log file, so I have no clue what exactly failed. I have swapped the vid card, made no difference at all. 32-bit distros on it will still compile similar-vintage nvidia files without error.

Meantime, in further searching I have by now found several distros here that run glxgears under KDE4 at the same speed as it runs under LXDE, or older kde3 on the same platform. Latest is Mepis 11, running at this moment.

Mobo in question seems to pass all diags that I have here [most running under XP or win2k] -- so I'm still stumped by this.

I will just add that for nvidia machines which refuse to run the noveau driver, doing the compile is difficult, requires a changes-save mechanism to keep the blacklist file that the nvidia run file makes, through a reboot. This was not a problem with the older nv driver. Can't imagine that a noob would ever make it past this. So I guess the message to developers would be, make sure that a nvidia module is available at the time a new kernel appears.

Posted after 2 hours 5 minutes 6 seconds:
Continuing with my gripe-session ... I'm using the port v1.0 x86_64 beta.

-- after copying the frugal install to the newer desktop, including the nvidia driver now at the repo, found that the nvidia driver will run, but produces a screwed mouse cursor, looks like 4 cursors overlapped.

-- v1 would NOT recognize that my changes file even existed -- so used rootcopy to get past the nouveau driver blacklist issue, after which I was then successful at compiling my own nvidia driver. Works, solves the mouse cursor issue. Could this be due to a 4-core cpu?

-- changes= does not seem to recognize /dev/part/filename.dat syntax, but changes=filename.dat is accepted. FWIW, this is with the .dat file on the same vfat partition where port64beta frugal install is located.

-- finally, it's running. Glxgears speed is now nominal, same as in all 32-bit distros, same as in lxde.

-- think someone else mentioned timezone issues -- reports error when I try to set it, and this will probably prevent tork/tor/privoxy from working; that requires accurate time setting.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4547
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: nvidia speed

Post#6 by fanthom » 10 Mar 2011, 23:49

Finally good news bb :)

some explanation to problems which you have encounter:
"-- after copying the frugal install to the newer desktop, including the nvidia driver now at the repo, found that the nvidia driver will run, but produces a screwed mouse cursor, looks like 4 cursors overlapped."
i guess that nvidia binary blacklists nouveau fine but is not aware of super-hyper-crappy 'modesetting' userspace driver introduced in Slackware Mesa ( :shock: ) package.
there must be a reason of existence of this driver but i dont see any... if anybody have any idea why it is there and what kind of job it does - let me know.
it will be wiped out forever since next release, also should not exist when SP1 is applied.

"-- v1 would NOT recognize that my changes file even existed -- so used rootcopy to get past the nouveau driver blacklist issue, after which I was then successful at compiling my own nvidia driver. Works, solves the mouse cursor issue. Could this be due to a 4-core cpu?"
rather not

"-- changes= does not seem to recognize /dev/part/filename.dat syntax, but changes=filename.dat is accepted. FWIW, this is with the .dat file on the same vfat partition where port64beta frugal install is located."
this sound like a problem in linuxrc which appeared after adding 'lazy' devices support. i must have sc**w up something. will check it...

"-- think someone else mentioned timezone issues"
this is due to downgraded 'polkit' package: reasons are in 64bit BETA thread.

"-- finally, it's running. Glxgears speed is now nominal, same as in all 32-bit distros, same as in lxde."

Great news!
and thanks for the feedback.

please add [Solved]

Posted after 2 hours 34 minutes 22 seconds:
UPDATE

burninbush is right - i have removed sed /dev -> /mnt translation for 'changes=' cheatcode (dont know what i was thinking).
you can still use 'changes=/mnt/part/filename.dat' syntax.
/dev/part/filename.dat will be fixed in SP2 :)

Thanks a lot!
Please add [Solved] to your thread title if the solution was found.

hypomania
Samurai
Samurai
Posts: 117
Joined: 10 Mar 2011, 10:50
Distribution: Windows phone
Location: Saudi Arabia

Re: nvidia speed

Post#7 by hypomania » 11 Mar 2011, 02:41

fanthom wrote:@bb
does it make any difference if you run LXDE instead of KDE?
I test nvidia speed on both LXDE and KDE , but no deference and still big fonts in both desktops.
also I notify the battery of laptop is running fast , through 45 minutes will finish if I will not connect it with Electricity !

User avatar
brokenman
Site Admin
Site Admin
Posts: 5439
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: nvidia speed

Post#8 by brokenman » 21 Mar 2011, 23:41

Arabic_World wrote:I notify the battery of laptop is running fast , through 45 minutes will finish if I will not connect it with Electricity !
Do you have dual switchable graphics?
How do i become super user?
Wear your underpants on the outside and put on a cape.

Post Reply