load custom audio mixer setting at boot

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
stevek
Ronin
Ronin
Posts: 2
Joined: 04 Apr 2014, 09:23
Distribution: porteus
Location: Australia

load custom audio mixer setting at boot

Post#1 by stevek » 04 Apr 2014, 09:36

Hello,

I have a problem. Every time I boot porteus for one of my laptop the speaker started to make a very loud noise (like a siren :-( ) so I have to quickly click Audio and Mute it it.

What I see is the 'Internal Mic Boost' is set to 100%. How can I reset it to 0 for this machine. Other machine booted fine.

I tried to play around with /etc/asound.state and /etc/rc.d/rc.alsa - can be sure that currently from the state file, Internal Mic Boost is set 0 - but it is still happening -

thanks in advance

stevek
Ronin
Ronin
Posts: 2
Joined: 04 Apr 2014, 09:23
Distribution: porteus
Location: Australia

Re: load custom audio mixer setting at boot

Post#2 by stevek » 04 Apr 2014, 09:45

OK so I found that save-session does not actually save the current /var/lib/alsa/asound.state! Is it a bug or mis-feature?

So I run alsactl store and then manually copy it and compress the changes file module - now it works.

anyway it works now

User avatar
freestyler
Contributor
Contributor
Posts: 382
Joined: 17 Oct 2013, 14:21
Distribution: Porteus KDE4
Location: Traveller
Contact:

Re: load custom audio mixer setting at boot

Post#3 by freestyler » 04 Apr 2014, 09:48

sweet
https://www.porteus-apps.org

cttan
Shogun
Shogun
Posts: 332
Joined: 26 Jan 2011, 16:15
Distribution: Porteus 3.2 64bit KDE
Location: Malaysia

Re: load custom audio mixer setting at boot

Post#4 by cttan » 04 Apr 2014, 09:58

Hi stevek,

You can put volume=0% in the APPEND line in your /boot/syslinux/porteus.cfg file.
Normally I start with 20%

I also hate it when the speaker start up with a loud chime and wake up everybody.

Post Reply