[Solved] System Time

Here you can post about the issues related to modifications performed manually (not through the kiosk wizard). Example: swapped kernel, added 3rd party modules or files.
Please describe in detail what has been changed and hopefully other kiosk user will be able to help.
Porteus team wont resolve bugs posted in this category as we support only modifications made by the kiosk wizard.
Post Reply
rh102801
Black ninja
Black ninja
Posts: 48
Joined: 21 Mar 2014, 14:02
Distribution: porteus 3.7 kiosk
Location: Chattanooga

[Solved] System Time

Post#1 by rh102801 » 01 Apr 2014, 17:52

During the ISO build process from the Wizard, I selected US/Eastern as my time zone; however, the system time appears to be about 4 hours off.
We run an HTML file that pulls the system time and displays it in a webpage. The time is 4 hrs off from the system Bios which I verified to be the correct time.

Is there a way to verify that it really is applying the setting I chose on the ISO creation Wizard where I specified US/Eastern?

This is part of the reason I had another post looking for a way to use an NTP server to acquire the time.
If I can't this to work I'll try to get the website to get the time from somewhere else instead.

Thanks
Last edited by rh102801 on 02 Apr 2014, 14:05, edited 1 time in total.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4566
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: System Time

Post#2 by fanthom » 02 Apr 2014, 07:09

please check on this website:
http://www.uize.com/examples/digital-clock.html

as yesterday i have created 2 ISOs through our wizard: one with timezone set to 'Europe/Minsk' and one with 'Europe/Dublin' and there was 2 hrs difference between them so i assume it's working ok.

EDIT:\\
after some reading i think i have got it now :)
https://wiki.archlinux.org/index.php/time#Time_standard

your hardware clock (RTC/time in the BIOS) must be set to localtime and kiosk is expecting the UTC one. UTC is better as Daylight Saving Time will be adjusted automatically. to fix you hw clock please do as follows:

a) generate ISO with ssh component enabled and time set to your timezone (ie: Europe/Warsaw)
b) boot kiosk and login through ssh
c) set the time manually, ie:

Code: Select all

date --set "5 Aug 2012 12:54"
c) run 'hwclock --systohc --utc' command to save current time to the RTC
d) after reboot everything should be ok
Please add [Solved] to your thread title if the solution was found.

rh102801
Black ninja
Black ninja
Posts: 48
Joined: 21 Mar 2014, 14:02
Distribution: porteus 3.7 kiosk
Location: Chattanooga

Re: [Solved] System Time

Post#3 by rh102801 » 02 Apr 2014, 14:11

As always fanthom excellent instructions.
I had some trouble with the command to set the date and time. This is what I typed:

root@porteus:~# date --set "2 Apr 2014 09:02"
date: invalid date '2 Apr 2014 09:02'
Note: I also tried April instead of Apr (I am sure the answer is something simple)

I tried a few combinations and finally opted for just entering the time since the date seemed to be already correct

root@porteus:~# date +%T -s "09:07:00"
09:07:00


and then
root@porteus:~# hwclock --systohc --utc
root@porteus:~# reboot


Upon reboot everything was as it should.

Thank you so much, you rock.

Post Reply