[Solved] Newbie Issues (Save, UPM) etc.

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
eldogbbhed
White ninja
White ninja
Posts: 9
Joined: 27 Mar 2014, 21:27
Distribution: Proteus3.0
Location: USA

[Solved] Newbie Issues (Save, UPM) etc.

Post#1 by eldogbbhed » 27 Mar 2014, 21:45

I'm using 32bit LXDE Porteus 3.0

First off, I can understand clearly how to create a save file, and that I have to change the .cfg file to point to it.

The thing is, the instructions say to do this but don't say how you're supposed to be able to alter a .cfg file that is on a read-only CD when running it live. If I boot Slitaz I can maybe extract the files from the iso and re-build it and burn it and *maybe* that will work, but it still just seems like a total oversight to require changing what is a read-only file if booting from a live CD.

Secondly, I'm assuming the changes=/porteus should be changed to =/sda1/path/save.dat - but I'm wondering if sda1(my hard drive) is 'defined' as /porteus. I don't want to re-build the iso twice just to be able to save.

Thirdly, after getting the UPM database the package manager *appears* to work, but it doesn't seem to actually make modules from slackware packages; /tmp/upm/ remains empty after a success message in UPM telling me my files are there. This I can work around by manually downloading slackware packages and installing via the tools in UPM but it's getting a bit tedious.

Fourth, is bluetooth. I manually installed all the packages/dependencies(I think), including the python stuff etc. and got a bluez isn't running error and another out of blueman and some console output. I'll have to try all over again later to get the specifics as I couldn't save.

Other than all that I have to say thus far Porteus performs well and I really do like it.
Last edited by eldogbbhed on 30 Mar 2014, 07:12, edited 1 time in total.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5436
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Newbie Issues (Save, UPM) etc.

Post#2 by brokenman » 27 Mar 2014, 22:22

First of all welcome to Porteus.

To address the non writable issue. It seems a little counter intuitive that one would burn Porteus to non writable media and then want persistent changes (i.e writes) however this is achievable. The easiest way would be to edit your .cfg file before burning your disk by unpacking the ISO, making the edit and then using the script in the porteus folder to regenerate the ISO file for burning. Another option which may be more interesting and doesn't require remastering is to create a folder somewhere on your HD (let's say /mnt/sda2/mysaves) and then when you want to save a session you can use the 'Porteus Settings Centre' to save the session as a module, which you subsequently place in this mysaves folder. During boot, at the boot menu (and only if you choose to load the saves) you hit TAB and enter the cheat extramod=/mnt/sda2/mysaves and you module with persistent changes will be loaded. These cheat codes are documented in boot/docs/cheatcodes.txt and can be added to your porteus.cfg file instead of entering them at the command line if you choose.

Secondly, I'm assuming the changes=/porteus should be changed to =/sda1/path/save.dat
Correct. Give the absolute path to the save file. Remove the /porteus completely. If the partition on which you are saving changes is a native linux file system then a save.dat is not required. Just a folder will suffice.

Regarding USM. Which version are you using. Please post the output of: usm -v
I havn't seen this happen before nor had it reported.

Bluetooth. This is the thorn in my side also. I am struggling with this on two other desktops. I believe it works in KDE but I am as yet unable to get a GUI working for mate, razor or gnome-3.10. Sorry I can't help on this one but no doubt someone else will.

Hopefully some of these suggestions are useful to you. If not we are always open to suggestions and discussion on how to improve Porteus.
How do i become super user?
Wear your underpants on the outside and put on a cape.

eldogbbhed
White ninja
White ninja
Posts: 9
Joined: 27 Mar 2014, 21:27
Distribution: Proteus3.0
Location: USA

Re: Newbie Issues (Save, UPM) etc.

Post#3 by eldogbbhed » 28 Mar 2014, 02:57

Thank you for the very helpful response. I think I can get the save file going now and I will use the module-save feature until I get to re-mastering the disc.

The version of USM is the latest one I believe- 3.1 which you thankfully posted in response to someone else's issue of the database being broken- I downloaded both packages and installed with upm and that allowed it to find the packages and seemingly make the modules except they aren't in tmp/upm.

However I will go back later and try usm -v to verify that 3.1 is in fact installed. Perhaps upm can't be installed properly outside the terminal or something. I was doing it through the existing upm gui.

I'm trying to get my bluetooth keyboard+touchpad to work with it and I just might manage that in time. In fact I'll have to do that to make Proteus my preferred OS. If I manage it I'll post an update here :D .

Anyway, thanks a lot!

eldogbbhed
White ninja
White ninja
Posts: 9
Joined: 27 Mar 2014, 21:27
Distribution: Proteus3.0
Location: USA

Re: Newbie Issues (Save, UPM) etc.

Post#4 by eldogbbhed » 28 Mar 2014, 16:57

USM is now working perfectly- I just had to 'update all'- didn't do that before.

I guess that just leaves the bluetooth.

I got a bluez daemon is not running error, and when starting blueman-manager from terminal [edit] I got an error as well, but now I think I've fixed it

User avatar
brokenman
Site Admin
Site Admin
Posts: 5436
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Newbie Issues (Save, UPM) etc.

Post#5 by brokenman » 28 Mar 2014, 20:36

Good news. Let us know how you get on.
How do i become super user?
Wear your underpants on the outside and put on a cape.

eldogbbhed
White ninja
White ninja
Posts: 9
Joined: 27 Mar 2014, 21:27
Distribution: Proteus3.0
Location: USA

Re: Newbie Issues (Save, UPM) etc.

Post#6 by eldogbbhed » 28 Mar 2014, 20:47

Ok, it seems that after saving (and perhaps a terminal command or two like 'hciconfig hci0 up') and restarting, I have fixed the problem and my bluetooth mini-keyboard+touchpad is running just fine. The applet starts up at boot and works correctly as far as I can tell. 8)

Thanks again for setting me straight on the save options, Brokenman!

Hopefully this will help others that need bluetooth in Proteus3.1LXDE...

The following modules were installed first:

aaa_elflibs-14.0-i486-4.xzm
blueman-porteus2.1-i486-1dk.xzm (From another thread on the forum)
blueman-r708-i486-2.xzm
bluez-4.99-i486-2.xzm
bluez-firmware-1.2-i486-1.xzm
dbus-python-1.1.0-i486-1.xzm
git-1.7.12.1-i486-1.xzm
gst-plugins-base-0.10.36-i486-2.xzm
gstreamer-0.10.36-i486-1.xzm
gtk+3-3.4.4-i486-1.xzm
libidl-0.8.14-i486-1.xzm
libxcb-1.8.1-i486-1.xzm
modules.txt
notify-python-0.1.1-i486-3.xzm
ORBit2-2.14.19-i486-3sl.xzm
pycairo-1.8.10-i486-2.xzm
pygobject-2.28.6-i486-2.xzm
pygtk-2.24.0-i486-1.xzm
python-2.7.3-i486-2.xzm
tcl-8.5.11-i486-1.xzm
tk-8.5.11-i486-1.xzm
xcb-util-0.3.8-i486-1.xzm

Because I had to save+reboot to get it to work, some of these may have been unnecessarily installed but I'm not going to try to find out now that it works.

I hope this helps and good luck to anyone with similar difficulties!

eldogbbhed
White ninja
White ninja
Posts: 9
Joined: 27 Mar 2014, 21:27
Distribution: Proteus3.0
Location: USA

Re: Newbie Issues (Save, UPM) etc.

Post#7 by eldogbbhed » 28 Mar 2014, 21:26

Looks like I spoke too soon.

Now Porteus won't boot to the gui- just a black screen.

This is odd, because I didn't add any new modules.

1. I first had the modules installed, then saved.
2. On reboot, bluetooth worked.
3. I paired the device, then saved again, but then black screen on reboot.
4. Then I started from scratch and re-installed the modules, saved and then on reboot, rather than having bluetooth I get the blank screen.

The last message in the console is something like login: network manager, and lists a lib that has an apparent error when looking for a 'symbol' or something.

So I'm going to play with this some more and isolate the offending module assuming that's the problem. But being as it worked, then didn't with me doing nothing but pairing my keyboard and saving/rebooting- I'm a bit baffled as to how this could be.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4547
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Newbie Issues (Save, UPM) etc.

Post#8 by fanthom » 28 Mar 2014, 22:03

you are on porteus-3.0 which is slack-14.1 based and i see 'aaa_elflibs-14.0-i486-4.xzm' which is from slack-14.0.
this package holds many libs and it simply cant work in this setup.
Please add [Solved] to your thread title if the solution was found.

eldogbbhed
White ninja
White ninja
Posts: 9
Joined: 27 Mar 2014, 21:27
Distribution: Proteus3.0
Location: USA

Re: Newbie Issues (Save, UPM) etc.

Post#9 by eldogbbhed » 28 Mar 2014, 22:13

Ah, I see. I will try to get them from USM then and see if that helps. It was one I downloaded manually from the repositories and guessed it was based on 14.0

Thank you!

User avatar
brokenman
Site Admin
Site Admin
Posts: 5436
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Newbie Issues (Save, UPM) etc.

Post#10 by brokenman » 29 Mar 2014, 03:00

At least version python-2.7.5-i486-1.txz should be used instead.
blueman-porteus2.1-i486-1dk.xzm is also from slackware 14.0 (Porteus 2.1) The blueman-r708-i486-2.xzm should be enough.

The mate desktop has the majority of these dependencies shipped with it. Including python and friends and gstreamer.

It's great that you got some life (albeit short lived) from bluetooth and the black screen probably came from the aaa mismatch.
How do i become super user?
Wear your underpants on the outside and put on a cape.

eldogbbhed
White ninja
White ninja
Posts: 9
Joined: 27 Mar 2014, 21:27
Distribution: Proteus3.0
Location: USA

Re: Newbie Issues (Save, UPM) etc.

Post#11 by eldogbbhed » 29 Mar 2014, 20:17

Yes, it seems to work fine with the correct aaa lib and updated python now.

But now I've re-mastered the disc to load my save file on boot and that appears to work, however it appears to be 'fresh' with none of the changes I saved. I then re-loaded the modules, then saved and again it loads the save on boot but still boots to a 'fresh' system. I must be missing something there. I can do the extramod cheat code but I prefer to save it to the .dat container and not have to enter the cheat code on boot so I'll keep playing with it and see if I can fix that.

Edit: I did both. I re-mastered the disc to load both the extra modules and the save file. I was under the impression these modules were saved in the .dat rather than just settings etc.

Thanks guys!

Post Reply