Wireless only in "always fresh"

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
sim
White ninja
White ninja
Posts: 4
Joined: 26 Mar 2014, 06:35
Distribution: mint
Location: poland

Wireless only in "always fresh"

Post#1 by sim » 26 Mar 2014, 07:54

Hello! My problem is simple.

In "always fresh" mode Porteus runs as it should.

In standard LXDE mode, there is no wireless connection - when clicking the icon of Internet connection, in wireless section there is a label "device is not ready". When activating pns-tool/xpns-tool via terminal, wifi manager does not show any devices as well.

The hardware is netbook Asus EEE with Windows XP, I boot Porteus from pendrive, ext2 file system, produced under Linux Mint.

Thanks for help!

tome
Contributor
Contributor
Posts: 562
Joined: 26 Jun 2013, 14:03
Distribution: x64 Openbox
Location: Poland
Contact:

Re: Wireless only in "always fresh"

Post#2 by tome » 26 Mar 2014, 09:26

Cześć sim!
Rename your changes folder to changes-old and try again in standard LXDE mode.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4567
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Wireless only in "always fresh"

Post#3 by fanthom » 26 Mar 2014, 10:24

perhaps this:

Code: Select all

nonetwork

   ... This boot parameter will prevent Porteus from automatically
       establishing a network connection on start-up.
       Note that this cheatcode makes some modifications to
       your system which must be manually restored, so it is
       recommended that you only use this cheatcode in "Always
       Fresh" mode. If you've ignored this advice and need to
       recover your network connection, please run the following:

       chmod +x /etc/rc.d/rc.inet1 /etc/rc.d/rc.networkmanager
       sed -i 's/Hidden=true//g' /etc/xdg/autostart/nm-applet.desktop
Please add [Solved] to your thread title if the solution was found.

User avatar
francois
Contributor
Contributor
Posts: 4947
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: Wireless only in "always fresh"

Post#4 by francois » 26 Mar 2014, 11:27

@fanthom:
You really know them all! :o
Voltaire: Le mieux est l'ennemi du bien.

sim
White ninja
White ninja
Posts: 4
Joined: 26 Mar 2014, 06:35
Distribution: mint
Location: poland

Re: Wireless only in "always fresh"

Post#5 by sim » 26 Mar 2014, 18:00

Thanks, but both solution did not work.

In the second one terminal displayed "no such directory or folder" message...

User avatar
brokenman
Site Admin
Site Admin
Posts: 5461
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Wireless only in "always fresh"

Post#6 by brokenman » 26 Mar 2014, 18:22

In "always fresh" mode Porteus runs as it should.
This means in the other mode you have made a modification that prevents it from working as it should.
In the second one terminal displayed "no such directory or folder" message...
Please be more specific. What is 'the second one'? If these files or folders don't exist then something is wrong with your installation.

Finally, please boot into the non working mode and use the Porteus Settings Centre to generate a system information dump. Save it somewhere, boot into fresh mode and upload it to pastebin and post the link here.
How do i become super user?
Wear your underpants on the outside and put on a cape.

sim
White ninja
White ninja
Posts: 4
Joined: 26 Mar 2014, 06:35
Distribution: mint
Location: poland

Re: Wireless only in "always fresh"

Post#7 by sim » 26 Mar 2014, 19:00

brokenman wrote:
In "always fresh" mode Porteus runs as it should.
This means in the other mode you have made a modification that prevents it from working as it should.
I didn't do any changes - it was first start.
In the second one terminal displayed "no such directory or folder" message...
Please be more specific. What is 'the second one'? If these files or folders don't exist then something is wrong with your installation.

Finally, please boot into the non working mode and use the Porteus Settings Centre to generate a system information dump. Save it somewhere, boot into fresh mode and upload it to pastebin and post the link here.
As for second solution: I put suggested line in terminal

Code: Select all

  chmod +x /etc/rc.d/rc.inet1 /etc/rc.d/rc.networkmanager
and received mentioned message.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4567
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Wireless only in "always fresh"

Post#8 by fanthom » 26 Mar 2014, 21:35

maybe you deleted those scripts or some other important files? please provide mentioned xpsinfo report and show me the output of:

Code: Select all

find /mnt/live/memory/changes -name ".wh.*"
this command will show us the files which have been deleted from core modules.
thanks
Please add [Solved] to your thread title if the solution was found.

sim
White ninja
White ninja
Posts: 4
Joined: 26 Mar 2014, 06:35
Distribution: mint
Location: poland

Re: Wireless only in "always fresh"

Post#9 by sim » 26 Mar 2014, 22:55

Code: Select all

/mnt/live/memory/changes/.wh..wh.plnk
/mnt/live/memory/changes/.wh..wh.orph
/mnt/live/memory/changes/.wh..wh.aufs

tome
Contributor
Contributor
Posts: 562
Joined: 26 Jun 2013, 14:03
Distribution: x64 Openbox
Location: Poland
Contact:

Re: Wireless only in "always fresh"

Post#10 by tome » 28 Mar 2014, 07:36

Are you connected to power supply and have activated proper modules like in always fresh mode?

User avatar
francois
Contributor
Contributor
Posts: 4947
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: Wireless only in "always fresh"

Post#11 by francois » 28 Mar 2014, 12:15

Another suggestion that usually does the trick with wifi pns-tool. In command line issue the following command:

Code: Select all

root@porteus:~# pns-tool
See the following thread:
viewtopic.php?f=123&t=2971
Voltaire: Le mieux est l'ennemi du bien.

Post Reply