[Solved] Blank Screen in many Sites using Chrome in KDE.

Post here if you are a new Porteus member and you're looking for some help.
User avatar
francois
Contributor
Contributor
Posts: 5080
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: Blank Screen in many Sites using Chrome in KDE.

Post#16 by francois » 22 Mar 2014, 17:37

No matter how you name it, as much as there is a .xzm at the end.
brokenman wrote: ...
The real 'always fresh' mode uses the boot option 'base_only' which means nothing in modules folder will be loaded.
...
I have made a test. When I reboot with no instructions into the changes= cheatcode area, my libreoffice module will boot in always fresh mode. Is there another way to really be in always fresh mode^ :%)
Voltaire: Le mieux est l'ennemi du bien.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4617
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Blank Screen in many Sites using Chrome in KDE.

Post#17 by fanthom » 22 Mar 2014, 18:26

my libreoffice module will boot in always fresh mode. Is there another way to really be in always fresh mode^ :%)
modules maintained by us (Porteus Team):
http://dl.porteus.org/x86_64/current/modules/
have names starting with 0* and are considered as "safe" so are not affected by 'base_only' cheatcode. Drivers are also maintained by us, but may cause troubles so it's better to not name them as 0* - this way they wont be loaded when 'base_only' cheat is used.
Please add [Solved] to your thread title if the solution was found.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5574
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Blank Screen in many Sites using Chrome in KDE.

Post#18 by brokenman » 22 Mar 2014, 23:53

There are various ways to tackle the boot option.
1) You can remove base_only from the always fresh mode and leave the driver module in modules folder
2) You can put your driver in porteus/optional and then add load=nVidia to the boot line
3) You can put it in the base folder

I recommended adding a 0 (zero) to the front of the name because in always fresh mode (base_only) only module in the base folder starting with 0 are loaded.

You see an asterisk at the end because all your files have the executable bit set. Probably on a FAT32 partition.
How do i become super user?
Wear your underpants on the outside and put on a cape.

User avatar
francois
Contributor
Contributor
Posts: 5080
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: Blank Screen in many Sites using Chrome in KDE.

Post#19 by francois » 23 Mar 2014, 00:37

Ok. I got it. Did not noticed about that cheatcode, as I never used it or never came across it yet:
http://www.porteus.org/tutorials/26-gen ... -them.html
base_only

... This cheatcode will prevent the system from loading any
modules at startup other than the 'base' modules included
with the default ISO (000-kernel.xzm, 001-core.xzm, etc).
This is useful in debugging to see if problems you are
having are associated with some module you've added to the
system.
These cheatcodes are really handy to customize porteus.

Thanks, for the additional knowledge. :wink:
Voltaire: Le mieux est l'ennemi du bien.

mparillo
White ninja
White ninja
Posts: 22
Joined: 14 Mar 2014, 19:11
Distribution: Porteus-KDE-v3.1-i486 Chrome
Location: USA

Re: Blank Screen in many Sites using Chrome in KDE.

Post#20 by mparillo » 23 Mar 2014, 01:48

brokenman wrote:There are various ways to tackle the boot option.
1) You can remove base_only from the always fresh mode and leave the driver module in modules folder
2) You can put your driver in porteus/optional and then add load=nVidia to the boot line
3) You can put it in the base folder

I recommended adding a 0 (zero) to the front of the name because in always fresh mode (base_only) only module in the base folder starting with 0 are loaded.

You see an asterisk at the end because all your files have the executable bit set. Probably on a FAT32 partition.
It is FAT32, yes.

Is another way for me to simply edit /mnt/sdb1/boot/syslinux/porteus.cfg
and remove the changes=/porteus from this line:

APPEND initrd=initrd.xz changes=/porteus timezone=America/New_York

User avatar
francois
Contributor
Contributor
Posts: 5080
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: Blank Screen in many Sites using Chrome in KDE.

Post#21 by francois » 23 Mar 2014, 12:22

From porteus ,just edit /mnt/sdb1/boot/syslinux/porteus.cfg with any text editor, kwrite for example and remove the instructions associated with changes= , that is:

Code: Select all

APPEND initrd=initrd.xz changes= timezone=America/New_York
or

Code: Select all

APPEND initrd=initrd.xz timezone=America/New_York
Reboot and that is it. :wink:
Voltaire: Le mieux est l'ennemi du bien.

mparillo
White ninja
White ninja
Posts: 22
Joined: 14 Mar 2014, 19:11
Distribution: Porteus-KDE-v3.1-i486 Chrome
Location: USA

[Solved] Blank Screen in many Sites using Chrome in KDE.

Post#22 by mparillo » 23 Mar 2014, 19:42

I edited /mnt/sdb1/boot/syslinux/porteus.cfg with kate to
APPEND initrd=initrd.xz timezone=America/New_York

And using the primary option (the one labeled KDE, not the one labeled 'Always Fresh'), I hit tab and saw that changes= was not there.
I hit enter, and briefly saw the Nvidia flash up on my screen.
mail.yahoo.com and youtube appear to work.

Marking this solved.

Post Reply