USM bug reports

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
ElectriQT
Samurai
Samurai
Posts: 116
Joined: 10 Nov 2013, 12:02
Distribution: LXDE3.5Manjaro, LXDE3.01-32bit
Location: Sweden

Re: [FAA]USM bug reports

Post#286 by ElectriQT » 06 Feb 2015, 21:09

Ed_P wrote:FWIW I get the LIBS.TXT error also. On i386 systems and x86-64 systems, 3.0.1 and 3.1 releases all with different save.dat files.
Mmm, I have an upgraded 301 LXDE , with the most of its stuff now from 3.1 or updated

But I dont use savefile at all, just changes-modules And I always run it in Copy2ram as default start now, as sometimes they have no hdd or I need to hot-plug / out from a systems stick and boot an other one, or the power is lost.. and so on.
a fantastic feature in this Linux system layout I must say. :-)

What version on Bash do you run?
# bash -version

ElectriQT
Samurai
Samurai
Posts: 116
Joined: 10 Nov 2013, 12:02
Distribution: LXDE3.5Manjaro, LXDE3.01-32bit
Location: Sweden

Re: [FAA]USM bug reports

Post#287 by ElectriQT » 06 Feb 2015, 21:46

brokenman wrote:ElectriQT, please replace your usm.conf in your custom location with the one from /etc/usm/usm.conf and then make your custom changes in it again. The broken LIBS.TXT file may be because of whiteout files in your changes.
Hmm, Now I dont follow you about, how I should do it.
No, there is no usm.conf in a /root/usm Should it really be?

Not in root/usm/local/ , There it is just the "libs.txt" in my folder /local/
(libs.txt , in lowercase letters it is, but I tried rename it with highcases-letters also, no changes. )

Ok, but NOW it is, the new copy of usm.conf from etc/usm/usm.comf

Nope,No change in the LIBS.TXT not found-error, and still all the new "unary operator expected" -lines when I do an update.

(and the changes was already there in this copied original etc/usm/usm.conf file that I did copy to root/usm/local/ now. )

The LIBS-error was there also before I changed to a root/usm storage.

Ok, I even tried to deleted the file in etc/usm now, = usm will not start ,
(so that is the place it load the usm.conf from.)

I now deleted all /root/usm/ stuff

I think I really need to wipeout usm everywhere in my system and do a 3.17 clean install. Dont waste more energy on this if it is just Ed and Me having problems? So how to find all the usm-stuff&places in linux to delete? :-)

User avatar
brokenman
Site Admin
Site Admin
Posts: 5575
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: [FAA]USM bug reports

Post#288 by brokenman » 06 Feb 2015, 22:19

Ok so something in your changes modules may be affecting the LIBS.TXT file. I remember there was a problem in 3.0.1 at some stage with whiteout files.

Wiping USM out manually will not help if the problem is indeed in your save modules as they may overwrite the USM file (I don't know your module layout so it is hard to tell).
Not in root/usm/local/ , There it is just the "libs.txt" in my folder /local/
(libs.txt , in lowercase letters it is, but I tried rename it with highcases-letters also, no changes. )
This folder (root/usm/local/) should not exist and most definitely LIBS.TXT should be in uppercase. How did it become lowercase? Yes I think you need to start again with a fresh system and add your changes modules back one at a time until you find the one causing the problem. If you don't do this then the problem will never be found. ALso make sure your USM module you downloaded is the last thing to be loaded. Perhaps name it zz-usm-3.1.7-noarch-1.xzm
How do i become super user?
Wear your underpants on the outside and put on a cape.

Bogomips
Full of knowledge
Full of knowledge
Posts: 2563
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: [FAA]USM bug reports

Post#289 by Bogomips » 06 Feb 2015, 23:22

OPTIFEST?

Code: Select all

root@porteus:/home/guest# usm -g flash

 The following items were found.
 Choose an number to confirm. 
 ctrl+c to quit

1) flash-player-plugin-11.2.202.359-i386-1sl.txz
2) flash-player-plugin-11.2.202.429-i386-1sl.txz
3) flash-plugin-11.2.202.440-i686-1gv.txz
4) flashplayer-plugin-11.2.202.440-i386-1alien.txz
#? ^C
root@porteus:/home/guest# usm -s flash 

flash-player-plugin-11.2.202.429-i386-1sl.txz was found in slacky [not installed]
flash-player-plugin-11.2.202.359-i386-1sl.txz was found in slacky [not installed]
flash-plugin-11.2.202.442-i686-1gv.txz was found in salix [not installed]
chromium-pepperflash-plugin-16.0.0.305-i386-1alien.txz was found in alien [not installed]
flashplayer-plugin-11.2.202.442-i386-1alien.txz was found in alien [installed]
Packages found:   5 

root@porteus:/home/guest# usm -i flash 

 The following items were found.
 Choose an number to confirm. 
 ctrl+c to quit

1) flash-player-plugin-11.2.202.429-i386-1sl.txz
2) flash-player-plugin-11.2.202.359-i386-1sl.txz
3) flash-plugin-11.2.202.442-i686-1gv.txz
4) chromium-pepperflash-plugin-16.0.0.305-i386-1alien.txz
5) flashplayer-plugin-11.2.202.442-i386-1alien.txz
#? ^C

root@porteus:/home/guest# usm -g flashplayer-plugin-11.2.202.442-i386-1alien
 Nothing found for:  flashplayer-plugin-11.2.202.442-i386-1alien 
Minor 442 not downloadable.
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

User avatar
brokenman
Site Admin
Site Admin
Posts: 5575
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: [FAA]USM bug reports

Post#290 by brokenman » 07 Feb 2015, 12:35

Thanks Bogomips. This problem and ElectriQt's problem with the LIBS.TXT file are not related. The missing packages problem will be fixed this weekend. Just need to get time to fix the update system. Probably this Sunday. The missing LIBS.TXT problem is more complex and a result of changes modules and/or mixing of Porteus/USM versions.
How do i become super user?
Wear your underpants on the outside and put on a cape.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5575
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: [FAA]USM bug reports

Post#291 by brokenman » 08 Feb 2015, 23:08

Issue regarding fonts packages in slackware repo has been resolved. Update slackware database to test:

Code: Select all

usm -u slackware
usm -g ttf-indic
How do i become super user?
Wear your underpants on the outside and put on a cape.

Bogomips
Full of knowledge
Full of knowledge
Posts: 2563
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: USM bug reports

Post#292 by Bogomips » 09 Feb 2015, 01:28

Code: Select all

oot@porteus:/home/guest#     usm -u slackware
 Starting slackware database update 
Downloading: vercheck.txt  DONE
Downloading: CHECKSUMS.md5  DONE
Downloading: MANIFEST.bz2  DONE
Downloading: PACKAGES.TXT  DONE
Downloading: LIBS.TXT.gz  DONE
File verification was good.
Optimizing manifest
 slackware  database updated. 


root@porteus:/home/guest#     usm -g ttf-indic

 Nothing found for:  ttf-indic 

root@porteus:/home/guest#     usm -g ttf-indic-fonts

 Nothing found for:  ttf-indic-fonts 
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

User avatar
brokenman
Site Admin
Site Admin
Posts: 5575
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: USM bug reports

Post#293 by brokenman » 09 Feb 2015, 22:34

Thanks. After uploading 64bit yesterday I was locked out of sourceforge (permission denied) and couldn't upload 32bit stuff. Will do this later tonight as it seems my access is working again.
How do i become super user?
Wear your underpants on the outside and put on a cape.

Bogomips
Full of knowledge
Full of knowledge
Posts: 2563
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: USM bug reports

Post#294 by Bogomips » 10 Feb 2015, 12:17

Deficiency or Bug?

Code: Select all

root@porteus:/home/guest# usm -g openjre

 The following items were found.
 Choose an number to confirm. 
 ctrl+c to quit

1) openjre-7u51_b31-i486-2gv.txz     3) openjre-7u75_b13-i486-1alien.txz
2) openjre-7u71_b14-i486-2sl.txz
#? 2

Processing:   openjre-7u71_b14-i486-2sl.txz 
Ignored libraries: 

Libraries required:  70
Libraries found in system: 61
Libraries to resolve: 9

Processing library: libawt.so
Processing library: libcups.so.2

 More than one package contains:  libcups.so.2
cups-1.5.4-i486-3.txz        1856K  slackware
aaa_elflibs-14.1-i486-3.txz  4708K  slackware

 The following items were found.
 Choose an number to confirm. 
 ctrl+c to quit

1) cups-1.5.4-i486-3.txz
2) aaa_elflibs-14.1-i486-3.txz
#? 1
Processing library: libjava.so
Processing library: libjli.so
Processing library: libjvm.so
Processing library: libmawt.so
Processing library: libnet.so
Processing library: libnio.so
Processing library: libverify.so


Processing:   cups-1.5.4-i486-3.txz 
Ignored libraries: 

Libraries required:  27
Libraries found in system: 21
Libraries to resolve: 6

Processing library: libcups.so.2
Processing library: libcupscgi.so.1
Processing library: libcupsdriver.so.1
Processing library: libcupsimage.so.2
Processing library: libcupsmime.so.1
Processing library: libcupsppdc.so.1


 The following packages are required. 
cups-1.5.4-i486-3.txz [1856K] [not installed]
openjre-7u71_b14-i486-2sl.txz [40039K] [not installed]
rhino-1_7R4-i486-3sl.txz [1351K] [not installed]

Total size: 43 MB

 Multiple packages were detected.
 Would you like to merge the packages into one module? [y/n]
 Would you like to create a subfolder for the files? [y/n]
 Would you like to install the package/s? (custom paths are supported) [y/n]

 Press [r] to remove packages, [q] to quit, or enter to start downloading.
However here

Code: Select all

root@porteus:/home/guest# usm -g iced

 The following items were found.
 Choose an number to confirm. 
 ctrl+c to quit

1) icedtea-web-1.4.1-i486-1alien.txz  3) icedtea-web-1.5.2-i486-2alien.txz
2) icedtea-web-1.5.2-i486-1sl.txz
#? 2

Processing:   icedtea-web-1.5.2-i486-1sl.txz 
Ignored libraries: 

Libraries required:  11
Libraries found in system: 11
Libraries to resolve: 0



 The following packages are required. 
icedtea-web-1.5.2-i486-1sl.txz [1356K] [not installed]
openjre-7u71_b14-i486-2sl.txz [40039K] [not installed]

Total size: 41 MB

 Multiple packages were detected.
 Would you like to merge the packages into one module? [y/n]
 Would you like to create a subfolder for the files? [y/n]
 Would you like to install the package/s? (custom paths are supported) [y/n]
having pulled in openjre, one would expect openjre to be scanned for dependencies. Also noticed this with a couple of other packages previously.

Btw usm -g ttf-indic still failing.
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

User avatar
brokenman
Site Admin
Site Admin
Posts: 5575
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: USM bug reports

Post#295 by brokenman » 10 Feb 2015, 12:59

Updated 32bit to fix missing font.

Regarding the openjre, you need to install the module for it to be processed by USM. It doesn't process modules/packages that you may have downloaded but not installed.
I just tested by downloading openjre and installing and then processing icedtea and it didn't request openjre. Let me know if you find otherwise.
How do i become super user?
Wear your underpants on the outside and put on a cape.

Bogomips
Full of knowledge
Full of knowledge
Posts: 2563
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: USM bug reports

Post#296 by Bogomips » 10 Feb 2015, 13:39

brokenman wrote:Updated 32bit to fix missing font.
OK
brokenman wrote:USM. It doesn't process modules/packages that you may have downloaded but not installed.

Code: Select all

root@porteus:/home/guest# ls /tmp/usm/iced*
/bin/ls: cannot access /tmp/usm/iced*: No such file or directory
root@porteus:/home/guest# ls /tmp/usm/openjr*
/bin/ls: cannot access /tmp/usm/openjr*: No such file or directory
root@porteus:/home/guest# ls /tmp/usm/rhi*
/bin/ls: cannot access /tmp/usm/rhi*: No such file or directory

root@porteus:/home/guest# usm -g iced         

 The following items were found.
 Choose an number to confirm. 
 ctrl+c to quit

1) icedtea-web-1.4.1-i486-1alien.txz  3) icedtea-web-1.5.2-i486-2alien.txz
2) icedtea-web-1.5.2-i486-1sl.txz
#? 2

Processing:   icedtea-web-1.5.2-i486-1sl.txz 
Ignored libraries: 

Libraries required:  11
Libraries found in system: 11
Libraries to resolve: 0



 The following packages are required. 
icedtea-web-1.5.2-i486-1sl.txz [1356K] [not installed]
openjre-7u71_b14-i486-2sl.txz [40039K] [not installed]

Total size: 41 MB

 Multiple packages were detected.
 Would you like to merge the packages into one module? [y/n]
 Would you like to create a subfolder for the files? [y/n]
 Would you like to install the package/s? (custom paths are supported) [y/n]

 Press [r] to remove packages, [q] to quit, or enter to start downloading.
If correctly understood, all above packages should have been resolved.
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

User avatar
brokenman
Site Admin
Site Admin
Posts: 5575
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: USM bug reports

Post#297 by brokenman » 11 Feb 2015, 01:32

Ok I think I understand what you are saying. In openjre the libraries are buried 5 layers deep in the lib folder and aren't being processed. I remember having this issue before and will have to go back through notes to find why. It may be that I will need to add the dependencies into the extra file. Thanks.
How do i become super user?
Wear your underpants on the outside and put on a cape.

Bogomips
Full of knowledge
Full of knowledge
Posts: 2563
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: USM bug reports

Post#298 by Bogomips » 11 Feb 2015, 11:51

brokenman wrote:In openjre the libraries are buried 5 layers deep in the lib folder and aren't being processed.
But on its own, dependencies are being resolved

Code: Select all

root@porteus:/home/guest# usm -g openjre

 The following items were found.
 Choose an number to confirm. 
 ctrl+c to quit

1) openjre-7u51_b31-i486-2gv.txz     3) openjre-7u75_b13-i486-1alien.txz
2) openjre-7u71_b14-i486-2sl.txz
#? 2

Processing:   openjre-7u71_b14-i486-2sl.txz 
Ignored libraries: 

Libraries required:  70
Libraries found in system: 61
Libraries to resolve: 9

Processing library: libawt.so
Processing library: libcups.so.2

 More than one package contains:  libcups.so.2
cups-1.5.4-i486-3.txz        1856K  slackware
aaa_elflibs-14.1-i486-3.txz  4708K  slackware

 The following items were found.
 Choose an number to confirm. 
 ctrl+c to quit

1) cups-1.5.4-i486-3.txz
2) aaa_elflibs-14.1-i486-3.txz
#? 1
Processing library: libjava.so
Processing library: libjli.so
Processing library: libjvm.so
Processing library: libmawt.so
Processing library: libnet.so
Processing library: libnio.so
Processing library: libverify.so


Processing:   cups-1.5.4-i486-3.txz 
Ignored libraries: 

Libraries required:  27
Libraries found in system: 21
Libraries to resolve: 6

Processing library: libcups.so.2
Processing library: libcupscgi.so.1
Processing library: libcupsdriver.so.1
Processing library: libcupsimage.so.2
Processing library: libcupsmime.so.1
Processing library: libcupsppdc.so.1


 The following packages are required. 
cups-1.5.4-i486-3.txz [1856K] [not installed]
openjre-7u71_b14-i486-2sl.txz [40039K] [not installed]
rhino-1_7R4-i486-3sl.txz [1351K] [not installed]

Total size: 43 MB

 Multiple packages were detected.
 Would you like to merge the packages into one module? [y/n]
 Would you like to create a subfolder for the files? [y/n]
 Would you like to install the package/s? (custom paths are supported) [y/n]


It's only when it's being pulled in as dependency(requirement?) of another package (icedtea) that dependencies are not being resolved.
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

User avatar
brokenman
Site Admin
Site Admin
Posts: 5575
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: USM bug reports

Post#299 by brokenman » 11 Feb 2015, 23:49

Good point. Will check it out this weekend. Thanks for the report.
How do i become super user?
Wear your underpants on the outside and put on a cape.

User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Re: USM bug reports

Post#300 by Rava » 18 Feb 2015, 11:40

All went well prior updating Porteus with

Code: Select all

001-core_alldesktops-150124.xzm
002-xorg.xzm
004-xfce_fixes-150124.xzm
Now this happens:

Code: Select all

root@porteus:/usr/lib64# usm -u all
 Starting alien database update 
Downloading: vercheck.txt  DONE
Downloading: CHECKSUMS.md5.gz  DONE
Downloading: MANIFEST.bz2  DONE
Downloading: PACKAGES.TXT.gz  DONE
Downloading: LIBS.TXT.gz  DONE
File verification was good.

gzip: /var/usm/alien/LIBS.TXT.gz: not in gzip format
          

==============================================================================
WARNING!        WARNING!        WARNING!        WARNING!        WARNING!
==============================================================================
One or more errors occurred while usm was running:                       
 
FATAL ERROR!
usm update_database 259
Could not decompress: LIBS.TXT.gz
 
============================================================================== 
More info:

Code: Select all

root@porteus:/usr/lib64# file /var/usm/alien/LIBS.TXT.gz
/var/usm/alien/LIBS.TXT.gz: HTML document, ASCII text
root@porteus:/usr/lib64# ls -l /var/usm/alien/LIBS.TXT.gz
-rw-r--r-- 1 root root 635 Feb 18 06:30 /var/usm/alien/LIBS.TXT.gz
root@porteus:/usr/lib64# head /var/usm/alien/LIBS.TXT.gz
<html><head>
<title>Testing</title>
<!-- <script src="/js/jquery.com/jquery-1.11.0.min.js"></script> -->
<script src="//code.jquery.com/jquery-1.11.0.min.js"></script>
<script src="//sourceforge.net/js/mirrors.js"></script>
<script src="/js/sf.js"></script>
<script>
var DR_loc = DR_parse_hash_url();
if (DR_loc) {
    DR_sf_main(DR_loc);
The reason, from the html page:

Code: Select all

We're sorry -- the Sourceforge site is currently in Disaster Recovery mode, and currently requires
the use of javascript to function.  Please check back later.
Sure, seems like an SF issue. Can it be made that usm "reads" the error in the html file and tells the user that error?
Cheers!
Yours Rava

Post Reply