USM bug reports

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
User avatar
brokenman
Site Admin
Site Admin
Posts: 5456
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: USM bug reports

Post#226 by brokenman » 06 Nov 2014, 12:50

Ok. Please keep this thread on topic about USM. Thanks.
How do i become super user?
Wear your underpants on the outside and put on a cape.

User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Re: USM bug reports

Post#227 by Rava » 24 Nov 2014, 20:10

Can I request a new database / package provider?

According to http://pkgs.org Freestylers has 907 i486 and 1394, x86_64 packages, while Slackware itself has 1246 i486 packages, but only 1046 x86_64, so, by x86_64, it seems Freestylers got most package of all...

Anyhow, is https://porteus-apps.org affiliated with porteus?

Cause a search for "Slackware Freestylers" gave me this https://porteus-apps.org/?q=slackware
and the title of that page is freestylers slackware repository
Cheers!
Yours Rava

Bogomips
Full of knowledge
Full of knowledge
Posts: 2541
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: USM bug reports

Post#228 by Bogomips » 24 Nov 2014, 20:47

Rava wrote: Anyhow, is https://porteus-apps.org affiliated with porteus?
porteus-apps.org wrote:Porteus-apps.org is an un-official public repository for Porteus Linux xzm modules
Suppose, if it was official, would be affiliated.
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Re: USM bug reports

Post#229 by Rava » 24 Nov 2014, 21:32

^
Figured that much, still, when downloading stuff there sometime the dependencies are broken....
Cheers!
Yours Rava

Bogomips
Full of knowledge
Full of knowledge
Posts: 2541
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: USM bug reports

Post#230 by Bogomips » 24 Nov 2014, 21:35

Code: Select all

==============================================================================
WARNING!        WARNING!        WARNING!        WARNING!        WARNING!
==============================================================================
One or more errors occurred while usm was running:                       
 
FATAL ERROR!
 resolve_deps 356
Brokenman needs to update database. Could not find: LIBS.TXT
 
============================================================================== 
Whatever that means :Search:
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

User avatar
brokenman
Site Admin
Site Admin
Posts: 5456
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: USM bug reports

Post#231 by brokenman » 24 Nov 2014, 22:43

Can I request a new database / package provider?
Isn't 5 enough for you? Actually I have a copy of USM here with freestylers repo included but have not included it. I need to be 100% sure that all packages:

1) Can be resolved within slackware repositories
2) Will continue to be maintained

For this reason I am sticking to only well known/maintained repos.
Whatever that means
Hehe. It means exactly what it says. Brokenman needs to update the database. The package you searched for was found in the slackware repo but not in the LIBS.TXT file which is generated locally here.
How do i become super user?
Wear your underpants on the outside and put on a cape.

Bogomips
Full of knowledge
Full of knowledge
Posts: 2541
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: USM bug reports

Post#232 by Bogomips » 10 Dec 2014, 15:25

Failure on Attempting Upgrade

Code: Select all

root@porteus:/home/guest# usm -u usm
Downloading: vercheck.txt  DONE

 An update is available for the usm database files.
 Please run:  usm -u all 

You have the current USM version.

root@porteus:/home/guest# usm -v
 You are using USM version:  3.1.7

root@porteus:/home/guest# usm -u all
alien was updated 9728 seconds ago. Skipping.
salix was updated 9098 seconds ago. Skipping.
slacky was updated 9712 seconds ago. Skipping.
ponce was updated 9709 seconds ago. Skipping.
slackware was updated 9698 seconds ago. Skipping.
slackwarepatches was updated 9687 seconds ago. Skipping.
sbo was updated 9112 seconds ago. Skipping.

extra-deps.txt was updated 5300 seconds ago. Skipping.
ignore-deps.txt was updated 5299 seconds ago. Skipping.

You can change the time limit for skipping in: /etc/usm/usm.conf
The default is 3 hours

root@porteus:/home/guest# usm -g flashplayer-plugin

 The following items were found.
 Choose an number to confirm. 
 ctrl+c to quit

1) flashplayer-plugin-11.2.202.424-i386-1alien.txz
#? 1

Processing:   flashplayer-plugin-11.2.202.424-i386-1alien.txz 
Ignored libraries: libkdeui.so,libkutils.so,libkdecore.so,libQt,

Libraries required:  70
Libraries found in system: 70
Libraries to resolve: 0


awk: cmd. line:1: (FILENAME=- FNR=1) fatal: attempt to access field -1
grep: /etc/usm/mirrors-.txt: No such file or directory
grep: /var/usm//PACKAGES.TXT: No such file or directory
grep: /var/usm//PACKAGES.TXT: No such file or directory

 The following packages are required. 
flashplayer-plugin-11.2.202.424-i386-1alien.txz [] [downgrade]

Total size: 0 KB
 Would you like to install the package/s? (custom paths are supported) [y/n]

 Press [r] to remove packages, [q] to quit, or enter to start downloading.

 Updates are available. 
 Program update:   not required 
 Database update:  available 
 Please run:  usm -u all  and/or  usm -u usm 
 This message can be disabled in /etc/usm/usm.conf
 ############################### 
flashplayer-plugin-11.2.202.424-i386-1alien.txz already exists
Error was same when attempting upgrade. There has been system crash in between, which is why it now says downgrade.

Success eventually with Slackyd

Code: Select all

guest@porteus:~$ slackyd -c p10/Por/slackyd.conf -s flashplayer-plugin
Searching flashplayer-plugin: found 1 package.
flashplayer-plugin-11.2.202.425-i386-1alien.txz [from alien]

guest@porteus:~$ slackyd -c p10/Por/slackyd.conf -g flashplayer-plugin
Searching flashplayer-plugin: found 1 package.
flashplayer-plugin-11.2.202.425-i386-1alien.txz [from alien]
*** flashplayer-plugin-11.2.202.425-i386-1alien.txz: already installed (flashplayer-plugin-11.2.202.411-i386-1alien).
All packages available are installed.

guest@porteus:~$ slackyd -c p10/Por/slackyd.conf -g flashplayer-plugin-11.2.202.425-i386-1alien
Searching flashplayer-plugin-11.2.202.425-i386-1alien: found 1 package.
flashplayer-plugin-11.2.202.425-i386-1alien.txz [from alien]
*** flashplayer-plugin-11.2.202.425-i386-1alien.txz: already installed (flashplayer-plugin-11.2.202.411-i386-1alien).
All packages available are installed.

root@porteus:/home/guest# deactivate /mnt/sda1/mods/flashplayer-plugin-11.2.202.411-i386-1alien.xzm

guest@porteus:~$ slackyd -c p10/Por/slackyd.conf -g flashplayer-plugin-11.2.202.425-i386-1alien
Searching flashplayer-plugin-11.2.202.425-i386-1alien: found 1 package.
flashplayer-plugin-11.2.202.425-i386-1alien.txz [from alien]
Download flashplayer-plugin-11.2.202.425-i386-1alien.txz [from alien] ? [y/N] y
* Verify md5 checksum: ok.
Second time in succession with flashplayer-plugin, that Slackyd has come to the rescue. (1st time being upgrade attempt to 11.2.202.411)

Code: Select all

root@porteus:/home/guest# usm -i flashplayer-plugin

Package:  flashplayer-plugin-11.2.202.425-i386-1alien.txz  (5100 K) [installed]
brokenman wrote:
Whatever that means
Hehe. It means exactly what it says. Brokenman needs to update the database. The package you searched for was found in the slackware repo but not in the LIBS.TXT file which is generated locally here.
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

User avatar
brokenman
Site Admin
Site Admin
Posts: 5456
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: USM bug reports

Post#233 by brokenman » 10 Dec 2014, 16:14

Was a ltitle busy releasing final and didn't get a chance to update USM on the weekend. Will do my best for tomrorow.
How do i become super user?
Wear your underpants on the outside and put on a cape.

tome
Contributor
Contributor
Posts: 562
Joined: 26 Jun 2013, 14:03
Distribution: x64 Openbox
Location: Poland
Contact:

Re: USM bug reports

Post#234 by tome » 10 Dec 2014, 17:01

I have tried (i486):

Code: Select all

usm -g rekonq
but usm couldn't resolve dependencies.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5456
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: USM bug reports

Post#235 by brokenman » 10 Dec 2014, 18:12

Updated USM database.

Tom, thanks I will add dependencies.
How do i become super user?
Wear your underpants on the outside and put on a cape.

blizar
Ronin
Ronin
Posts: 1
Joined: 11 Dec 2014, 08:54
Distribution: Porteus 3.1 amd64 LXQt
Location: france

Re: USM bug reports

Post#236 by blizar » 11 Dec 2014, 09:42

I'm just using the new 3.1 version (LXQt)

I got a problem trying to update
usm - all
...
Starting slackware database update
Downloading: CHECKSUMS.md5 DONE
Downloading: MANIFEST.bz2 DONE
Downloading: PACKAGES.TXT DONE
Downloading: LIBS.TXT.gz DONE
There was a problem downloading the file:
other repositories work well (alien, salix, slacky, ponce)

User avatar
brokenman
Site Admin
Site Admin
Posts: 5456
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: USM bug reports

Post#237 by brokenman » 11 Dec 2014, 19:29

Most likely the repository was down at the time of updating. If it persists, you can open the config file in /etc/usm (for slackware) and uncomment your preferred server.
How do i become super user?
Wear your underpants on the outside and put on a cape.

tome
Contributor
Contributor
Posts: 562
Joined: 26 Jun 2013, 14:03
Distribution: x64 Openbox
Location: Poland
Contact:

Re: USM bug reports

Post#238 by tome » 12 Dec 2014, 08:30

Code: Select all

usm -g chromium
also doesn't work.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5456
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: USM bug reports

Post#239 by brokenman » 12 Dec 2014, 13:15

In what way doesn't it work? Can you explain further?
How do i become super user?
Wear your underpants on the outside and put on a cape.

tome
Contributor
Contributor
Posts: 562
Joined: 26 Jun 2013, 14:03
Distribution: x64 Openbox
Location: Poland
Contact:

Re: USM bug reports

Post#240 by tome » 12 Dec 2014, 15:40

Code: Select all

root@me:/home/guest# usm -g chromium

 The following items were found.
 Choose an number to confirm. 
 ctrl+c to quit

1) chromium-39.0.2171.71-i486-1alien.txz
2) chromium-pepperflash-plugin-16.0.0.235-i386-1alien.txz
3) chromium-widevine-plugin-1.4.4.637-i386-1alien.txz
#? 1

Processing:   chromium-39.0.2171.71-i486-1alien.txz 
Ignored libraries: 

Libraries required:  71
Libraries found in system: 71
Libraries to resolve: 0


awk: linia poleceń:1: (FILENAME=- FNR=1) fatalny błąd: próba dostępu do pola -1
grep: /etc/usm/mirrors-.txt: Nie ma takiego pliku ani katalogu
grep: /mnt/data/appdata/usm-x86//PACKAGES.TXT: Nie ma takiego pliku ani katalogu
grep: /mnt/data/appdata/usm-x86//PACKAGES.TXT: Nie ma takiego pliku ani katalogu

 The following packages are required. 
chromium-39.0.2171.71-i486-1alien.txz [] [not installed]

Total size: 0 KB
 Would you like to install the package/s? (custom paths are supported) [y/n]

Post Reply