USM bug reports

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
User avatar
brokenman
Site Admin
Site Admin
Posts: 5574
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: USM bug reports

Post#196 by brokenman » 19 Oct 2014, 19:42

Are the MANIFEST files no longer used/needed in newer usm?
No. Since v3.1.6.

I just checked usm-v3.1.7 in Porteus-v3.1rc1-xfce and gimp is found no problems.
How do i become super user?
Wear your underpants on the outside and put on a cape.

Bogomips
Full of knowledge
Full of knowledge
Posts: 2563
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: USM bug reports

Post#197 by Bogomips » 20 Oct 2014, 01:09

Code: Select all

root@porteus:/home/guest# usm -s flashplayer

flashplayer-plugin-11.2.202.411-i386-1alien.txz was found in alien [not installed]
Packages found:   1 

Use:   usm -i <package>  for more info
Use:   usm -g <package>  to download

root@porteus:/home/guest# usm -g flashplayer

 The following items were found.
 Choose an number to confirm. 
 ctrl+c to quit

1) flashplayer-plugin-11.2.202.406-i386-1alien.txz
#? ^C
root@porteus:/home/guest# usm -v
 You are using USM version:  3.1.7
Out of Sync?
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

User avatar
brokenman
Site Admin
Site Admin
Posts: 5574
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: USM bug reports

Post#198 by brokenman » 20 Oct 2014, 02:47

Must be. We released Porteus yesterday and I replaced flashplayer in the opera package the day before which at the time was at minor 406, so I guess another (minor 411) was released yesterday or today. Damn.
How do i become super user?
Wear your underpants on the outside and put on a cape.

Bogomips
Full of knowledge
Full of knowledge
Posts: 2563
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: USM bug reports

Post#199 by Bogomips » 20 Oct 2014, 14:08

Never mind

Code: Select all

guest@porteus:~$ slackyd -c p10/Por/slackyd.conf -g flashplayer-plugin-11.2.202.411-i386-1alien
Searching flashplayer-plugin-11.2.202.411-i386-1alien: found 1 package.
flashplayer-plugin-11.2.202.411-i386-1alien.txz [from alien]
Download flashplayer-plugin-11.2.202.411-i386-1alien.txz [from alien] ? [y/N] y
                                                                                            Downloading to /var/slackyd/flashplayer-plugin-11.2.202.411-i386-1alien.txz. [ok]
* Verify md5 checksum: ok.
8)
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Re: USM bug reports

Post#200 by Rava » 20 Oct 2014, 20:44

@bogomips

I don't have any slackyd on Port 3.0.1 x86-64... I not recall when last trying to use slackyd... Was that never part of Port (and I had to activate slackyd module I forgot about back then), or was it just dropped in 3.0.1?

Code: Select all

root@porteus:/etc# cat porteus-version 
Porteus-v3.0.1
root@porteus:/etc# slackyd
-su: slackyd: command not found
root@porteus:/etc# sla[tab]
slabtop   slattach  
???
Cheers!
Yours Rava

Bogomips
Full of knowledge
Full of knowledge
Posts: 2563
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: USM bug reports

Post#201 by Bogomips » 20 Oct 2014, 21:11

@ Rava

On starting with Porteus 3.0.0 slackyd was already dropped. So

Code: Select all

usm -g slackyd
As it's so small normally install it from rc.local, running always fresh.
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Re: USM bug reports

Post#202 by Rava » 20 Oct 2014, 21:17

@bogomips

Thanks for the heads up... Sadly, my personal usm bug bit me again:

Code: Select all

root@porteus:/etc# usm -g slackyd

 Nothing found for:  slackyd 
Even updating to 3.0.1 and using neko's 001-core5.xzm (that got newest usm already) not solved any of my weird usm issues...

I have to start 3.1rc1 or a different machine to look it that would better my issues...

If not, then it must be some stuff I put in my personal "changes" module named 990-rootcopy_[version+date] or 991-rootcopy_[version+date] module(s)
Cheers!
Yours Rava

User avatar
brokenman
Site Admin
Site Admin
Posts: 5574
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: USM bug reports

Post#203 by brokenman » 20 Oct 2014, 23:52

Updated USM database so you can grab flashplayer-plugin latest now.
How do i become super user?
Wear your underpants on the outside and put on a cape.

Bogomips
Full of knowledge
Full of knowledge
Posts: 2563
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: USM bug reports

Post#204 by Bogomips » 21 Oct 2014, 01:43

@Rava

There is nothing to stop you from downloading latest usm txz package from git hub, and installing it, is there?
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

Bogomips
Full of knowledge
Full of knowledge
Posts: 2563
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: USM bug reports

Post#205 by Bogomips » 24 Oct 2014, 23:21

2nd Pass Bug not yet Resolved?

Determining Dependencies

Code: Select all

root@porteus:/home/guest# usm -d
Checked: ConsoleKit-0.4.5-i486-1
Checked: MPlayer-r36573-i486-1ftm
...
Checked: libcdio-0.83-i486-1
Processing: libcl-1.1-4-i686
Checked: libcroco-0.6.8-i486-1
...
Checked: libglade-2.6.4-i486-4
libgomp1-4.9.2-0.20140910.3.mga5.i586  is not a valid file  skipping
Checked: libgpg-error-1.11-i486-1
...
Checked: libkworkspace-4.11.12-i486-1ftm
Checked: liblqr-0.4.2-1-i686
Processing: libltdl-2.4.2-14-i686
Checked: libmad-0.15.1b-i486-3
...
Checked: libplasmaclock-4.11.12-i486-1ftm
Checked: libplasmagenericshell-4.11.12-i486-1ftm
Checked: libpng-1.4.12-i486-1
Processing: libpng16-16-1.6.6-4.1.i586
Checked: libqmi-1.4.0-i486-1
Checked: libraw-0.16.0-i486-1ftm
...
Checked: zd1211-firmware-1.4-fw-1
Checked: zeroconf-ioslave-4.14.1-i486-1ftm
Processing: zlib-1.2.8-i486-1

####################################

libcups.so.2 => not found
Required by: gtk+2-2.24.20-i486-1 (/usr/lib/gtk-2.0/2.10.0/printbackends/libprintbackend-cups.so)

libwmflite-0.2.so.7 => not found
Required by: imagemagick-6.8.9.8-1-i686 (/usr/lib/ImageMagick-6.8.9/modules-Q16HDRI/coders/wmf.so)

libpng16.so.16 => not found
Required by: imagemagick-6.8.9.8-1-i686 (/usr/lib/ImageMagick-6.8.9/modules-Q16HDRI/coders/png.so)

libgs.so.9 => not found
Required by: imagemagick-6.8.9.8-1-i686 (/usr/lib/ImageMagick-6.8.9/modules-Q16HDRI/coders/pdf.so)

libwebp.so.5 => not found
Required by: imagemagick-6.8.9.8-1-i686 (/usr/lib/ImageMagick-6.8.9/modules-Q16HDRI/coders/webp.so)

libopenjp2.so.7 => not found
Required by: imagemagick-6.8.9.8-1-i686 (/usr/lib/ImageMagick-6.8.9/modules-Q16HDRI/coders/jp2.so)

libtiff.so.5 => not found
Required by: imagemagick-6.8.9.8-1-i686 (/usr/lib/ImageMagick-6.8.9/modules-Q16HDRI/coders/tiff.so)

libgs.so.9 => not found
Required by: imagemagick-6.8.9.8-1-i686 (/usr/lib/ImageMagick-6.8.9/modules-Q16HDRI/coders/ps.so)

libspectre.so.1 => not found
Required by: okular-4.14.1-i486-1ftm (/usr/lib/kde4/okularGenerator_ghostview.so)

libmysqlclient.so.18 => not found
Required by: perl-5.18.1-i486-1 (/usr/lib/perl5/vendor_perl/auto/DBD/mysql/mysql.so)

libtk8.6.so => not found
libtcl8.6.so => not found
Required by: python-2.7.5-i486-1 (/usr/lib/python2.7/lib-dynload/_tkinter.so)

libprojectM.so.2 => not found
Required by: qmmp-0.8.1-i486-1ftm (/usr/lib/qmmp/Visual/libprojectm.so)

libclucene-core.so.1 => not found
libclucene-core.so.1 => not found
Required by: soprano-2.9.0-i486-1 (/usr/bin/sopranod)

libclucene-core.so.1 => not found
libclucene-core.so.1 => not found
Required by: soprano-2.9.0-i486-1 (/usr/bin/sopranocmd)

libclucene-core.so.1 => not found
Required by: soprano-2.9.0-i486-1 (/usr/lib/libsopranoindex.so.1.1.0)

libraptor2.so.0 => not found
Required by: soprano-2.9.0-i486-1 (/usr/lib/soprano/libsoprano_raptorserializer.so)

libiodbc.so.2 => not found
Required by: soprano-2.9.0-i486-1 (/usr/lib/soprano/libsoprano_virtuosobackend.so)

libraptor2.so.0 => not found
Required by: soprano-2.9.0-i486-1 (/usr/lib/soprano/libsoprano_raptorparser.so)

librdf.so.0 => not found
Required by: soprano-2.9.0-i486-1 (/usr/lib/soprano/libsoprano_redlandbackend.so)

libaa.so.1 => not found
Required by: vlc-2.1.5-i486-1alien (/usr/lib/vlc/plugins/video_output/libaa_plugin.so)

libcaca.so.0 => not found
Required by: vlc-2.1.5-i486-1alien (/usr/lib/vlc/plugins/video_output/libcaca_plugin.so)

libsmbclient.so.0 => not found
Required by: vlc-2.1.5-i486-1alien (/usr/lib/vlc/plugins/access/libaccess_smb_plugin.so)
####################################
...
root@porteus:/home/guest# usm -v
 You are using USM version:  3.1.7
But libpng16.so.16 => not found does not gel with

Code: Select all

guest@porteus:~$ ldd /usr/lib/ImageMagick-6.8.9/modules-Q16HDRI/coders/png.so | grep not
guest@porteus:~$ ldd /usr/lib/ImageMagick-6.8.9/modules-Q16HDRI/coders/png.so
        linux-gate.so.1 (0xb77b3000)
        libMagickCore-6.Q16HDRI.so.2 => /usr/lib/libMagickCore-6.Q16HDRI.so.2 (0xb745d000)
        liblcms2.so.2 => /usr/lib/liblcms2.so.2 (0xb740a000)
        liblqr-1.so.0 => /usr/lib/liblqr-1.so.0 (0xb73fa000)
        libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0xb72cc000)
        libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xb7292000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb7205000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0xb71f3000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0xb70bc000)
        libXt.so.6 => /usr/lib/libXt.so.6 (0xb7060000)
        libbz2.so.1.0 => /lib/libbz2.so.1.0 (0xb704f000)
        libltdl.so.7 => /usr/lib/libltdl.so.7 (0xb7042000)
        libgomp.so.1 => /usr/lib/libgomp.so.1 (0xb7028000)
        libpng16.so.16 => /usr/lib/libpng16.so.16 (0xb6fec000)
        libjpeg.so.8 => /usr/lib/libjpeg.so.8 (0xb6fb4000)
        ...
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

User avatar
brokenman
Site Admin
Site Admin
Posts: 5574
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: USM bug reports

Post#206 by brokenman » 25 Oct 2014, 01:20

I froze development until the rc1 release. Where did you get your imagemagick package from?
How do i become super user?
Wear your underpants on the outside and put on a cape.

Bogomips
Full of knowledge
Full of knowledge
Posts: 2563
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: USM bug reports

Post#207 by Bogomips » 25 Oct 2014, 14:12

brokenman wrote: Where did you get your imagemagick package from?
usm's imagemagick display did not display, owing to documented bug. Updated to latest version from Arch, and now following upgrade from 9.7 to 9.8, carried out dependency verification.
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

User avatar
brokenman
Site Admin
Site Admin
Posts: 5574
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: USM bug reports

Post#208 by brokenman » 25 Oct 2014, 20:26

Ok. I am not familiar with arch packages but USM relies on a valid slackware style /var//log/packages file for dependency resolution.
How do i become super user?
Wear your underpants on the outside and put on a cape.

Bogomips
Full of knowledge
Full of knowledge
Posts: 2563
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: USM bug reports

Post#209 by Bogomips » 25 Oct 2014, 22:53

brokenman wrote:Ok. I am not familiar with arch packages but USM relies on a valid slackware style /var//log/packages file for dependency resolution.
Got package from arch, exploded it, made install, slack-desc, then created slackware package using makepkg, which deleted symlinks and created doinst.sh. Verified using installpkg. Did not complain, description came up, indicating txz had valid name formatting.
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

r004
White ninja
White ninja
Posts: 19
Joined: 24 Sep 2014, 10:32
Distribution: Porteus
Location: troy,MI

USM doesn't install anything

Post#210 by r004 » 31 Oct 2014, 08:23

/usr/share/usm/funcpackageGet: line 103: declare: 1476K: value too great for base (error token is "1476K")
I get this. then I downloaded 3.1.7 from sourseforge and installed it by GUI.
but the error still happening.

Post Reply