Porteus 3.0 final feedback

New features which should be implemented in Porteus; suggestions are welcome. All questions or problems with testing releases (alpha, beta, or rc) should go in their relevant thread here, rather than the Bug Reports section.
Post Reply
User avatar
brokenman
Site Admin
Site Admin
Posts: 5439
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Porteus 3.0 final feedback

Post#61 by brokenman » 19 Mar 2014, 01:40

Thanks for the info regarding the installer. This is important.
I can't reproduce the hang in the information screen but can you please upload the dump? It might help to narrow down what is causing the hang. My main interest is in any info that is missing or garbled.

I'm glad I had dinner before re-reading this thread and seeing your edit. My heart skipped a beat.
How do i become super user?
Wear your underpants on the outside and put on a cape.

roadie
Full of knowledge
Full of knowledge
Posts: 205
Joined: 02 Jan 2011, 18:41
Distribution: Porteus 3.5...with a twist
Location: In a hayfield

Re: Porteus 3.0 final feedback

Post#62 by roadie » 19 Mar 2014, 03:15

I can't reproduce the hang in the information screen but can you please upload the dump? It might help to narrow down what is causing the hang. My main interest is in any info that is missing or garbled.
Testing it right now with a new iso and getting similar behavior, but not freezing. It's really haphazard, sometimes fairly fast, then slow, then fast again. On generating a dump file and answering 'yes' to pastebin upload, it generates the file....claims it's uploading.....say's the link file is in /tmp....but the link file there is only 1k in size.

The md5sum of both iso's is identical and matches the site md5sum.
I'll keep playing with it.....the dump file seems normal.

http://pastebin.com/A8LEwnNZ

EDIT: Just booted the iso from the Wizard....same behavior.
Could it be my machine?

roadie
Last edited by roadie on 19 Mar 2014, 04:03, edited 1 time in total.

roadie
Full of knowledge
Full of knowledge
Posts: 205
Joined: 02 Jan 2011, 18:41
Distribution: Porteus 3.5...with a twist
Location: In a hayfield

Re: Porteus 3.0 final feedback

Post#63 by roadie » 19 Mar 2014, 03:28

I'm glad I had dinner before re-reading this thread and seeing your edit. My heart skipped a beat.
Apologies....I discovered that using Midnight Commander to view an iso doesn't show all the files, though it does show all the directories in /boot it doesn't for /porteus.
It also doesn't copy the unseen directories if copied from that window.

Learn something every day.

roadie

User avatar
bdheeman
Contributor
Contributor
Posts: 77
Joined: 15 Sep 2012, 19:39
Distribution: Porteus 3.0.1+ MATE/XFCE
Location: Chandigarh, PB, India
Contact:

Re: Porteus 3.0 final feedback

Post#64 by bdheeman » 19 Mar 2014, 16:49

I just built an ISO usin the wizard (MATE-v3.0-x86_64) and engrampa is working. Please try running: sh /opt/porteus-scripts/xorg/update-cache
to see if the schema gets generated.
Sorry, no avail even after update-cache and, or rebuilding a porteus mate 32bit ISO :(

I downloaded mate-file-archiver 1.6.2 i586 RPM from fedora 20 and converted the same to an xzm, which worked fine here ;)
--
Balwinder S "bdheeman" Dheeman (http://bdheeman.BlogSpot.in/)
"Working together, works! The proof is GNU/Linux and F/LOSS Projects;
Do you too voluntarily work on or contribute to making any difference?"

User avatar
brokenman
Site Admin
Site Admin
Posts: 5439
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Porteus 3.0 final feedback

Post#65 by brokenman » 19 Mar 2014, 17:18

Could it be my machine?
I would say it is since others can't reproduce it. These small units are becoming popular so would be nice to nail what command is causing it.

Thanks bdheeman, I will recompile mate file archiver for next release. Mate 1.8 should be the base by then.
How do i become super user?
Wear your underpants on the outside and put on a cape.

roadie
Full of knowledge
Full of knowledge
Posts: 205
Joined: 02 Jan 2011, 18:41
Distribution: Porteus 3.5...with a twist
Location: In a hayfield

Re: Porteus 3.0 final feedback

Post#66 by roadie » 19 Mar 2014, 18:06

Sorry, no avail even after update-cache and, or rebuilding a porteus mate 32bit ISO

I fixed the Mate Engrampa error by running 'glib-compile-schemas /usr/share/glib-2.0/schemas

roadie

roadie
Full of knowledge
Full of knowledge
Posts: 205
Joined: 02 Jan 2011, 18:41
Distribution: Porteus 3.5...with a twist
Location: In a hayfield

Re: Porteus 3.0 final feedback

Post#67 by roadie » 19 Mar 2014, 18:16

Could it be my machine?
I would say it is since others can't reproduce it. These small units are becoming popular so would be nice to nail what command is causing it.
I'm assuming that xpsinfo doesn't cache the reports and needs to run a new parse with each tab change?

I tried with another netbook, an Acer...same specs and got the same result, though no freezing, there is definite lagging.

These things will become very popular with XP support ending as (I think) they won't run Windows 7 very well. They're great as a cheap portable Linux box. Both I've tried run Kde4 quite well, an older Toshiba NB300 lagged with it.

roadie

cttan
Shogun
Shogun
Posts: 332
Joined: 26 Jan 2011, 16:15
Distribution: Porteus 3.2 64bit KDE
Location: Malaysia

Re: Porteus 3.0 final feedback

Post#68 by cttan » 20 Mar 2014, 08:49

Hi,

Something funny happened. I have tried reboot many time and also reboot into Always Fresh mode but still the same thing happen.

I have been using bluetooth for communication in between my handphone and laptop using Asterisk.
Yesterday I have noticed that somehow the bluetooth systray icon is gone in Porteus v3.0 final.

When I check using KDE System Settings > Bluetooth, there is no device detected as per screenshot:-
Image

Using the CLI tool I am able to see the bluetooth device:-

Code: Select all

~# hcitool dev
Devices:
        hci0    00:21:86:85:9D:19
In the application, I can see the bluetooth device and use it as well:-

Code: Select all

 -- Bluetooth Device Samsung_i9500 has connected, initializing...
    -- Bluetooth Device Samsung_i9500 initialized and ready.

roadie
Full of knowledge
Full of knowledge
Posts: 205
Joined: 02 Jan 2011, 18:41
Distribution: Porteus 3.5...with a twist
Location: In a hayfield

Re: Porteus 3.0 final feedback

Post#69 by roadie » 20 Mar 2014, 15:04

When I check using KDE System Settings > Bluetooth, there is no device detected as per screenshot:-

I found the same yesterday, haven't gone further into it yet. The hci tool finds no devices with 2 different phones.

EDIT: This seems to be an ongoing problem from a couple of years back. I installed rfkill and ran 'rfkill list' which showed bluetooth as being soft blocked....running 'rfkill unblock all' did unblock it, but no change in Kde.
roadie

roadie
Full of knowledge
Full of knowledge
Posts: 205
Joined: 02 Jan 2011, 18:41
Distribution: Porteus 3.5...with a twist
Location: In a hayfield

Re: Porteus 3.0 final feedback

Post#70 by roadie » 21 Mar 2014, 04:07

I installed bluedevil-1.3.1 from Slackware along with libbluedevil-1.9.3 and Kde bluetooth now works....at least it scans and finds bluetooth devices. I haven't been able to send files as of yet.

roadie

User avatar
fanthom
Site Admin
Site Admin
Posts: 4547
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Porteus 3.0 final feedback

Post#71 by fanthom » 21 Mar 2014, 09:48

@roadie
xpsinfo collects all the info and log files so the 'freeze' could be explained by that.
otoh - psinfo does the same and is much quicker so must be a gtkdialog fault.

@cttan/roadie
my bad. i have bumped to kde-4.12.3 and bluedevil-2.0 rc1 just before the final and seems that something broke.
will try to track it down and push a fix through Porteus updates on Monday.
Please add [Solved] to your thread title if the solution was found.

User avatar
bdheeman
Contributor
Contributor
Posts: 77
Joined: 15 Sep 2012, 19:39
Distribution: Porteus 3.0.1+ MATE/XFCE
Location: Chandigarh, PB, India
Contact:

Re: Porteus 3.0 final feedback

Post#72 by bdheeman » 22 Mar 2014, 11:18

I build JRE modules, both 32bit and 64bit, using vanilla tarballs from http://www.oracle.com/technetwork/java/ ... index.html, some of the java apps which use java.awt.desktop work fine under LinuxMint MATE/XFCE Desktop Environments, but the same do not work under Porteus MATE/XFCE due to unsupported/unknown desktops :(

The java apps fail when these try to open a URL/URI indeed.
--
Balwinder S "bdheeman" Dheeman (http://bdheeman.BlogSpot.in/)
"Working together, works! The proof is GNU/Linux and F/LOSS Projects;
Do you too voluntarily work on or contribute to making any difference?"

User avatar
bdheeman
Contributor
Contributor
Posts: 77
Joined: 15 Sep 2012, 19:39
Distribution: Porteus 3.0.1+ MATE/XFCE
Location: Chandigarh, PB, India
Contact:

Re: Porteus 3.0 final feedback

Post#73 by bdheeman » 22 Mar 2014, 11:27

brokenman wrote: I would say it is since others can't reproduce it. These small units are becoming popular so would be nice to nail what command is causing it.

Thanks bdheeman, I will recompile mate file archiver for next release. Mate 1.8 should be the base by then.
I confirm, that running 'glib-compile-schemas /usr/share/glib-2.0/schemas is essential to make the engrampa work.

You're welcome; I'm awaiting to test Mate 1.8 :)
--
Balwinder S "bdheeman" Dheeman (http://bdheeman.BlogSpot.in/)
"Working together, works! The proof is GNU/Linux and F/LOSS Projects;
Do you too voluntarily work on or contribute to making any difference?"

sams
Legendary
Legendary
Posts: 27
Joined: 05 Jan 2011, 18:53
Location: Alaska

Re: Porteus 3.0 final feedback

Post#74 by sams » 24 Mar 2014, 07:38

Hi all, thanks for the new release, it is working really well here. Still testing and building some stuff, but thus far 3.0 is all aces, everything I couldn't get working in earlier versions (since way back) either works here or I've been able to build it and make it work, no problem. :Yahoo!:

worthy release, is appreciated!

User avatar
francois
Contributor
Contributor
Posts: 4902
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: Porteus 3.0 final feedback

Post#75 by francois » 24 Mar 2014, 14:56

We really appreciate your feedback, especially coming from a «connaisseur». And reinforce us to think that we have one of the best linux distribution somewhere out there in the universe. :twisted:
Voltaire: Le mieux est l'ennemi du bien.

Post Reply