lIBsdl problem Porteus 3.0 rc2

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
ztealmax
Black ninja
Black ninja
Posts: 50
Joined: 16 Dec 2012, 00:11
Distribution: Porteus [LXDE] x86_64 v3.2.2 A
Location: Sweden
Contact:

lIBsdl problem Porteus 3.0 rc2

Post#1 by ztealmax » 17 Feb 2014, 14:28

hi im trying to get et-sdl-sound to work in porteus 3.0 rc2 its a script to get sound working
on Wolfenstein Enemy Territory, it worked on Porteus 2.1
im getting this output when trying to run the script:

Code: Select all

./et-sdl-sound 
[et-sdl-sound] info   : et.x86 is installed to /usr/local/games/enemy-territory
[et-sdl-sound] error  : can't locate libSDL.so
[et-sdl-sound] info   : tried following files
[et-sdl-sound] info   : /usr/lib/libSDL.so
[et-sdl-sound] info   :    symbolic link to `libSDL-1.2.so.0.11.4' 
[et-sdl-sound] info   : /usr/lib/libSDL-1.2.so.0.11.4
[et-sdl-sound] info   :    ELF 32-bit LSB  shared object, Intel 80386, version 1 (SYSV), dynamically linked, stripped
[et-sdl-sound] info   : /usr/lib/libSDL-1.2.so.0
[et-sdl-sound] info   :    symbolic link to `libSDL-1.2.so.0.11.4' 
[et-sdl-sound] info   : /usr/lib/libSDL-1.2.so.0.11.4
[et-sdl-sound] info   :    ELF 32-bit LSB  shared object, Intel 80386, version 1 (SYSV), dynamically linked, stripped
[et-sdl-sound] info   : /usr/lib/libSDL.so
[et-sdl-sound] info   :    symbolic link to `libSDL-1.2.so.0.11.4' 
[et-sdl-sound] info   : /usr/lib/libSDL-1.2.so.0.11.4
[et-sdl-sound] info   :    ELF 32-bit LSB  shared object, Intel 80386, version 1 (SYSV), dynamically linked, stripped
[et-sdl-sound] info   : /usr/lib/libSDL-1.2.so.0
[et-sdl-sound] info   :    symbolic link to `libSDL-1.2.so.0.11.4' 
[et-sdl-sound] info   : /usr/lib/libSDL-1.2.so.0.11.4
[et-sdl-sound] info   :    ELF 32-bit LSB  shared object, Intel 80386, version 1 (SYSV), dynamically linked, stripped
[et-sdl-sound] info   : /usr/lib/libSDL-1.2.so.0.11.4
[et-sdl-sound] info   :    ELF 32-bit LSB  shared object, Intel 80386, version 1 (SYSV), dynamically linked, stripped
[et-sdl-sound] info   : /usr/lib/libSDL-1.2.so.0.11.4
[et-sdl-sound] info   :    ELF 32-bit LSB  shared object, Intel 80386, version 1 (SYSV), dynamically linked, stripped
script im trying to run is found here:
http://nullkey.kapsi.fi/et-sdl-sound/

Code: Select all

wget -q -O - http://nullkey.kapsi.fi/et-sdl-sound/et-sdl-sound.gz | gzip -d > et-sdl-sound && chmod a+x et-sdl-sound
Any help would be greatly apriciated

Ztealmax
Porteus XFCE x86_64
- Amd A10-7850k
- Amd Radeon R7
- 16Gb RAM
- 120Gb Samsung Evo SSD

User avatar
brokenman
Site Admin
Site Admin
Posts: 5659
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: lIBsdl problem Porteus 3.0 rc2

Post#2 by brokenman » 17 Feb 2014, 15:19

This is what stands out for me:
can't locate libSDL.so

Open terminal and type: usm -s SDL

and look for the sound related package. Should be something like: SDL_sound-1.0.3
How do i become super user?
Wear your underpants on the outside and put on a cape.

ztealmax
Black ninja
Black ninja
Posts: 50
Joined: 16 Dec 2012, 00:11
Distribution: Porteus [LXDE] x86_64 v3.2.2 A
Location: Sweden
Contact:

Re: lIBsdl problem Porteus 3.0 rc2

Post#3 by ztealmax » 17 Feb 2014, 16:43

tried that and before that i searched the filestructure and i have LibSDL.so etc... weird

anyways im now running 2.1 version again until i can sort it out :)

Thank you for the help
Porteus XFCE x86_64
- Amd A10-7850k
- Amd Radeon R7
- 16Gb RAM
- 120Gb Samsung Evo SSD

cttan
Shogun
Shogun
Posts: 332
Joined: 26 Jan 2011, 16:15
Distribution: Porteus 3.2 64bit KDE
Location: Malaysia

Re: lIBsdl problem Porteus 3.0 rc2

Post#4 by cttan » 18 Feb 2014, 03:58

Hi ztealmax,

You will need to activate
1. compat32-libraries-3.0-x86_64-1sl.xzm(download from Porteus.org)
2. glu-compat32-9.0.0-x86_64-1compat32.xzm(downloaded from pkgs.org)

Enjoy you game!

ztealmax
Black ninja
Black ninja
Posts: 50
Joined: 16 Dec 2012, 00:11
Distribution: Porteus [LXDE] x86_64 v3.2.2 A
Location: Sweden
Contact:

Re: lIBsdl problem Porteus 3.0 rc2

Post#5 by ztealmax » 18 Feb 2014, 10:03

Thanx m8
compat32-libraries-3.0-x86_64-1sl.xzm is allready activated
downloading glu-compat32-9.0.0-x86_64-1compat32.xzm now :)
Porteus XFCE x86_64
- Amd A10-7850k
- Amd Radeon R7
- 16Gb RAM
- 120Gb Samsung Evo SSD

ztealmax
Black ninja
Black ninja
Posts: 50
Joined: 16 Dec 2012, 00:11
Distribution: Porteus [LXDE] x86_64 v3.2.2 A
Location: Sweden
Contact:

Re: lIBsdl problem Porteus 3.0 rc2

Post#6 by ztealmax » 18 Feb 2014, 10:28

Still no go with sound:

Code: Select all

[et-sdl-sound] error  : can't locate libSDL.so
You also running 64-bit version of Porteus 3.0 rc2?

Why im trying to get it to work is im playing a mod for wolfenstein enemy territory called True Combat Elite , simular to CS so it would be great to have a portable
OS with my favorite games ;)

Hmm my Porteus just frezed up locked for no reason, must check this out
happend a couple of times while i was doing nothing special, i wonder if it might be xfce or amd driver acting up
Porteus XFCE x86_64
- Amd A10-7850k
- Amd Radeon R7
- 16Gb RAM
- 120Gb Samsung Evo SSD

cttan
Shogun
Shogun
Posts: 332
Joined: 26 Jan 2011, 16:15
Distribution: Porteus 3.2 64bit KDE
Location: Malaysia

Re: lIBsdl problem Porteus 3.0 rc2

Post#7 by cttan » 18 Feb 2014, 22:39

Hi ztealmax,

I'm running Porteus 3.0RC2 64bit KDE version. You are using XFCE. Maybe there is something missing there.
I'm testing using etlegacy-linux-2.71rc1.

Dependency after activating compat32-libraries-3.0-x86_64-1sl.xzm. Missing libGLU.

Code: Select all

# ldd /opt/etlegacy/etl
        linux-gate.so.1 (0xf776c000)
        libdl.so.2 => /lib/libdl.so.2 (0xf7747000)
        libm.so.6 => /lib/libm.so.6 (0xf7705000)
        librt.so.1 => /lib/librt.so.1 (0xf76fc000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xf76e2000)
        libGLU.so.1 => not found
        libGL.so.1 => /usr/lib/libGL.so.1 (0xf7682000)
        libSM.so.6 => /usr/lib/libSM.so.6 (0xf767a000)
        libICE.so.6 => /usr/lib/libICE.so.6 (0xf7661000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0xf752a000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0xf7517000)
        libc.so.6 => /lib/libc.so.6 (0xf738c000)
        /lib/ld-linux.so.2 (0xf776d000)
        libglapi.so.0 => /usr/lib/libglapi.so.0 (0xf736d000)
        libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0xf736a000)
        libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0xf7365000)
        libX11-xcb.so.1 => /usr/lib/libX11-xcb.so.1 (0xf7362000)
        libxcb-glx.so.0 => /usr/lib/libxcb-glx.so.0 (0xf734b000)
        libxcb-dri2.so.0 => /usr/lib/libxcb-dri2.so.0 (0xf7346000)
        libxcb.so.1 => /usr/lib/libxcb.so.1 (0xf7326000)
        libXxf86vm.so.1 => /usr/lib/libXxf86vm.so.1 (0xf7321000)
        libdrm.so.2 => /usr/lib/libdrm.so.2 (0xf7314000)
        libuuid.so.1 => /lib/libuuid.so.1 (0xf7310000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0xf730d000)
        libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xf7307000)
ldconfig -p | grep libSDL

Code: Select all

# ldconfig -p | grep libSDL
        libSDL_ttf-2.0.so.0 (libc6,x86-64) => /usr/lib64/libSDL_ttf-2.0.so.0
        libSDL_ttf-2.0.so.0 (libc6) => /usr/lib/libSDL_ttf-2.0.so.0
        libSDL_net-1.2.so.0 (libc6,x86-64) => /usr/lib64/libSDL_net-1.2.so.0
        libSDL_net-1.2.so.0 (libc6) => /usr/lib/libSDL_net-1.2.so.0
        libSDL_mixer-1.2.so.0 (libc6,x86-64) => /usr/lib64/libSDL_mixer-1.2.so.0
        libSDL_mixer-1.2.so.0 (libc6) => /usr/lib/libSDL_mixer-1.2.so.0
        libSDL_image-1.2.so.0 (libc6,x86-64) => /usr/lib64/libSDL_image-1.2.so.0
        libSDL_image-1.2.so.0 (libc6) => /usr/lib/libSDL_image-1.2.so.0
        libSDL-1.2.so.0 (libc6,x86-64) => /usr/lib64/libSDL-1.2.so.0
        libSDL-1.2.so.0 (libc6) => /usr/lib/libSDL-1.2.so.0
Game startup log:-

Code: Select all

# /opt/etlegacy/etl                  
ET Legacy v2.71rc1 linux-i386 Feb 27 2013
Zone megs: 24
Info: fs_game is set to 'legacy' mod. Start ET:Legacy with param '+set fs_game etmain' for adoring history.
----- FS_Startup -----
Current search path:
    /root/.etlwolf/legacy
    /opt/etlegacy/legacy/pak3_v2.70rc1.pk3 (683 files)
    /opt/etlegacy/legacy/etl_bin_v2.71rc1.pk3 (8 files)
    /opt/etlegacy/legacy
    /root/.etlwolf/etmain/mml_minastirith_fp3.pk3 (90 files)
    /root/.etlwolf/etmain/etdo_f2.pk3 (136 files)
    /root/.etlwolf/etmain
    /opt/etlegacy/etmain/pak2.pk3 (22 files)
    /opt/etlegacy/etmain/pak1.pk3 (10 files)
    /opt/etlegacy/etmain/pak0.pk3 (3725 files)
    /opt/etlegacy/etmain/mp_bin.pk3 (6 files)
    /opt/etlegacy/etmain

----------------------
4680 files in pk3 files
^3WARNING: profile.pid found for profile 'ace' - system settings will revert to defaults
execing default.cfg
execing profiles/ace/etconfig.cfg
r_mode is unsafe. Check com_crashed.
r_depthbits is unsafe. Check com_crashed.
r_stencilbits is unsafe. Check com_crashed.
r_colorbits is unsafe. Check com_crashed.
r_texturebits is unsafe. Check com_crashed.
r_ext_texture_filter_anisotropic is unsafe. Check com_crashed.
r_ext_compiled_vertex_array is unsafe. Check com_crashed.
r_ext_multitexture is unsafe. Check com_crashed.
r_ext_compressed_textures is unsafe. Check com_crashed.
r_allowExtensions is unsafe. Check com_crashed.
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok
Not logging server attacks to disk.
Trackbase: Server communication disabled by sv_advert.
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
ETKEY found.
Loaded 85 translation strings from scripts/translation.cfg
----- Client Initialization Complete -----
----- R_Init -----
SDL using driver "x11"
Initializing OpenGL display
Estimated display aspect: 1.600
...setting mode 4:
 800 600
libGL error: failed to load driver: i965
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
libGL error: failed to load driver: swrast
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
Using 8/8/8 Color bits, 24 depth, 0 stencil display.
Available modes: '1280x800 640x480 800x600 1024x768'
GL_RENDERER: Mesa DRI Mobile Intel® GM45 Express Chipset 
Initializing OpenGL extensions
...GL_EXT_texture_compression_s3tc not found
...GL_S3_s3tc not found
...using GL_EXT_texture_env_add
...using GL_ARB_multitexture
...GL_EXT_compiled_vertex_array not found
...ignoring GL_EXT_texture_filter_anisotropic

GL_VENDOR: Intel Open Source Technology Center
GL_RENDERER: Mesa DRI Mobile Intel® GM45 Express Chipset 
GL_VERSION: 1.4 (2.1 Mesa 10.0.2)
GL_EXTENSIONS: GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_shadow GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_program GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_copy_texture GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_object GL_EXT_multi_draw_arrays GL_EXT_packed_pixels GL_EXT_point_parameters GL_EXT_polygon_offset GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_subtexture GL_EXT_texture GL_EXT_texture3D GL_EXT_texture_compression_dxt1 GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod_bias GL_EXT_texture_object GL_EXT_texture_rectangle GL_EXT_vertex_array GL_3DFX_texture_compression_FXT1 GL_APPLE_packed_pixels GL_ATI_draw_buffers GL_ATI_texture_env_combine3 GL_ATIX_texture_env_combine3 GL_IBM_texture_mirrored_repeat GL_INGR_blend_func_separate GL_MESA_pack_invert GL_MESA_ycbcr_texture GL_NV_blend_square GL_NV_depth_clamp GL_NV_light_max_exponent GL_NV_texgen_reflection GL_NV_texture_env_combine4 GL_NV_texture_rectangle GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_SUN_multi_draw_arrays 
GL_MAX_TEXTURE_SIZE: 8192
GL_MAX_ACTIVE_TEXTURES_ARB: 8
PIXELFORMAT: color(24-bits) Z(24-bit) stencil(0-bits)
MODE: 4, 800 x 600 fullscreen hz:N/A
GAMMA: hardware w/ 0 overbright bits
rendering primitives: multiple glArrayElement
texturemode: GL_LINEAR_MIPMAP_LINEAR
picmip: 0
texture bits: 0
multitexture: enabled
compiled vertex arrays: disabled
texenv add: enabled
compressed textures: disabled
Initializing Shaders
----- finished R_Init -----
------ Initializing Sound ------
SDL_Init( SDL_INIT_AUDIO )... OK
SDL audio driver is "alsa".
SDL_AudioSpec:
  Format:   AUDIO_S16LSB
  Freq:     44100
  Samples:  940
  Channels: 2
  Silence:  0
  Size:     3760
Starting SDL audio callback...
SDL audio initialized.
----- Sound Info -----
sound system is muted
    1 stereo
32768 samples
   16 samplebits
    1 submission_chunk
44100 speed
0xb673670 dma buffer
No background file.
----------------------
Sound initialization successful.
s_backend set to base
--------------------------------
ALSA lib pcm.c:7843:(snd_pcm_recover) underrun occurred
Sound memory manager started
Sys_LoadDll(/root/.etlwolf/legacy/ui.mp.i386.so)... succeeded
Sys_LoadDll(ui) found vmMain function at 0xe0fc3e30
160 UI cvars in use.
ALSA lib pcm.c:7843:(snd_pcm_recover) underrun occurred
Favourite servers restored: 0
--- Common Initialization Complete ---
IP: 127.0.0.1
IP: 10.10.10.10
IP: 192.168.127.57
IP: 137.135.128.57
IP: 192.168.110.57
IP: 192.11.13.5
IP: 192.168.1.57
IP: 192.168.0.100
Opening IP socket: 0.0.0.0:27960
MOTD: resolving motd.etlegacy.com
MOTD: motd.etlegacy.com resolved to 5.135.27.11:27951
tty]ALSA lib pcm.c:7843:(snd_pcm_recover) underrun occurred
Switching to windowed rendering
MOTD: resolving motd.etlegacy.com
MOTD: motd.etlegacy.com resolved to 5.135.27.11:27951
----- CL_Shutdown -----
Closing SDL audio device...
SDL audio device shut down.
RE_Shutdown( 1 )
Favourite servers saved: 0
-----------------------

ztealmax
Black ninja
Black ninja
Posts: 50
Joined: 16 Dec 2012, 00:11
Distribution: Porteus [LXDE] x86_64 v3.2.2 A
Location: Sweden
Contact:

Re: lIBsdl problem Porteus 3.0 rc2

Post#8 by ztealmax » 19 Feb 2014, 12:21

Ahh thank you ill check out the KDE version if it works good for me there iknow thats something is missing in xfce :)

Thanx alot for your efforts, ill post back my results
Porteus XFCE x86_64
- Amd A10-7850k
- Amd Radeon R7
- 16Gb RAM
- 120Gb Samsung Evo SSD

Post Reply