Switch languages in Kiosk [Solved]

Here you can post about the issues related to modifications performed manually (not through the kiosk wizard). Example: swapped kernel, added 3rd party modules or files.
Please describe in detail what has been changed and hopefully other kiosk user will be able to help.
Porteus team wont resolve bugs posted in this category as we support only modifications made by the kiosk wizard.
Post Reply
svarog
Ronin
Ronin
Posts: 2
Joined: 30 Jan 2014, 11:08
Distribution: Porteus Kiosk 3
Location: RF

Switch languages in Kiosk [Solved]

Post#1 by svarog » 30 Jan 2014, 11:43

Hi
I need switchable languages in Porteus-Kiosk-3.0-i486
Changing "squashfs-root/etc/xdg/openbox/autostart" with

Code: Select all

setxkbmap -layout us,ru -option “grp:alt_shift_toggle”
doesn't work.
Also I have try to copy "/usr/share/X11/xorg.conf.d/90-keyboard-layout.conf" to "/etc/X11/xorg.conf.d" and add to that copy

Code: Select all

Option "XkbLayout" "us,ru"
Option "XKbOptions" "grp:alt_shift_toggle"
Also no luck

What i'm doing wrong?
Last edited by svarog on 31 Jan 2014, 04:33, edited 1 time in total.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4548
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Switch languages in Kiosk

Post#2 by fanthom » 30 Jan 2014, 14:48

hi svarog,

works here.
make sure you use " not “ so your code should look like:

Code: Select all

setxkbmap -layout us,ru -option "grp:alt_shift_toggle"
and not:

Code: Select all

setxkbmap -layout us,ru -option “grp:alt_shift_toggle”
btw: moving your thread to 'User's modifications to the Kiosk ISO' section of the forum.
Please add [Solved] to your thread title if the solution was found.

svarog
Ronin
Ronin
Posts: 2
Joined: 30 Jan 2014, 11:08
Distribution: Porteus Kiosk 3
Location: RF

Re: Switch languages in Kiosk

Post#3 by svarog » 31 Jan 2014, 04:32

It works! I've just copied quotes from other place of this file, and it works! Thank you, fanthom!

Post Reply