[Solved] No ethernet nor wifi on ASUS 1015E

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
7an
White ninja
White ninja
Posts: 4
Joined: 18 Dec 2013, 09:32
Distribution: 2.1
Location: San Diego, CA

[Solved] No ethernet nor wifi on ASUS 1015E

Post#1 by 7an » 18 Dec 2013, 09:43

EDIT: Both the ethernet and wifi problems went away with the upgrade to Porteus 3! Many thanks to the awesome development team!

Hi there,

Really liking what I've seen of Porteus so far. However, I can't get networking (ethernet or wifi) going on my ASUS 1015E laptop (it's a relatively new model; came out a few months back). No networks are recognized and there's a permanent red x on the network icon in XFCE.

I've tried the blacklist trick for wifi in /mnt/sdc1/porteus/rootcopy/etc/modprobe.d/b43_blacklist.conf to no avail. All it seems to do is remove the XFCE network icon.

lspci tells me the following:

02:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)
03:00.0 Ethernet controller: Atheros Communications Inc. AR8162 Fast Ethernet (rev 10)

dmesg gives me the "taints kernel" regarding wl.

CrunchBang, Puppy and other distros recognize the ethernet right away and wifi with some help. Also, Proteus ethernet (same flash drive) works fine on some of my other machines, including another (very old) ASUS laptop.

I'd be grateful for any suggestions. Thanks!
Last edited by 7an on 24 Dec 2013, 08:26, edited 1 time in total.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4547
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: No ethernet nor wifi on ASUS 1015E

Post#2 by fanthom » 18 Dec 2013, 10:02

hi 7an,

if wl driver does not work then you have to blacklist it and download brcm firmware, please follow broadcom HOWTO carefully:
viewtopic.php?f=39&t=1099

regarding ethernet driver: please show me output of 'lspci -knn | grep Ethernet' command.
thanks
Please add [Solved] to your thread title if the solution was found.

7an
White ninja
White ninja
Posts: 4
Joined: 18 Dec 2013, 09:32
Distribution: 2.1
Location: San Diego, CA

Re: No ethernet nor wifi on ASUS 1015E

Post#3 by 7an » 19 Dec 2013, 02:45

Thanks for your reply, fanthom!

I'll give the compile/extract instructions a try. I wonder, if I blacklist wl in order to get it working on this machine, will wifi be messed up on other computers?

The output of "lspci -knn | grep Ethernet" in Porteus is:

03:00.0 Ethernet controller [0200]: Atheros Communications Inc. Device [1969:1090] (rev 10)

And on the same computer in CrunchBang (Debian):

03:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR8162 Fast Ethernet [1969:1090] (rev 10)

Thanks again!

User avatar
fanthom
Site Admin
Site Admin
Posts: 4547
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: No ethernet nor wifi on ASUS 1015E

Post#4 by fanthom » 19 Dec 2013, 22:13

if I blacklist wl in order to get it working on this machine, will wifi be messed up on other computers?
yes but only ones which have broadcom chipset which is not supported by the open source drivers. the list is here: click
probably the best idea is to create separate broadcom-os.xzm containing 'blacklist wl' + opensource firmware -> put it into /porteus/optional folder -> use 'load=broadcom-os' cheatcode when it's necessary.

bad news regarding wired connection: kernel update is necessary as alx driver was not present in the kernel released with porteus-2.1:
http://www.linuxfoundation.org/collabor ... orking/alx
good news is that early next we are shipping porteus-3.0-rc1 with new kernel and upgrade is as easy as taking vmlinuz+000-kernel.xzm from it and replacing existing ones.
Please add [Solved] to your thread title if the solution was found.

7an
White ninja
White ninja
Posts: 4
Joined: 18 Dec 2013, 09:32
Distribution: 2.1
Location: San Diego, CA

Re: No ethernet nor wifi on ASUS 1015E

Post#5 by 7an » 19 Dec 2013, 23:02

Hi again fanthom,

Thank you for your reply and the advice re: the wifi; I'll try that if I can get it running.

Thanks also for the info about the next release; I'll check that out once it becomes available. Great work by you and the team.

Post Reply