sound card issue -- driver ca0106

Here you can post about your various experiences with PC hardware. You can also post about hardware that is not compatible with the linux kernel or not recommended for use with Porteus.
Post Reply
Burninbush
Power user
Power user
Posts: 49
Joined: 29 Dec 2010, 01:46
Location: Near SF, CA

sound card issue -- driver ca0106

Post#1 by Burninbush » 02 Feb 2011, 18:50

I'll mention this here, without much hope.

The driver in the subject line is for a couple Creative sound cards: Sound Blaster Live 5.1 24-bit, and also Audigy SE [may in fact be the same card] and a few others from CT.

Card works wonderfully in windows from win2k forward, excellent low-distortion sound, but have never gotten it to work correctly in any linux distro. The problem appears as a ridiculously reduced Kmixer [and alsamixer] display, only a few sliders, none for front or main volume.

I hear stories of people who have gotten it to work, by fiddling with 'asound.rc' or something like, but copying what they did has never worked for me.

I have another prized older soundcard, TurtleBeach Santa Cruz, which is also wildly incorrect in stock Slax distribution, but by adding KDEMultimedia -xxx-.tgz I get a proper mixer display.

Hopefully,
bb

User avatar
brokenman
Site Admin
Site Admin
Posts: 5574
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: sound card issue -- driver ca0106

Post#2 by brokenman » 02 Feb 2011, 20:24

Perhaps you can add some elements to /etc/rc.alsa as mentioned in viewtopic.php?f=53&t=266.

It won't help fix your funky display but may give you sound without accessing the sliders.
How do i become super user?
Wear your underpants on the outside and put on a cape.

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: sound card issue -- driver ca0106

Post#3 by Ahau » 02 Feb 2011, 21:14

Have you ruled out conflicting hardware or drivers?

See: http://forums.linuxmint.com/viewtopic.p ... 4&p=330589

Maybe try booting to command line, rmmod'ing everything you can, then load this drivver, and check alsamixer.

Good luck!
Please take a look at our online documentation, here. Suggestions are welcome!

Burninbush
Power user
Power user
Posts: 49
Joined: 29 Dec 2010, 01:46
Location: Near SF, CA

Re: sound card issue -- driver ca0106

Post#4 by Burninbush » 02 Feb 2011, 22:22

Have you ruled out conflicting hardware or drivers?

See: http://forums.linuxmint.com/viewtopic.p ... 4&p=330589 >ahau

++++++++++++++

Uhmmm ... well, sure you have to disable onboard sound. However, the guy at the link who considers his problem solved may yet still have the problem I perceive here.

A lsusb command shows no unexpected devices.

What does only 4 'subdevices' mean? Does that correspond to sliders in a mixer? For example, when I use aplay -l to look at this Turtle Beach card it lists 32 subdevices -- and that is how many sliders I see in Kmix or alsamixer. The SB card only shows 4, while in windows it has many more controls.

And, to be clear, my cs46xx driver for the Turtle Beach card is loaded by stock slax, but with a very reduced set of sliders, not nearly enough to control all the functions on the card. Adding kdemultimedia solves it for the TB card, but not for the Sound Blaster. So ... I have the idea that the problem is not with the basic ca0106 driver but with Kmix or other linux mixer apps. Where do the mixer apps learn about the driver capabilities?

A google on 'ca0106 linux' will find many users unhappy with it in linux. I'm amazed that a card as popular as the SB Live 5.1 isn't well served.

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: sound card issue -- driver ca0106

Post#5 by Ahau » 03 Feb 2011, 00:18

I had a feeling that you would have already tried anything I knew how to suggest :)

Do you get no sound at all, or do you get some sound, with limited capabilities?

I don't know where the mixer apps find out about driver capabilities, either. I was trying to answer that question myself when I stumbled on rc.alsa, and stopped looking after my fix there worked.
Please take a look at our online documentation, here. Suggestions are welcome!

Burninbush
Power user
Power user
Posts: 49
Joined: 29 Dec 2010, 01:46
Location: Near SF, CA

Re: sound card issue -- driver ca0106

Post#6 by Burninbush » 03 Feb 2011, 18:14

I had a feeling that you would have already tried anything I knew how to suggest :)

Do you get no sound at all, or do you get some sound, with limited capabilities? >ahau

+++++++++++++++

Well, you never know -- sometimes answers come in out of the blue. You think all is lost, but then discover a bunch of people had solved your problem and they thought everybody knew the solution.

Yes, I get sound from the card, but as noted the Kmix gui shows only 4 sliders -- as I recall they are like front left, front right, and a couple others I don't recall -- does not even show a master volume, and no way at all to use the surround capabilities. Adding KDEMultimedia does not fix it for that card. As I recall it, the name on the mixer gui is also incorrect.

Ideally, I'd like to see an article that explains the entire chain of events, including how to setup the mixer [whichever one decides to use].

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: sound card issue -- driver ca0106

Post#7 by Ahau » 03 Feb 2011, 18:29

Ahh, I understand better now. Initially, I thought you were getting no sound at all.

If you come across such an article, please post it. I've only found bits and pieces. I was wondering if alsamixer pulled info from asound.state, so I deleted asound.state and alsamixer still worked, so it's not taken directly from there.
Please take a look at our online documentation, here. Suggestions are welcome!

User avatar
Hamza
Warlord
Warlord
Posts: 1847
Joined: 28 Dec 2010, 07:41
Distribution: Porteus
Location: France

Re: sound card issue -- driver ca0106

Post#8 by Hamza » 03 Feb 2011, 19:15

Maybe , your driver ca0106 do not works with alsa mixer , try with OSS mixer !

Regards,
NjVFQzY2Rg==

Post Reply