NDISwrapper

Post links to your 32-bit module repos here. Repo maintainers are responsible for resolving any issues caused by their xzm's.
Post Reply
RogueNeuron
Ronin
Ronin
Posts: 1
Joined: 30 Oct 2013, 20:50
Distribution: Manjaro KDE
Location: USA

NDISwrapper

Post#1 by RogueNeuron » 30 Oct 2013, 21:07

Had a hard time finding any recent info on ndiswrapper and porteus and 1.57/1.58 wouldnt build or install properly from source for me so I pulled this pkg from the slackware repo and converted it. Optimal or not, it works for me with no issues. Hopefully someone else benefits from it, enjoy.


As usual, copy to /porteus/modules or load it on-the-fly.

Usage:
modprobe ndiswrapper
ndiswrapper -i /path/to/driver.inf
ndiswrapper -m

add "modprobe ndiswrapper" to your startup script.


ndiswrapper-1.52_2.6.24.5_smp-i486-1alien.xzm

User avatar
fanthom
Site Admin
Site Admin
Posts: 4590
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: NDISwrapper

Post#2 by fanthom » 31 Oct 2013, 09:46

this module wont work with Porteus as depends on the specific kernel version. Porteus has kernel in version '3.9.11' and this package was created for '2.6.24.5' (pretty ancient).

if you want ndiswrapper running then you should get the sources from the slackbuilds project and compile it on your PC:
http://slackbuilds.org/repository/14.0/ ... pper-utils (utilities which does not depend on the kernel version)
http://slackbuilds.org/repository/14.0/ ... er-kernel/ (kernel module which is compiled against the kernel version you are using right now)
Please add [Solved] to your thread title if the solution was found.

Post Reply