[Solved]Mobile connection failure

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
dataworx
White ninja
White ninja
Posts: 14
Joined: 21 Oct 2013, 17:19
Distribution: Porteus LXDE v2.1 i486
Location: ZA

[Solved]Mobile connection failure

Post#1 by dataworx » 28 Oct 2013, 11:09

I'm trying to establish a mobile broadband (GSM) connection, I get:

Connection failure
Failed to add/activate connection
(32) apn

The modem and sim test OK in other windows and linux boxes. Wifi works fine.

Is there a quick fix?
Last edited by dataworx on 28 Oct 2013, 13:54, edited 1 time in total.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5576
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Mobile connection failure

Post#2 by brokenman » 28 Oct 2013, 11:21

You give very little info to troubleshoot. Upload the file dump from: xpsinfo and link to it here. Also please change your 'Distribution' in your profile from knoppix to whatever version/desktop of Porteus you are using. This will save people having to ask when you post a problem.
How do i become super user?
Wear your underpants on the outside and put on a cape.

dataworx
White ninja
White ninja
Posts: 14
Joined: 21 Oct 2013, 17:19
Distribution: Porteus LXDE v2.1 i486
Location: ZA

Re: Mobile connection failure

Post#3 by dataworx » 28 Oct 2013, 11:44

Wow, you guys are quick

http://pastebin.ca/2472135

User avatar
fanthom
Site Admin
Site Admin
Posts: 4621
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Mobile connection failure

Post#4 by fanthom » 28 Oct 2013, 13:06

looks like 'iso-codes' package never made into LXDE/XFCE desktops (Razor/MATE/KDE4 are ok):

Code: Select all

** (nm-applet:3225): WARNING **: Cannot create mobile providers database: Failed to load '/usr/share/xml/iso-codes/iso_3166.xml' from 'iso-codes': Failed to open file '/usr/share/xml/iso-codes/iso_3166.xml': No such file or directory
please download it from here:
http://ftp.heanet.ie/mirrors/ftp.slackw ... arch-1.txz
then convert to xzm and activate.

now you should be able to use your mobile connection without problems.
Please add [Solved] to your thread title if the solution was found.

dataworx
White ninja
White ninja
Posts: 14
Joined: 21 Oct 2013, 17:19
Distribution: Porteus LXDE v2.1 i486
Location: ZA

Re: [Solved]Mobile connection failure

Post#5 by dataworx » 28 Oct 2013, 13:55

Damn! I think I found my new home. Thanks for the excellent product and service.

Post Reply