[SOLVED]]AMD Cataylst Reports Wrong OpenGL version

Post here if you are a new Porteus member and you're looking for some help.
JR44
White ninja
White ninja
Posts: 10
Joined: 27 Oct 2013, 20:33
Distribution: Porteus 2.1 64bit
Location: US

[SOLVED]]AMD Cataylst Reports Wrong OpenGL version

Post#1 by JR44 » 27 Oct 2013, 20:52

Hi I have a AMD Radeon HD 5450 and the opengl version should be 3.2 as it was when I had windows.
It reported 4.2 and then I installed java and now its saying 1.4. I can't play minecraft or any other opengl game any help please?
Running Porteus 2.1 64bit

EDIT: Ran glxinfo | grep -i opengl
heres the results

Code: Select all

libGL error: failed to load driver: swrast
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: AMD Radeon HD 5450
OpenGL version string: 1.4 (2.1 (4.2.12217 Compatibility Profile Context 12.104))
OpenGL extensions:
No OpenGL extensions are showing

EDIT 2: So I also need the x32 bit packages but cant find them anywhere do I download the x32 bit of porteus and copy over the files or is there a way to compile the .run from AMD website?
Last edited by JR44 on 05 Nov 2013, 12:42, edited 3 times in total.

lybxlpsv
Ronin
Ronin
Posts: 3
Joined: 28 Oct 2013, 11:28
Distribution: Porteus 2.1 64bit
Location: asdf

Re: AMD Cataylst Reports Wrong OpenGL version

Post#2 by lybxlpsv » 28 Oct 2013, 11:30

having the same problem here with AMD RADEON HD 5470.
help?

User avatar
fanthom
Site Admin
Site Admin
Posts: 4588
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: AMD Cataylst Reports Wrong OpenGL version

Post#3 by fanthom » 28 Oct 2013, 13:43

@guys
everything is ok here:

Code: Select all

guest@porteus:~$ glxinfo | grep -i opengl
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: ATI Radeon HD 2600 XT
OpenGL core profile version string: 3.3.11672 Core Profile Context
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.3.11672 Compatibility Profile Context
OpenGL shading language version string: 3.30
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile
OpenGL extensions:
there is something wrong with your system (probably amd-catalyst-legacy module was unloaded prior to Xorg startup) so please post a link to the raport generated by 'xpsinfo' utility.
Please add [Solved] to your thread title if the solution was found.

lybxlpsv
Ronin
Ronin
Posts: 3
Joined: 28 Oct 2013, 11:28
Distribution: Porteus 2.1 64bit
Location: asdf

Re: AMD Cataylst Reports Wrong OpenGL version

Post#4 by lybxlpsv » 28 Oct 2013, 14:28

heres the psinfo report file link
http://mc2.lybxlpsv.com/psinfo_report.txt
EDIT : Fixed by making symlink from /usr/lib64/fglrx/fglrx-libGL.so.1.2 to /usr/lib64/libGL.so.1.2.0. It was linked to swrast driver.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4588
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: AMD Cataylst Reports Wrong OpenGL version

Post#5 by fanthom » 28 Oct 2013, 15:58

Fixed by making symlink from /usr/lib64/fglrx/fglrx-libGL.so.1.2 to /usr/lib64/libGL.so.1.2.0. It was linked to swrast driver.
any idea how this swrast symlink was created? did you boot porteus on different PCs or maybe VirtualBox?
Please add [Solved] to your thread title if the solution was found.

lybxlpsv
Ronin
Ronin
Posts: 3
Joined: 28 Oct 2013, 11:28
Distribution: Porteus 2.1 64bit
Location: asdf

Re: AMD Cataylst Reports Wrong OpenGL version

Post#6 by lybxlpsv » 28 Oct 2013, 22:27

no, i'm just copied the files to my flashdisc.
and this is running amd-catalyst module not amd-catalyst-legacy, maybe there was something to do with the amd-catalyst module?
anyways the driver goes back to swrast every reboot so need to redo the symlink.

JR44
White ninja
White ninja
Posts: 10
Joined: 27 Oct 2013, 20:33
Distribution: Porteus 2.1 64bit
Location: US

Re: AMD Cataylst Reports Wrong OpenGL version

Post#7 by JR44 » 29 Oct 2013, 01:08

fanthom wrote:@guys
everything is ok here:

Code: Select all

guest@porteus:~$ glxinfo | grep -i opengl
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: ATI Radeon HD 2600 XT
OpenGL core profile version string: 3.3.11672 Core Profile Context
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.3.11672 Compatibility Profile Context
OpenGL shading language version string: 3.30
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile
OpenGL extensions:
there is something wrong with your system (probably amd-catalyst-legacy module was unloaded prior to Xorg startup) so please post a link to the raport generated by 'xpsinfo' utility.
Here you go http://pastebin.ca/2472328
EDIT:
The opengl version seems to change when I activate the java module and once I deactivate it still is 1.4. Might it be the module thats causing the problem? also New xps info log top one is w/out java on always fresh
http://pastebin.ca/2472335

User avatar
fanthom
Site Admin
Site Admin
Posts: 4588
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: AMD Cataylst Reports Wrong OpenGL version

Post#8 by fanthom » 29 Oct 2013, 08:37

glad that you are able to recreate issue so let's track it down. could both of you boot porteus as before (make sure that /usr/lib64/libGL.so points to swrast, and glxinfo reports opengl version 1.4) and then give me an output of following commands:

Code: Select all

find /mnt/live/memory/ -name "libGL.so*"
ls -al /usr/lib64/libGL.so
who -b
thanks.
Please add [Solved] to your thread title if the solution was found.

JR44
White ninja
White ninja
Posts: 10
Joined: 27 Oct 2013, 20:33
Distribution: Porteus 2.1 64bit
Location: US

Re: AMD Cataylst Reports Wrong OpenGL version

Post#9 by JR44 » 29 Oct 2013, 11:53

For "find /mnt/live/memory/ -name "libGL.so*""

Code: Select all

root@porteus:/home/guest# find /mnt/live/memory/ -name "libGL.so*"
/mnt/live/memory/changes/usr/lib64/libGL.so.1
/mnt/live/memory/images/amd-catalyst-13.4-porteus-v2.1-x86_64-1ftm.xzm/usr/lib64/libGL.so
/mnt/live/memory/images/amd-catalyst-13.4-porteus-v2.1-x86_64-1ftm.xzm/usr/lib64/libGL.so.1
/mnt/live/memory/images/amd-catalyst-13.4-porteus-v2.1-x86_64-1ftm.xzm/usr/lib64/libGL.so.1.2
/mnt/live/memory/images/002-xorg.xzm/usr/lib64/libGL.so
/mnt/live/memory/images/002-xorg.xzm/usr/lib64/libGL.so.1
/mnt/live/memory/images/002-xorg.xzm/usr/lib64/libGL.so.1.2.0
For "ls -al /usr/lib64/libGL.so"

Code: Select all

lrwxrwxrwx 1 root root 10 Jul 23 02:14 /usr/lib64/libGL.so -> libGL.so.1*
For "who -b"

Code: Select all

         system boot  2013-10-29 06:33

User avatar
fanthom
Site Admin
Site Admin
Posts: 4588
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: AMD Cataylst Reports Wrong OpenGL version

Post#10 by fanthom » 29 Oct 2013, 12:10

i'm sorry - please run these 4 commands (will give me brighter picture whats happening):

Code: Select all

find /mnt/live/memory/ -name "libGL.so*"
ls -al /usr/lib64/libGL.so*
who -b
glxinfo | grep -i opengl
Please add [Solved] to your thread title if the solution was found.

JR44
White ninja
White ninja
Posts: 10
Joined: 27 Oct 2013, 20:33
Distribution: Porteus 2.1 64bit
Location: US

Re: AMD Cataylst Reports Wrong OpenGL version

Post#11 by JR44 » 29 Oct 2013, 19:55

Here You go

Code: Select all

root@porteus:/home/guest# find /mnt/live/memory/ -name "libGL.so*"
/mnt/live/memory/images/amd-catalyst-13.4-porteus-v2.1-x86_64-1ftm.xzm/usr/lib64/libGL.so
/mnt/live/memory/images/amd-catalyst-13.4-porteus-v2.1-x86_64-1ftm.xzm/usr/lib64/libGL.so.1
/mnt/live/memory/images/amd-catalyst-13.4-porteus-v2.1-x86_64-1ftm.xzm/usr/lib64/libGL.so.1.2
/mnt/live/memory/images/002-xorg.xzm/usr/lib64/libGL.so
/mnt/live/memory/images/002-xorg.xzm/usr/lib64/libGL.so.1
/mnt/live/memory/images/002-xorg.xzm/usr/lib64/libGL.so.1.2.0

Code: Select all

root@porteus:/home/guest# find /mnt/live/memory/ -name "libGL.so*"
/mnt/live/memory/images/amd-catalyst-13.4-porteus-v2.1-x86_64-1ftm.xzm/usr/lib64/libGL.so
/mnt/live/memory/images/amd-catalyst-13.4-porteus-v2.1-x86_64-1ftm.xzm/usr/lib64/libGL.so.1
/mnt/live/memory/images/amd-catalyst-13.4-porteus-v2.1-x86_64-1ftm.xzm/usr/lib64/libGL.so.1.2
/mnt/live/memory/images/002-xorg.xzm/usr/lib64/libGL.so
/mnt/live/memory/images/002-xorg.xzm/usr/lib64/libGL.so.1
/mnt/live/memory/images/002-xorg.xzm/usr/lib64/libGL.so.1.2.0

Code: Select all

root@porteus:/home/guest# ls -al /usr/lib64/libGL.so*
lrwxrwxrwx 1 root root     10 Jul 23 02:14 /usr/lib64/libGL.so -> libGL.so.1*
lrwxrwxrwx 1 root root     12 Jul 23 02:14 /usr/lib64/libGL.so.1 -> libGL.so.1.2*
lrwxrwxrwx 1 root root     24 Jul 23 02:14 /usr/lib64/libGL.so.1.2 -> fglrx/fglrx-libGL.so.1.2*
-rwxr-xr-x 1 root root 441208 Aug  2 09:37 /usr/lib64/libGL.so.1.2.0*

Code: Select all

root@porteus:/home/guest# who -b
         system boot  2013-10-29 14:52

Code: Select all

root@porteus:/home/guest# glxinfo | grep -i opengl
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon HD 5450
OpenGL core profile version string: 4.2.12217 Core Profile Context 12.104
OpenGL core profile shading language version string: 4.20
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.2.12217 Compatibility Profile Context 12.104
OpenGL shading language version string: 4.20
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile
OpenGL extensions:


User avatar
fanthom
Site Admin
Site Admin
Posts: 4588
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: AMD Cataylst Reports Wrong OpenGL version

Post#12 by fanthom » 29 Oct 2013, 20:40

i see that symlink from your changes is missing:

Code: Select all

/mnt/live/memory/changes/usr/lib64/libGL.so.1
and OpenGL reports correct version:

Code: Select all

OpenGL version string: 4.2.12217 Compatibility Profile Context 12.104
did you boot without 'changes=' cheatcode?
if yes then please delete '/changes/usr/lib64/libGL.so.1' symlink manually (if stored inside save.dat then please mount it with 'mloop' utility) and boot with 'changes=' cheatcode.
if swrast symlink wont recreate then everything should be ok (although i still dont know how it was created in first place). if it will recreate then please post 4 commands again.

thanks.
Please add [Solved] to your thread title if the solution was found.

JR44
White ninja
White ninja
Posts: 10
Joined: 27 Oct 2013, 20:33
Distribution: Porteus 2.1 64bit
Location: US

Re: AMD Cataylst Reports Wrong OpenGL version

Post#13 by JR44 » 29 Oct 2013, 20:54

Tested Minecraft and shadertoy and it finally works correctly thanks!

JR44
White ninja
White ninja
Posts: 10
Joined: 27 Oct 2013, 20:33
Distribution: Porteus 2.1 64bit
Location: US

Re: [REOPENED]]AMD Cataylst Reports Wrong OpenGL version

Post#14 by JR44 » 04 Nov 2013, 22:49

Its back again on my phone gotta copy n paste text manually will edit when finished
Edit: taking photo instead going to upload

Edit 2: blah pics are too big so i'll have to type it out

Code: Select all

guest@porteus:~$ su
Password: 
root@porteus:/home/guest# find /mnt/live/memory/ -name "libGL.so*"
/mnt/live/memory/changes/usr/lib64/libGL.so.1
/mnt/live/memory/images/amd-catalyst-13.4-porteus-v2.1-x86_64-1ftm.xzm/usr/lib64/libGL.so
/mnt/live/memory/images/amd-catalyst-13.4-porteus-v2.1-x86_64-1ftm.xzm/usr/lib64/libGL.so.1
/mnt/live/memory/images/amd-catalyst-13.4-porteus-v2.1-x86_64-1ftm.xzm/usr/lib64/libGL.so.1.2
/mnt/live/memory/images/002-xorg.xzm/usr/lib64/libGL.so
/mnt/live/memory/images/002-xorg.xzm/usr/lib64/libGL.so.1
/mnt/live/memory/images/002-xorg.xzm/usr/lib64/libGL.so.1.2.0
root@porteus:/home/guest# ls -al /usr/lib64/libGL.so*
lrwxrwxrwx 1 root root     10 Jul 23 02:14 /usr/lib64/libGL.so -> libGL.so.1*
lrwxrwxrwx 1 root root     14 Oct 31 16:15 /usr/lib64/libGL.so.1 -> libGL.so.1.2.0*
lrwxrwxrwx 1 root root     24 Jul 23 02:14 /usr/lib64/libGL.so.1.2 -> fglrx/fglrx-libGL.so.1.2*
-rwxr-xr-x 1 root root 441208 Aug  2 09:37 /usr/lib64/libGL.so.1.2.0*
root@porteus:/home/guest# who -b
         system boot  2013-11-04 17:39
root@porteus:/home/guest# glxinfo | grep -i opengl
libGL error: failed to load driver: swrast
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: AMD Radeon HD 5450
OpenGL version string: 1.4 (2.1 (4.2.12217 Compatibility Profile Context 12.104))
OpenGL extensions:
root@porteus:/home/guest# 

User avatar
fanthom
Site Admin
Site Admin
Posts: 4588
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: [REOPENED]]AMD Cataylst Reports Wrong OpenGL version

Post#15 by fanthom » 05 Nov 2013, 11:46

right so we can see that swrast symlink was created on 31st of October at 16:15:

Code: Select all

lrwxrwxrwx 1 root root     14 Oct 31 16:15 /usr/lib64/libGL.so.1 -> libGL.so.1.2.0*
do you remember what you were doing by then? did you activate some extra modules? had booting problems? anything?

please bring back amd-catalyst symlink with following command:

Code: Select all

ln -sf /usr/lib64/libGL.so.1.2 /usr/lib64/libGL.so.1
then reboot and confirm that 'glxinfo' returns opengl-4.x.

now - please watch /usr/lib64/libGL.so.1 symlink and try to find when it changes from /usr/lib64/libGL.so.1.2 (amd-catalyst) to /usr/lib64/libGL.so.1.2.0 (swrast from mesa).
please let us know if you find the reason (i'm damn curious how it's happening).
Please add [Solved] to your thread title if the solution was found.

Post Reply