[Solved]cups.sock missing

Get help with XFCE specific problems
xtudiux
Black ninja
Black ninja
Posts: 72
Joined: 07 Mar 2011, 06:01
Location: Philippines

[Solved]cups.sock missing

Post#1 by xtudiux » 28 Sep 2013, 11:28

good pm,
my cups setting in /var is missing...everytime I restarts...

:D
Last edited by xtudiux on 18 Jan 2014, 05:26, edited 1 time in total.

User avatar
francois
Contributor
Contributor
Posts: 4990
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: cups.sock missing

Post#2 by francois » 28 Sep 2013, 14:21

Are you working with 2.1 version? Did you install printing.xzm module?
Voltaire: Le mieux est l'ennemi du bien.

xtudiux
Black ninja
Black ninja
Posts: 72
Joined: 07 Mar 2011, 06:01
Location: Philippines

Re: cups.sock missing

Post#3 by xtudiux » 29 Sep 2013, 13:31

good pm,

Yep. installed 2.1 x64. Also installed printing.xzm. It works when I downloaded the cups.xxx.xzm. It works again. but when I restart the system again. cups.sock is missing again. :D

User avatar
wread
Module Guard
Module Guard
Posts: 1080
Joined: 09 Jan 2011, 18:48
Distribution: Porteus v3.2.5-kde5-64 bits
Location: Santo Domingo
Contact:

Re: cups.sock missing

Post#4 by wread » 29 Sep 2013, 19:12

When you download cups.xxx.xzm you must put it in modules folder; if you leave it in a volatile folder, it will be gone when you restart the machine :(
Porteus is proud of the FASTEST KDE ever made.....(take akonadi, nepomuk and soprano out and you will have a decent OS).
The Porteus Community never sleeps!

xtudiux
Black ninja
Black ninja
Posts: 72
Joined: 07 Mar 2011, 06:01
Location: Philippines

Re: cups.sock missing

Post#5 by xtudiux » 30 Sep 2013, 03:14

Good pm,

I put it on the module folder. I notice that the permission on /var/run/cups is lp and its is only read...when i used the root account it works.

User avatar
francois
Contributor
Contributor
Posts: 4990
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: cups.sock missing

Post#6 by francois » 01 Oct 2013, 15:25

1) From what I understand you try a) to work from guest mode and you b) have the save change cheatcode in your bootloader commands. What is the bootloader that you are using currently? And what are the commands invoqued to have the save change options working?

2) You are trying to modify some parameters in the /etc/cups/cupsd.conf relative to some command lines in this file:

Code: Select all

# Only listen for connections from the local machine.
Listen localhost:631
Listen /var/run/cups/cups.sock
3) You have been setting CUPS from guest mode, but using root from terminal to get cupsd.conf modified within guest mode.

Did you tried to logout guest mode, login root mode and setup the cupsd.conf file from root mode?
Voltaire: Le mieux est l'ennemi du bien.

xtudiux
Black ninja
Black ninja
Posts: 72
Joined: 07 Mar 2011, 06:01
Location: Philippines

Re: cups.sock missing

Post#7 by xtudiux » 02 Oct 2013, 05:33

1.) hmmm...I think its syslinux.
2.) I didnt change any setting in cupsd.conf
3.) It used to work under guest mode...

I havent tried to logout in guest mode yet...I'll try that...
PS. the temp soln is download the cups-1.5.4-x86_64.xzm to make the print work... :D

xtudiux
Black ninja
Black ninja
Posts: 72
Joined: 07 Mar 2011, 06:01
Location: Philippines

Re: cups.sock missing

Post#8 by xtudiux » 12 Oct 2013, 04:25

Good am,

I notice when my porteus v2.1 x64 xfce boots up and manually activate the system-printer it works. but it activate automatically on boot-up. cups.sock is missing...
Just an observation. :D

User avatar
fanthom
Site Admin
Site Admin
Posts: 4588
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: cups.sock missing

Post#9 by fanthom » 12 Oct 2013, 12:01

@xtudiux
thats important information - will check it today.
thanks

EDIT:\\
everything is ok - cups sock is created no matter if module is activated during boot or during live session.
please make sure you have /etc/rc.d/rc.cups executable (maybe non exec file from your changes is playing a role here):

Code: Select all

chmod +x /etc/rc.d/rc.cups
Please add [Solved] to your thread title if the solution was found.

xtudiux
Black ninja
Black ninja
Posts: 72
Joined: 07 Mar 2011, 06:01
Location: Philippines

Re: cups.sock missing

Post#10 by xtudiux » 08 Nov 2013, 03:12

Good am...

Still the same...I have to manually activate the printer.xzm to make it work..anyway. its alright I rarely use it anyway...hehehehhe :D

tome
Contributor
Contributor
Posts: 562
Joined: 26 Jun 2013, 14:03
Distribution: x64 Openbox
Location: Poland
Contact:

Re: cups.sock missing

Post#11 by tome » 08 Nov 2013, 22:57

Try fresh mode and load your modules during boot in correct order - simply change first letter (number) of module name.

User avatar
francois
Contributor
Contributor
Posts: 4990
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: cups.sock missing

Post#12 by francois » 13 Nov 2013, 03:15

Have you tried the print.xzm in fresh mode? Also, a very silly question, in what folder did you put the module? :oops:
Voltaire: Le mieux est l'ennemi du bien.

xtudiux
Black ninja
Black ninja
Posts: 72
Joined: 07 Mar 2011, 06:01
Location: Philippines

Re: cups.sock missing

Post#13 by xtudiux » 13 Nov 2013, 06:44

Good pm,

1. havent try the fresh mode
2. its on the base folder...

User avatar
francois
Contributor
Contributor
Posts: 4990
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: cups.sock missing

Post#14 by francois » 14 Nov 2013, 00:22

Just give a try to always fresh mode, and report.
Voltaire: Le mieux est l'ennemi du bien.

xtudiux
Black ninja
Black ninja
Posts: 72
Joined: 07 Mar 2011, 06:01
Location: Philippines

Re: cups.sock missing

Post#15 by xtudiux » 24 Dec 2013, 11:36

Good pm,

Tried Always Fresh...Still the same...the printer module is not working...It needs to be deactivated then activate...

Anyway, I have a partial solution...I put it on the manual activation... :) ...Its not an elegant solution but it works...hehehhe

Post Reply