changes to /etc/lxdm/lxdm.conf lost on reboot

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
barnex
Ronin
Ronin
Posts: 2
Joined: 11 Sep 2013, 20:37
Distribution: porteus2.1-xfce
Location: Belgium

changes to /etc/lxdm/lxdm.conf lost on reboot

Post#1 by barnex » 11 Sep 2013, 20:58

Hi,

I'm trying to edit /etc/lxdm/lxdm.conf to autologin under my proper user name instead of guest. However, after every reboot, my changes to lxdm.conf are gone (while changes to other files are persistent). Later I also tried to put an lxdm.conf in my rootcopy/ and even rebuilt the 003-xfce4.xzm module with my lxdm.conf, but none of that worked: the default lxdm.conf file always returned.

Am I missing something?

Thanks,
Arne.

(running Linux porteus 3.9.11-porteus #1 SMP PREEMPT Mon Jul 22 22:29:21 UTC 2013 x86_64)

User avatar
fanthom
Site Admin
Site Admin
Posts: 4547
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: changes to /etc/lxdm/lxdm.conf lost on reboot

Post#2 by fanthom » 12 Sep 2013, 16:21

hi barnex,

please use 'login=user' cheatcode.
also - please read /boot/docs/cheatcodes.txt and other docs from http://www.porteus.org/info/tips-and-tricks.html and http://www.porteus.org/info/tutorials.html as many users are asking about features which are well explained in our basic documentation.
Please add [Solved] to your thread title if the solution was found.

User avatar
wread
Module Guard
Module Guard
Posts: 1062
Joined: 09 Jan 2011, 18:48
Distribution: Porteus v3.2.5-kde5-64 bits
Location: Santo Domingo
Contact:

Re: changes to /etc/lxdm/lxdm.conf lost on reboot

Post#3 by wread » 13 Sep 2013, 13:02

We must remember to rtfm...
Porteus is proud of the FASTEST KDE ever made.....(take akonadi, nepomuk and soprano out and you will have a decent OS).
The Porteus Community never sleeps!

barnex
Ronin
Ronin
Posts: 2
Joined: 11 Sep 2013, 20:37
Distribution: porteus2.1-xfce
Location: Belgium

Re: changes to /etc/lxdm/lxdm.conf lost on reboot

Post#4 by barnex » 13 Sep 2013, 14:27

sorry guys, but I had already tried the login=arne cheatcode and it didn't work either:

Code: Select all

login=arne
boots into lxdm login screen, with the keyboard layout wrongly set

Code: Select all

login
boots straight into guest account, not login screen like the documentation suggests.

Sure I can logout guest and login myself, that's only a minor annoyance.

But I would like to understand why my changes to lxdm.conf are not persistent, while changes to /etc/shadow et al., made in the same way, stayed fine. Maybe I want to make some other customization there as well. Am I missing some subtlety about the live FS?

-Arne

User avatar
brokenman
Site Admin
Site Admin
Posts: 5436
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: changes to /etc/lxdm/lxdm.conf lost on reboot

Post#5 by brokenman » 13 Sep 2013, 21:17

Hi Arne,

My suggestion would be to make your changes to lxdm.conf and them copy it into the rootcopy folder with the full path.

cp -a --parents /etc/lxdm/lxde.conf /mnt/sdxY/porteus/rootcopy

Rootcopy is the last folder to be copied to the live file system so if this does not work then there may be something wrong with your setup.
How do i become super user?
Wear your underpants on the outside and put on a cape.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4547
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: changes to /etc/lxdm/lxdm.conf lost on reboot

Post#6 by fanthom » 14 Sep 2013, 18:03

@barnex
correction:
'login' wont disable autologin, 'login=' will do
'login=arne' should bring you to the desktop, please check if /home/arne is there and has correct permissions. once you boot with 'login=arne' you should get lxdm.conf updated automatically with this username.

also - there is a bug which i reported to Ahau:

Code: Select all

when you boot into LXDE with saved changes and then switch to XFCE then booting stops at the login screen.
this is because edited lxdm.conf persists in changes and is overwriting one from xfce module (has 'session=/usr/bin/startlxde')
solution is to use sed to change to 'startxfce4' in rc.4 or point config to /usr/bin/startde which would be a symlink to startlxde/startxfce4/startrazor/whatever.
so if you are saving changes and previously booted to LXDE then please apply above solution.
Please add [Solved] to your thread title if the solution was found.

Post Reply