Keyboard Layout PT-BR

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
Post Reply
MarTinazzI
White ninja
White ninja
Posts: 12
Joined: 11 Sep 2013, 15:20
Distribution: Super Zaxxon
Location: Brasil

Keyboard Layout PT-BR

Post#1 by MarTinazzI » 11 Sep 2013, 15:38

I'm having problems with the keyboard layout Portuguese-Brazil, I can not use accents.
I use Porteus-2.1 32bit XFCE.
MarTinazzI, rafael

User avatar
Slaxmax
Contributor
Contributor
Posts: 403
Joined: 03 Jan 2013, 09:51
Distribution: KDE4
Location: Campinas Brazil https://goo.gl/yrxwKi

Re: Keyboard Layout PT-BR

Post#2 by Slaxmax » 11 Sep 2013, 16:13

Try it's

add this lines in /home/user/.bashrc

setxkbmap -model abnt2 -layout br -variant abnt2
setxkbmap -option terminate:ctrl_alt_bksp

For more information:
http://www.vivaolinux.com.br/topico/Ini ... -portugues
“DNA is like a computer program but far, far more advanced than any software ever created.”
― Bill Gates, The Road Ahead

User avatar
brokenman
Site Admin
Site Admin
Posts: 5558
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Keyboard Layout PT-BR

Post#3 by brokenman » 12 Sep 2013, 00:24

Welcome MarTinazzI,

In addition to slaxmax's comments, please open the 'Porteus Settings Centre' and run the language selection tool. This should download some files setup your system to run in Brasilian Portuguese. Do you have Brasilian keyboard?

Boa Sorte
How do i become super user?
Wear your underpants on the outside and put on a cape.

tome
Contributor
Contributor
Posts: 571
Joined: 26 Jun 2013, 14:03
Distribution: x64 Openbox
Location: Poland
Contact:

Re: Keyboard Layout PT-BR

Post#4 by tome » 12 Sep 2013, 21:34

If I use language selection tool (64bit) glibc is mounted but core etc. is not - it is downloaded (f.e. ca 60 MB core, all languages). Is it correct?

MarTinazzI
White ninja
White ninja
Posts: 12
Joined: 11 Sep 2013, 15:20
Distribution: Super Zaxxon
Location: Brasil

Re: Keyboard Layout PT-BR

Post#5 by MarTinazzI » 12 Sep 2013, 22:22

brokenman wrote:Welcome MarTinazzI,

In addition to slaxmax's comments, please open the 'Porteus Settings Centre' and run the language selection tool. This should download some files setup your system to run in Brasilian Portuguese. Do you have Brasilian keyboard?

Boa Sorte
That do not help, I use the PT-BR Dvorak, working great, but I use ABNT and dvorak layout.
PT-BR Nativo, I can use accents, but the layout is wrong, some keys are in wrong place, I tested all PT-BR layout and no one with a correct result, just the dvorak, but not all user use this.
tome wrote:If I use language selection tool (64bit) glibc is mounted but core etc. is not - it is downloaded (f.e. ca 60 MB core, all languages). Is it correct?
This download and create a new module with the selected language.
MarTinazzI, rafael

tome
Contributor
Contributor
Posts: 571
Joined: 26 Jun 2013, 14:03
Distribution: x64 Openbox
Location: Poland
Contact:

Re: Keyboard Layout PT-BR

Post#6 by tome » 13 Sep 2013, 07:53

But I don't need all languages, only one, and mounting core and other modules would be better (less data transfer and less time).

User avatar
brokenman
Site Admin
Site Admin
Posts: 5558
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Keyboard Layout PT-BR

Post#7 by brokenman » 14 Sep 2013, 18:37

glibc is mounted over httpfs and the core module is downloaded locally (takes too long to mount over httpfs). The core module is then mounted and the chosen files should be copied into the final module. I use a Portuguese keyboard and in fact tested the script during writing by downloading the Portuguese layout. I'll give it another test tonight to see if I can recreate your problem. Thanks for reporting.
How do i become super user?
Wear your underpants on the outside and put on a cape.

Post Reply