Setting local time on Porteus 2.1. i486 Mate, 32-Bit

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
Post Reply
Johannes
White ninja
White ninja
Posts: 25
Joined: 19 Jan 2013, 21:16
Distribution: Porteus - Kiosk 3.5.0 - i486
Location: Deutschland

Setting local time on Porteus 2.1. i486 Mate, 32-Bit

Post#1 by Johannes » 03 Sep 2013, 20:19

My local time on Porteus 2.1. i486 Mate, 32-Bit is always 2 hours ahead. I am booting off a USB-Stick. Shouldn't Porteus recognize the set time automatically? Even if I reset it manually, it advances 2 hours again after rebooting. Also, when I reset it manually to 2 hours back, it also resets the correct time on Windows to 2 hours back. It's not a big issue for me, but rather a cosmetic one (helps me exercise my subtractions) :D which is hopefully easy to fix. If it isn't, never mind.

Cheers,

Johannes

User avatar
francois
Contributor
Contributor
Posts: 4905
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: Setting local time on Porteus 2.1. i486 Mate, 32-Bit

Post#2 by francois » 04 Sep 2013, 01:53

Try system > settings > porteus setting center > wrench and screwdriver > time config

And follow the instructions. :)
Voltaire: Le mieux est l'ennemi du bien.

Johannes
White ninja
White ninja
Posts: 25
Joined: 19 Jan 2013, 21:16
Distribution: Porteus - Kiosk 3.5.0 - i486
Location: Deutschland

Re: Setting local time on Porteus 2.1. i486 Mate, 32-Bit

Post#3 by Johannes » 09 Sep 2013, 20:14

Sorry, but this is exactly what I did. Like I said, when I switch the time on Porteus OS installed on a USB-Stick, it influences the time setting on the whole system. When it's 8:00 a.m. on Windows 7, it's 10:00 a.m. on Porteus OS. When I set the time on Porteus back to 8:00 a.m., it automatically sets Windows 7 to 6:00 a.m. When I set Windows 7 back to 8:00 a.m., Porteus automatically switches back to 10:00 a.m. It's a vicious cycle! :roll: So now I gave up, and just leave the time settings on Porteus OS two hours ahead.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5439
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Setting local time on Porteus 2.1. i486 Mate, 32-Bit

Post#4 by brokenman » 10 Sep 2013, 01:33

Please try opening a console and entering: timeconfig

Let us know if this fixes things for you.
How do i become super user?
Wear your underpants on the outside and put on a cape.

donald
Full of knowledge
Full of knowledge
Posts: 1126
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Re: Setting local time on Porteus 2.1. i486 Mate, 32-Bit

Post#5 by donald » 10 Sep 2013, 01:42

@johannes
At first please check if you have the correct time in your bios.
If yes, boot porteus..If the time is correct,fine..if not you have to adjust the timezone, but do not adjust the displayed time itself, because if you change the time, then you have the wrong time in the bios.(That is the reason why Windows then also has the wrong time. )
In short:
set current Time In your bios, boot porteus, if your clock don't match, go into
PSC > system settings > Time config > Set Timezone > ...set to localtime > apply > reboot...
and don't change "Set Date/Time"

User avatar
francois
Contributor
Contributor
Posts: 4905
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: Setting local time on Porteus 2.1. i486 Mate, 32-Bit

Post#6 by francois » 12 Nov 2013, 02:27

Finally, I get some problem with xfce setting local time. Time will not be set automatically with porteus time config from the setting center with utc and allocating the correct timezone. There was an error of seven hours that I had to correct with the set Date/time option. :(
Voltaire: Le mieux est l'ennemi du bien.

donald
Full of knowledge
Full of knowledge
Posts: 1126
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Re: Setting local time on Porteus 2.1. i486 Mate, 32-Bit

Post#7 by donald » 12 Nov 2013, 14:13

@francois
Hi
I'm always not sure what it means if someone is saying "local time"
It could mean the current time where you live, or the time value, set in your box/bios.
(what it means to me)
Well, I'm a simple mind.I have set the current time in my bios
and all my OS are set to "just display what the bios tells you"
and as far as I can see It's working...at least for me.
Yes when it comes to DST I have to adjust it,but twice in a year is not too
much effort.
btw.If you still have a MS-OS on your Hdd it will change the DST time for you.
and I know that this is not the universal solution for all cases. :)

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: Setting local time on Porteus 2.1. i486 Mate, 32-Bit

Post#8 by Ahau » 12 Nov 2013, 15:46

@francois,

please download and test my updated timeconfig tool, which I posted in this thread: viewtopic.php?f=117&t=2730&start=15#p19217

Activate the module and run the clock/time settings from Porteus Settings Centre. Select the timezone and toggle between localtime and utc and it will update the time as it will be displayed in the lower right corner of the app. You may have to reset your BIOS clock to your local time before this will work properly (basically undoing the 7 hour change you did previously), assuming you want to continue having your BIOS clock set to local time.

HTH, and let me know if it doesn't.
Please take a look at our online documentation, here. Suggestions are welcome!

User avatar
francois
Contributor
Contributor
Posts: 4905
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: Setting local time on Porteus 2.1. i486 Mate, 32-Bit

Post#9 by francois » 13 Nov 2013, 03:06

Hi, Ahau.

Its nice to see that you are back on the forum.

Thanks for the fix. It worked just fine without having to reset the bios.

Once more your work is greatly appreciated. :)
Voltaire: Le mieux est l'ennemi du bien.

Post Reply