[Solved]No root login on xterm

Here you can post about the issues related to modifications performed manually (not through the kiosk wizard). Example: swapped kernel, added 3rd party modules or files.
Please describe in detail what has been changed and hopefully other kiosk user will be able to help.
Porteus team wont resolve bugs posted in this category as we support only modifications made by the kiosk wizard.
Post Reply
wsteven
Black ninja
Black ninja
Posts: 40
Joined: 21 Aug 2013, 10:01
Distribution: lubuntu
Location: Rennes

[Solved]No root login on xterm

Post#1 by wsteven » 30 Aug 2013, 14:28

Hi,

Coming back here in case anyone feels inspired :D

So I installed necessary packages for xterm, all placed in modules/ . Then I created a shortcut to be able to start it by modifying rc.xml from xdg/openbox/rc.xml which I placed in rootcopy/.

Code: Select all

  <keybind key="S-space">
	<keybind key="Tab">
			    <action name="Execute">
			    <command>/usr/bin/xterm -e su - guest</command>
			    </action>
	</keybind>
  </keybind>
My shortcut works like a charm, starting as guest, but I just can't su - root. Tells me my password is wrong. But I can still log in through ctlr-alt-F1.
Just in case, I placed my shadow file into 003-settings, but no luck.
Maybe I got rights problem? I don't have a clue.

Thanks!
Last edited by wsteven on 17 Oct 2013, 08:57, edited 1 time in total.

User avatar
wread
Module Guard
Module Guard
Posts: 1090
Joined: 09 Jan 2011, 18:48
Distribution: Porteus v3.2.5-kde5-64 bits
Location: Santo Domingo
Contact:

Re: No root login on xterm

Post#2 by wread » 31 Aug 2013, 02:03

What is your version of Porteus?; I use KDE4 and when I type "xterm" the corresponding application pops up inmediately...
Porteus is proud of the FASTEST KDE ever made.....(take akonadi, nepomuk and soprano out and you will have a decent OS).
The Porteus Community never sleeps!

wsteven
Black ninja
Black ninja
Posts: 40
Joined: 21 Aug 2013, 10:01
Distribution: lubuntu
Location: Rennes

Re: No root login on xterm

Post#3 by wsteven » 02 Sep 2013, 08:34

Well latest kiosk, 2.1

EDIT: Managed through ssh root@localhost. As for what I understood, a kernel modification would be necessary to allow su.

Post Reply