locale won't set to fr_FR

Post bug reports related to either the kiosk ISO or the kiosk wizard here.
Post Reply
wsteven
Black ninja
Black ninja
Posts: 40
Joined: 21 Aug 2013, 10:01
Distribution: lubuntu
Location: Rennes

locale won't set to fr_FR

Post#1 by wsteven » 22 Aug 2013, 15:00

Hello,

I did set locale to fr with the wizard, but I still get a qwerty keyboard. Modifying manually /etc/profile.d/lang.sh with

Code: Select all

export LANG=fr_FR
didn't help :(

Any idea?
Thanks,
Steven

User avatar
fanthom
Site Admin
Site Admin
Posts: 4548
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: locale won't set to fr_FR

Post#2 by fanthom » 22 Aug 2013, 18:43

"I did set locale to fr with the wizard,"
i guess you meant keyboard layout?
i have tested it myself: ran kiosk wizard -> choosen 'fr' as kbd layout -> got 'azerty' when typed in the firefox address bar

the fault must be on your side. please try again.
Please add [Solved] to your thread title if the solution was found.

wsteven
Black ninja
Black ninja
Posts: 40
Joined: 21 Aug 2013, 10:01
Distribution: lubuntu
Location: Rennes

Re: locale won't set to fr_FR

Post#3 by wsteven » 23 Aug 2013, 07:43

Thanks for your answer fanthom. I tested again, what is funny is that kbd layout is indeed correct in firefox. But not with system shell, if I switch with ctrl-alt-f1 I'm back with the US layout.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4548
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: locale won't set to fr_FR

Post#4 by fanthom » 23 Aug 2013, 09:42

kiosk wizard supports setting keyboard layout for GUI only (which covers 99.99% of cases).

if you want french kbd in console then you'll have to follow this doc:
http://docs.slackware.com/slackware:localization
and pay attention to setting the console font and keymaps chapter.

i'm sure that kiosk is missing many required files so heavy tweaking may be required.
Please add [Solved] to your thread title if the solution was found.

wsteven
Black ninja
Black ninja
Posts: 40
Joined: 21 Aug 2013, 10:01
Distribution: lubuntu
Location: Rennes

Re: locale won't set to fr_FR

Post#5 by wsteven » 23 Aug 2013, 10:50

Ok then I'll pass this one :)
Thanks for the precise answer

User avatar
francois
Contributor
Contributor
Posts: 4905
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: locale won't set to fr_FR

Post#6 by francois » 24 Aug 2013, 02:13

Bonjour wsteven:

In console mode did you try to use

Code: Select all

setxkbmap fr
Maybe putting this file in rootcopy could be enough for your needs. This is a long shot as I do not work on kiosk already. But maybe this weekend, as it might be helpful for the office.
Voltaire: Le mieux est l'ennemi du bien.

wsteven
Black ninja
Black ninja
Posts: 40
Joined: 21 Aug 2013, 10:01
Distribution: lubuntu
Location: Rennes

Re: locale won't set to fr_FR

Post#7 by wsteven » 26 Aug 2013, 08:23

Code: Select all

root@porteus:~# setxkbmap fr
Cannot open display "default display"
Thanks for your concern, but no luck ;)

Post Reply