[Solved] Font (?) problems again...

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
Post Reply
User avatar
ahz
Black ninja
Black ninja
Posts: 42
Joined: 29 Dec 2010, 15:05
Location: Germany

[Solved] Font (?) problems again...

Post#1 by ahz » 12 Aug 2013, 12:35

Hello all,

over a year ago I came up with the following:

viewtopic.php?t=1081

Now I am switched to Porteus 2.1 and have the exact same problem again (indeed I tried to figure out what it is for over a week now because I saw this behaviour in the 2.1rc2 too). I tried to add additional fonts, used different versions of the reader (from 9.4.2 up to 9.5.5) but hothing helped. compat32 from the repo is installed! Any idea?

Thanks!
Last edited by ahz on 14 Aug 2013, 06:31, edited 1 time in total.

User avatar
wread
Module Guard
Module Guard
Posts: 1069
Joined: 09 Jan 2011, 18:48
Distribution: Porteus v3.2.5-kde5-64 bits
Location: Santo Domingo
Contact:

Re: Font (?) problems again...

Post#2 by wread » 13 Aug 2013, 13:23

Installing google-earth adds more fonts to your system. Try and see if it is the cure of your problem :)

Viel Glück :(
Porteus is proud of the FASTEST KDE ever made.....(take akonadi, nepomuk and soprano out and you will have a decent OS).
The Porteus Community never sleeps!

User avatar
ahz
Black ninja
Black ninja
Posts: 42
Joined: 29 Dec 2010, 15:05
Location: Germany

Re: Font (?) problems again...

Post#3 by ahz » 13 Aug 2013, 13:41

Thanks for the tiip. Unfortunally this has no effect (I used an old working 6.0.3 module). I recognized that Eclipse also has this font problem...
I guess it has something to do with missing libraries or dependency problem... really weird.

User avatar
wread
Module Guard
Module Guard
Posts: 1069
Joined: 09 Jan 2011, 18:48
Distribution: Porteus v3.2.5-kde5-64 bits
Location: Santo Domingo
Contact:

Re: Font (?) problems again...

Post#4 by wread » 13 Aug 2013, 14:02

But, does google-earth show fonts correctly?
Porteus is proud of the FASTEST KDE ever made.....(take akonadi, nepomuk and soprano out and you will have a decent OS).
The Porteus Community never sleeps!

User avatar
fanthom
Site Admin
Site Admin
Posts: 4566
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Font (?) problems again...

Post#5 by fanthom » 13 Aug 2013, 17:10

we are dealing with 32bit packages under 64bit environment so have to update 32bit caches which are not covered by default by porteus booting scripts (something to think about for next release).
please run:

Code: Select all

update-pango-querymodules-32
and this should fix the font issue.
it's probably a good idea to update other caches (update-gdk-pixbuf-loaders-32, update-gtk-immodules-32) as well.
Please add [Solved] to your thread title if the solution was found.

User avatar
ahz
Black ninja
Black ninja
Posts: 42
Joined: 29 Dec 2010, 15:05
Location: Germany

Re: Font (?) problems again...

Post#6 by ahz » 14 Aug 2013, 06:30

@fanthom: Thanks that solved the problem!

@wread: fonts were displayed correctly in Google-Earth!

xtudiux
Black ninja
Black ninja
Posts: 72
Joined: 07 Mar 2011, 06:01
Location: Philippines

Re: [Solved] Font (?) problems again...

Post#7 by xtudiux » 14 Aug 2013, 14:16

cant we have a util to add fonts easily???

User avatar
ahz
Black ninja
Black ninja
Posts: 42
Joined: 29 Dec 2010, 15:05
Location: Germany

Re: [Solved] Font (?) problems again...

Post#8 by ahz » 14 Aug 2013, 17:37

Months ago I needed font-adobe-100dpi for an application. So I searched for it with the command 'slackyd -I -g adobe-100dpi', downloaded it build a module out of it and ready. Quite easy.

User avatar
francois
Contributor
Contributor
Posts: 4946
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: [Solved] Font (?) problems again...

Post#9 by francois » 14 Aug 2013, 18:46

One easy solution encompassing many fonts provided on pkgs.org I msfonts (windows standard fonts):
http://repository.slacky.eu/slackware-1 ... ch-1sl.txz
Voltaire: Le mieux est l'ennemi du bien.

Post Reply