[SOLVED] Problem clock KDE

Get help with KDE4 specific problems
User avatar
Slaxmax
Contributor
Contributor
Posts: 403
Joined: 03 Jan 2013, 09:51
Distribution: KDE4
Location: Campinas Brazil https://goo.gl/yrxwKi

[SOLVED] Problem clock KDE

Post#1 by Slaxmax » 11 Aug 2013, 15:46

I have a problem with the clock kde. I can not switch from UTC to America / Sao Paulo. Manually editing the file (ktimezonedrc) I can change to timezone America / Sao Paulo, but the time is early. I'm trying to use the Tor Browser which requires the correct time, but always the Tor shows me that my time is wrong.
I use Porteus 2.0 64bits.

Thank you.
Last edited by Slaxmax on 20 Aug 2013, 03:57, edited 1 time in total.
“DNA is like a computer program but far, far more advanced than any software ever created.”
― Bill Gates, The Road Ahead

User avatar
francois
Contributor
Contributor
Posts: 4901
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: Problem clock KDE

Post#2 by francois » 11 Aug 2013, 21:46

The solution is:
porteus panel menu > system > porteus setting center > toolbox with screwdriver and wrench > timeconfig > set time zone.
Voltaire: Le mieux est l'ennemi du bien.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5436
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Problem clock KDE

Post#3 by brokenman » 11 Aug 2013, 21:58

The problem is that setting Sao Paulo from Porteus Settings Centre just sets the wrong time. I don't know why but is around 4 hours out. If you want to use UTC/GMT please try setting it to GMT+0 in Porteus Settings Centre and see if Tor passes the time check. If not ... what I was doing before was just manually changing the time to whatever the logs in Tor wanted to see. Do you dual boot between windows and Porteus?
How do i become super user?
Wear your underpants on the outside and put on a cape.

User avatar
Hamza
Warlord
Warlord
Posts: 1846
Joined: 28 Dec 2010, 07:41
Distribution: Porteus
Location: France

Re: Problem clock KDE

Post#4 by Hamza » 11 Aug 2013, 22:05

Or you can also set the date/time in the BIOS.
NjVFQzY2Rg==

User avatar
surio
Black ninja
Black ninja
Posts: 49
Joined: 17 Mar 2013, 08:14
Distribution: 2.1 RC2 64/32 KDE/Razor-Qt
Location: Jambudvipa
Contact:

Re: Problem clock KDE

Post#5 by surio » 12 Aug 2013, 11:18

Just wanted to add that @francois' solution is what I use, as this problem is an upstream (KDE) bug with timezone. So, this workaround fixes that.

However, as jay has pointed out, Sao Paulo seems to have issues even with this workaround. Is it time for a "patch", "within a patch"? (semi-serious?) 8) :wink:
http://porteus.org/forum/images/ranks/user.png
Do, or do not. There is no try.

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: Problem clock KDE

Post#6 by Ahau » 12 Aug 2013, 17:41

I'm going out on a limb here and guessing that your system clock is set to "UTC". The default in Slackware is "localtime" and I'm also guessing that the kde clock application by itself doesn't know to change from "localtime" to "UTC". That's what the slackware "timeconfig" script is for, and the application that francois pointed to below is a gui front end to that timeconfig script which can also generate a module to store this setting for future use. Please give that a shot and let us know if it works for you.

I've also had experiences where trying to set the correct timezone messed up the time in my BIOS clock (this happens when you set a timezone without changing the system from localtime to UTC) so you may need to verify the clock is still correct in another OS or go into your BIOS and ensure it's properly set to either your local timezone or UTC time.
Please take a look at our online documentation, here. Suggestions are welcome!

User avatar
Slaxmax
Contributor
Contributor
Posts: 403
Joined: 03 Jan 2013, 09:51
Distribution: KDE4
Location: Campinas Brazil https://goo.gl/yrxwKi

Re: Problem clock KDE (SOLVED)

Post#7 by Slaxmax » 15 Aug 2013, 23:09

Hi guys

I solved the problem. I used the command timeconfig. I set hardware clock to localtime and timezone to America/Sao Paulo. This edits the file /etc/localtime.
And I created a module for this.

Thank everyone... now the Tor Browser runs normally. :Yahoo!:
“DNA is like a computer program but far, far more advanced than any software ever created.”
― Bill Gates, The Road Ahead

User avatar
francois
Contributor
Contributor
Posts: 4901
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: Problem clock KDE

Post#8 by francois » 16 Aug 2013, 01:47

@slaxmax:
Good to know that. I had some problem also using the tor package.
Thanks.

As I am not very familiar with TOR, I would appreciate that you come and write about the way you use tor so to be able to surf on the net anonymously. It is here:
viewtopic.php?f=113&t=2485
Doing it, would make me really happy. :D
Voltaire: Le mieux est l'ennemi du bien.

User avatar
francois
Contributor
Contributor
Posts: 4901
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: [SOLVED] Problem clock KDE

Post#9 by francois » 31 Aug 2013, 12:03

timeconfig does not work at all for me. This is bizarre.
Voltaire: Le mieux est l'ennemi du bien.

User avatar
wread
Module Guard
Module Guard
Posts: 1061
Joined: 09 Jan 2011, 18:48
Distribution: Porteus v3.2.5-kde5-64 bits
Location: Santo Domingo
Contact:

Re: [SOLVED] Problem clock KDE

Post#10 by wread » 31 Aug 2013, 16:10

@francois
You must do as slaxmax wrote. This generates a binary /etc/localtime file that you must put in rootcopy (for AF mode), then you can set your clock to the local time and reboot.

When I hover the cursor over the clock in the panel it shows the local and the UTC correctly. So Tor works OK too!

With this tweak you will get it always right.

8)
Porteus is proud of the FASTEST KDE ever made.....(take akonadi, nepomuk and soprano out and you will have a decent OS).
The Porteus Community never sleeps!

User avatar
francois
Contributor
Contributor
Posts: 4901
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: [SOLVED] Problem clock KDE

Post#11 by francois » 31 Aug 2013, 16:42

Thanks, I will do that. I did not thought that it was necessary to reboot. :)
Voltaire: Le mieux est l'ennemi du bien.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4546
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: [SOLVED] Problem clock KDE

Post#12 by fanthom » 31 Aug 2013, 18:04

hi guys,

few days ago i have pushed an update which fixes bug reported in this thread:

Code: Select all

+--------------------------+
Sun Aug 18 08:21:17 UTC 2013
003-kde_fixes-20130818:
- added /etc/localtime so setting timezone trough KDE4
  systemsettings works
- added missing 'super user mode - dolphin' entry to kmenu
Please add [Solved] to your thread title if the solution was found.

User avatar
francois
Contributor
Contributor
Posts: 4901
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: [SOLVED] Problem clock KDE

Post#13 by francois » 31 Aug 2013, 18:25

So we download the iso and grab up the porteus folder to replace the older one, to get time configuration in order.

Thanks. :D
Voltaire: Le mieux est l'ennemi du bien.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4546
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: [SOLVED] Problem clock KDE

Post#14 by fanthom » 31 Aug 2013, 18:43

you need to open PSC -> click on 'Porteus updater' -> download updates -> reboot.
quite easy :)
Please add [Solved] to your thread title if the solution was found.

User avatar
francois
Contributor
Contributor
Posts: 4901
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: [SOLVED] Problem clock KDE

Post#15 by francois » 31 Aug 2013, 18:55

This is really a fine option in porteus setting centeer. As I wrote elsewhere, reading the new threads regularly, and fiddling around with the system is not enough. I think I should read-reread the faq entirely. :twisted:

Porteus is really a fine and mature distro now. :D
Voltaire: Le mieux est l'ennemi du bien.

Post Reply