Porteus Kiosk Edition v2.0.5 feedback

Share your opinion about Porteus Kiosk Edition.
deakon
White ninja
White ninja
Posts: 4
Joined: 16 Jul 2013, 18:40
Distribution: Slackware
Location: United States

Re: Porteus Kiosk Edition v2.0.5 feedback

Post#16 by deakon » 18 Jul 2013, 17:59

@fanthom
Same issue as renebrakus.
Put the intel xzm module in the module folder as you said. It just keeps reloading splash screen like it's hitting some kind of loop.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5436
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Porteus Kiosk Edition v2.0.5 feedback

Post#17 by brokenman » 18 Jul 2013, 18:23

I experienced the same thing when putting the print module in the modules folder, but assumed it was overwriting some important file and didn't have time to check it out. Firefox would just flash and close in a loop.
How do i become super user?
Wear your underpants on the outside and put on a cape.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4547
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Porteus Kiosk Edition v2.0.5 feedback

Post#18 by fanthom » 19 Jul 2013, 08:42

@renebrakus, deakon
tested my instruction and booted without problems (but in Vbox). to avoid confusion i have created testing ISOs with old and new intel driver kept in /rootcopy. please give them a shot and report which one worked (if any):
http://dl.porteus.org/i486/testing/kiosk-testing/

thanks
Please add [Solved] to your thread title if the solution was found.

deakon
White ninja
White ninja
Posts: 4
Joined: 16 Jul 2013, 18:40
Distribution: Slackware
Location: United States

Re: Porteus Kiosk Edition v2.0.5 feedback

Post#19 by deakon » 19 Jul 2013, 16:19

@fanthom
old booted fine, new hits flash screen loop 40 second vid for example @ https://www.youtube.com/watch?v=_nsUPKW72W8

this was on a dell gx260

User avatar
fanthom
Site Admin
Site Admin
Posts: 4547
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Porteus Kiosk Edition v2.0.5 feedback

Post#20 by fanthom » 19 Jul 2013, 21:38

@renebrakus, deakon
once again - thanks a lot for testing.
i would love to get the log files and check wft is wrong with last intel drivers on old hardware (or maybe it's Kiosk fault itself?) so i have a vary last request:
please dowload and install 32bit 2.1-rc2 porteus standard edition (kiosk-2.0.5 userland is based on it), could be this:
http://dl.porteus.org/i486/testing/Port ... 2-i486.iso
then copy /rootcopy content from porteus-kiosk-2.0.5-intel_new.iso to it. this way you'll be testing latest xf86-video-intel-2.21.12 driver against your hardware.

please boot to text mode -> login as root -> type 'startx'

if you get a looping failure then press ctrl+alt+backspace (or ctrl+alt+F1 to switch to virtual terminal 1 and then 'ctrl+c') to kill Xorg.
once you do it, please save/var/log/Xorg.0.log and /var/log/dmesg on the usb and then switch to other (working) OS/hardware and upload them to pastebin.com and link here for a review.

if you do not get a looping failure then please generate full 'porteus system info' report and also upload to pastebin.com so i will know what is your exac hardware specification (and maybe search google for a solution).

thanks
Please add [Solved] to your thread title if the solution was found.

deakon
White ninja
White ninja
Posts: 4
Joined: 16 Jul 2013, 18:40
Distribution: Slackware
Location: United States

Re: Porteus Kiosk Edition v2.0.5 feedback

Post#21 by deakon » 24 Jul 2013, 22:16

List my problem as solved. I took the intel_drv file from version 2.0.4 and did what you suggested putting it into 2.0.5. I'm swamped for a few days. But I'll get back to testing like you asked soon.

kir4
White ninja
White ninja
Posts: 6
Joined: 21 Jun 2013, 02:37
Distribution: msdos
Location: EmeraldCity

Re: Porteus Kiosk Edition v2.0.5 feedback

Post#22 by kir4 » 05 Aug 2013, 04:56

First of all, fanthom thanx for pxe, I was waiting for it.
But in v2.0.5 I faced out with one problem.
For kiosk v2.0.4 I used the tip "use kernel from 32bit standard edition (/boot/syslinux/vmlinuz and /porteus/base/000-kernel.xzm)" for automounting usb sticks with the file systems: fat and ntfs.
If I do the same tip for v2.0.5 and trying to boot via pxe I am getting the error:

grep: /lib/modules/3.9.4-porteus/modules.alias: No such file or directory
find: /lib/modules/3.9.4-porteus/kernel/driver/net: No such file or directory
udhcpc: iosctl 0x8933 failed: No such device

Erro: Porteus data not found.
Startup cannot continue.

I used vmlinuz from Porteus 2.1 RC2.
Pxe for Porteus Kiosk Edition 2.0.5 without changing the kernel is working fine.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4547
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Porteus Kiosk Edition v2.0.5 feedback

Post#23 by fanthom » 05 Aug 2013, 09:30

hi kir4,

if you are swapping kernel then you need to update kernel drivers inside initrdpxe.xz which is downloaded by the wizard.
Please add [Solved] to your thread title if the solution was found.

kir4
White ninja
White ninja
Posts: 6
Joined: 21 Jun 2013, 02:37
Distribution: msdos
Location: EmeraldCity

Re: Porteus Kiosk Edition v2.0.5 feedback

Post#24 by kir4 » 06 Aug 2013, 00:04

fanthom,
Thnx,
I found your docs how to customize initrdpxe - http://www.porteus.org/component/conten ... ernel.html

Post Reply